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Introduction 

 

This manual contains important safety instructions as well as instructions for configuring IHSE KVM 
products and operating them. Observe the general safety instructions (see chapter 2) and additional 
instructions in the respective chapters. 

 

Product Identification 
The model and serial number of your products are indicated on the bottom of our products. Always refer to this 
information when you need to contact your distributor or the support of IHSE GmbH. 
 

Trademarks and Trade Names 
All trademarks and trade names mentioned in this document are acknowledged to be the property of their respective 
owners. 
 

Validity of this Manual 
This manual applies to all versions named on the cover page.  
The manufacturer reserves the right to change specifications and functions described here without notice. 
Information in this manual can be changed, expanded, or deleted without notice. You can find the current version of 
the manual in the download area of our website. 
 

Copyright 
© 2025. All rights reserved. This manual may not be reproduced in any manner without the prior written consent of 
the manufacturer. 
 

Available Documentation 

Name Format Description Provision 
User Manual PDF Provides an overview of the product together with technical 

data and safety instructions. 
Contains all instructions required to configure and operate 
the products. 

Download from 
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Germany 
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fax: +49 7546-9248-48 
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1 Important Information 
1.1 Symbols for Warnings and Helpful Information 
The meaning of the symbols used for warnings and helpful information in this manual is described below: 

 WARNING 

WARNING indicates a hazardous situation which, if not avoided, could result in death or serious injury. 
 

 CAUTION 

CAUTION, used with the safety alert symbol, indicates a hazardous situation which, if not avoided, could result in 
minor or moderate injury or in a loss of data. 

 

NOTICE 

NOTICE identifies information, if not observed, endangers the functionality of your device or the security of your 
data. 

 

 This symbol indicates information about special features on the device or when using device and function 
variants. 
 

 This symbol indicates instructions for procedures recommended by the manufacturer for an effective utilization of 
the device potential. 
 

1.2 Terms and Spellings 
Uniform terms are used in this manual for better readability or easier assignment. 
The following terms are used for products and descriptions: 

Term Description 
Matrix Draco tera enterprise, Draco tera flex 

Tera Tool Software to configure, monitor and operate IHSE KVM devices 

Source Computer, graphics card (USB, video, audio, data) 

Sink Console (monitor, keyboard, mouse, video, audio, data) 

CPU Unit Encoder to connect to the source 

CON Unit Decoder to connect at the console peripherals. 

EXT Unit Logical object for representing a CPU or CON Unit in the matrix 

CPU Device Logical object for switching EXT Units of CPU Units via matrix 

CON Device Logical object for switching EXT Units of CON Units via matrix 
 
The following spellings are used for keyboard commands: 

Keyboard command Description 
key Key on the keyboard 

key + key Press keys simultaneously 

key, key Press keys successively 

2x key Press key quickly, twice in a row (like a mouse double-click) 

Number/number on the 
keyboard 

Numeric key at the top end of the alphanumeric keyboard usually used for described 
operations 

Number on the 
numerical pad 

Numeric key on the numeric pad. If the use of the numeric pad is required, it is explicitly 
described 
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The following spelling is used for, e.g., descriptions of editing files or updating firmware: 

Keyboard command Description 
Config.txt For instance, file name. 

#CFG For instance, file content. 
 
The following spellings are used for software descriptions: 

Spelling Description 
Bold print Description of terms that are used in the device firmware or the Tera Tool software 

Bold print > Bold print Tera Tool software: selection of a menu item in the working area, the menu bar, or the 
toolbar, e.g., Extras > Options 

 

Mouse button Description 
Left mouse button Primary mouse button* (default in most operating systems) 

Right mouse button Secondary mouse button* 

* Unless you have customized your mouse settings in the used operating system. 

Descriptions containing "click...", "mouse click" or "double-click" each means a click with the primary (left) mouse 
button. If the right mouse button has to be used, this is explicitly declared in the description. 

 

1.3 Intended Use 
The Tera Tool software is a comfortable software program to configure, operate, and maintain IHSE KVM devices 
(matrices, extender modules) in single matrix systems and in matrix grids, and to establish connections via IP 
Gateway. 
 

The Tera Tool software offers various functions, e.g.: 

• Advanced configuration of matrix systems and matrix grids with up to 2,032 ports (4096 ports from firmware 
V06.00) 

• Extended monitoring options 

• Switching of KVM devices 

• System update (firmware update) of matrices and connected IHSE KVM devices 

• Local backup option 

• Documentation 

• Defining macros 

• Updating IHSE KVM devices directly 

• Configuring IP Gateway connections 
 

The Tera Tool software is available as a single executable program file that does not require installation. It can be 
downloaded from the link https://www.ihse.com/software. 
 

https://www.ihse.com/software
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2 Safety Instructions 
To ensure reliable and safe long-term operation of your device, please note the following guidelines: 
 Read this user manual carefully. 
 If using the Tera Tool software, only configure and operate the device according to this user manual. Failure to 

follow the instructions described can damage the device or endanger the security of your data. 
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3 Getting Tera Tool Software 
The Tera Tool software is available as a single executable program file that does not require any installation. You can 
download it from our homepage www.ihse.com. There are two versions: one for Windows operating systems and one 
for Mac OS and Linux operating systems. For using the Tera Tool software, a computer should be used that is not 
part of the KVM system. 
 

NOTICE 

Connection to the matrix blocked 
Synchronization directories or offline directories require special attention regarding the firewall settings, e.g., 
Windows: roaming directories. If blocked by the firewall, no connection to the matrix can be established. 
 Save the Tera Tool software in a locally available directory. 

 

3.1 Requirements for Using the Tera Tool Software  
 

For Windows 

Computer/Software/Network Requirements/Recommendations 
Free memory RAM Recommendation: 1 GB 

Operating system Microsoft Windows 10, Windows 11 

Connection - Between computer and matrix with LAN cable, between computer and 
extender module with Mini-USB/USB A cable. 

 
For MacOS, Linux 

Computer/Software/Network Requirements/Recommendations 
Free memory RAM Recommendation: 1 GB 

Operating system Linux e.g. Debian, Ubuntu, Mint, openSUSE 

macOS macOS 10.14 (Mojave) or higher, Intel platform 

Specification Java Java 11 is the minimum version required. However, we recommend using 
a newer version of Java.  
(https://adoptopenjdk.net, https://github.com/ojdkbuild/ojdkbuild) 

Connection - Between computer and matrix with LAN cable, between computer and 
extender module with Mini-USB/USB A cable. 

 

 Contact your system administrator concerning JRE and network connection. 
 
  

http://www.ihse.com/
https://adoptopenjdk.net/
https://github.com/ojdkbuild/ojdkbuild
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3.1.1 Setting up Network and Firewall Releases 
Releasing Network Ports 
The following ports are used by the matrix depending on the configuration and have to be released at the security 
gateway if necessary. The ports will only have to be released if you want to use the respective function. 

Function Port 
FTP 21/TCP 

DNS 53 

SNTP 123/UDP 

SNMP 161/162, both UDP 

LDAP 389 (636 for SSL) 

Syslog 514/UDP 

API 5555/TCP (5565 for SSL) 

Broadcast 5556/UDP (5566 for SSL) 

Matrix Grid 5557/TCP (5567 for SSL) 
 

Releasing Java Application in the Firewall 
The Java application (file javaw.exe) has to be released in the firewall settings for port 5555 to use the Tera Tool 
software. Contact your administrator to configure the firewall settings accordingly. 
Using the Tera Tool software with integrated Java Runtime, a request of the operating system could appear, e.g., if 
opening the Device Finder. 
 

3.1.2 Connecting the Computer with installed Tera Tool Software to a Matrix 
NOTICE 

For a connection between the computer and matrix via switch or hub, parallelly assembled network cables are 
required. 
 Only use a network connection between computer and the matrix that is not primarily used for streaming audio 

or video data. We strongly recommend using a computer that is not part of the KVM system (e.g., a laptop). 
 
 Connect the network cable to the RJ45 port of the computer and the controller board of the matrix. 
 

3.1.3 Connecting the Computer with installed Tera Tool Software to an Extender Module 
 Connect a Mini-USB/USB type A cable to the Mini-USB port of the extender module and an USB A port of the 

computer. 
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3.1.4 Starting the Tera Tool Software 
1. Download one of the Tera Tool software zip files from our website and store it on your computer. 
2. Unpack the zip file (unzip). 
3. Open the unzipped folder “Tera Tool”. 
4. Double-click the entry TeraTool. 

The Tera Tool software starts in offline mode. 

 

 

Fig. 1 Landing page in offline mode 
 
There are two options to connect to a device e.g., matrix, Draco MV, SNMP board via network connection. 

• Via known IP address 

• Via Device Finder 
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3.1.5 Connecting to the Matrix with known IP Address 
 At least power user rights are required, and the function External Configuration & Control in the network menu 

has to be enabled (default setting). 
 

 Up to 16 connections between the matrix and the Tera Tool software can be established at the same time due to 
a limitation of available sockets. 
 
1. Run the Tera Tool software. 
2. Click Connect in the tool bar. 

A login dialog appears. 

 
Fig. 2 Dialog Connect  
 

3. Enter the IP address according to the network configuration of the matrix. Use the OSD to view the network 
configuration. 
By default, the IP address of the matrix is 192.168.100.99 and DHCP is deactivated. 

4. Enter the username and password of an administrator. 
By default, the username is admin, and the password is admin. 

5. Click Login to confirm your entries. 
 

 The data must be entered each time the network connection is re-established. Alternatively, the data can be 
entered and stored in the Tera Tool software under Extras > Options (see section 4.1, page 16). 
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3.1.6 Connecting to the Matrix via Device Finder 
 At least power user rights are required, and the function External Configuration & Control in the network menu 

has to be enabled (default setting). 
 

 Up to 16 connections between the matrix and the Tera Tool software can be established at the same time due to 
a limitation of available sockets. 
 
The Device Finder offers the possibility to find all matrices, SNMP boards and MV42 that are in the same subnet. 
This is useful, e.g., if the IP address of a specific matrix is unknown and should be accessed via IP. 
 

1. Click Device Finder in the tool bar. 
A window opens. 

 

 

Fig. 3 Menu Device Finder  
 
The following device information is shown in the Device Finder: 

Information Description 
Broadcast/Multicast Search parameters for finding devices. 

Search via broadcast: 255.255.255.255 (default). 
Input for search within a multicast group: multicast address (section 6.5.7, page 50). 

Device Name of the device 

Name Name of the active configuration 

IP Address Current IP address of the device 

MAC Address MAC address of the device 

Master Type of the device 
 
 

2. For searching within a multicast group, enter the multicast address. By default, the search is set via broadcast: 
255.255.255.255. 

3. Click Connect in the last column of the Device Finder to establish a direct connection to the respective device 
within the same subnet or the button Connect in the bottom right-hand corner or press Enter. 

4. Enter the username and password of the administrator. 
By default, the username is admin, and the password of the administrator is admin. 

5. Click Login to confirm your entries. 
The online mode is started. 

6. Click the button Close to close the Device Finder window. 
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4 Basic Setting up of Tera Tool Software  
The settings of the Tera Tool software can be customized and optimized to support the configuration of the matrix 
and to avoid the repetition of data to be entered. The look of the software can also be customized. The settings can 
be changed in offline mode. 

 To activate changes in the Options menu, the Tera Tool software must be closed and restarted. 
 

 

4.1 Default Settings for Connection and Directories 
To avoid the repetition of data to be entered in the Tera Tool software, this data can be saved in the default settings. 
1. Select Extras > Options in the menu bar. 

The Options menu opens and shows the Default Settings tab. 

 
Fig. 4 Menu Extras - Options - Default Settings 
 

The following parameters can be configured: 

Option Description 
IP/Hostname Default IP address or host name of the matrix for establishing a connection. 

User Default username for establishing a connection. 

Configuration 
Directory 

Default directory for storing configuration files. 

Firmware Directory Default directory for loading and storing firmware files. 

Status Directory Default directory for storing status files. 

Import/Export 
Directory 

Default directory for import and export files. 

Presets Directory Default directory for storing presets. 
 

2. Enter the appropriate data. 
3. Click Ok to confirm the settings. 
4. Close the Tera Tool software and restart it. 
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4.2 Setting Font Size, Tooltip, and Theme 
1. Select Extras > Options in the menu bar and open the Style tab. 

 
Fig. 5 Menu Extras - Options - Style 
 

2. Select the desired font size (Normal or Large). 
3. Tick the Show Toolbar Button Text checkbox to display a tooltip when hovering over an item in the toolbar. 
4. Select the color theme for the Tera Tool software (Default (Dark Gray), Light Gray or Dark). The figures in this 

manual were made with the setting Light Gray.  
5. Click Ok to confirm the changes. 
6. Close the Tera Tool software and restart it. 
 

4.3 Setting the Language 
The language within the Tera Tool software is set in this menu. The charset must match the selected language to 
ensure correct representation.  
1. Select Extras > Options in the menu bar and open the Language tab. 
2. Select the desired language within the Tera Tool software and the corresponding charset. 
3. Click Ok to confirm the changes. 
4. Close the software and restart it. 
 

 If using Linux-based matrix systems, it is possible to enter Chinese characters. Therefore, a respective firmware 
package has to be installed, and the Chinese Encoding has to be enabled in the system settings. Please contact the 
manufacturer’s technical support for further information. 
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4.4 Changing the Background of Landing Page 
1. Copy a png image named “Background” into the Tera Tool folder. 
2. Start the Tera Tool software. Upon starting, the software checks if a png image named Background is present 

and displays it in full screen. 

 
Fig. 6 Changed Background  
 

3. Instead of a whole background, you can display a logo in the center of the window by copying a png image 
named “Logo” into the Tera Tool folder. The height of the logo is half the height of the area. 

 
Fig. 7 Displayed logo  

 

 When both png images (Background and Logo) are present in the Tera Tool folder, the software takes the 
background image. 
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4.5 Setting Autostart of the Device Finder and further Options 
Additional options for the Tera Tool software can be enabled in this menu. 

 
Fig. 8 Menu Extras - Options - Miscellaneous  
 

The following options can be enabled: 

Option Description 
Device Finder on startup Starts the Device Finder automatically when starting the Tera Tool software. 

Name adoption (EXT Unit <--> 
Device) 

Applies the entered name for a CON/CPU Device also to the EXT Unit and vice 
versa. 

Show Super Grid View Shows the Super Grid option in the task area. 

Show power backplane and fan 
firmware 

Shows the firmware of the fans and the power backplane in the menu Status & 
Updates > Status - Matrix Firmware. 

Enable single I/O board update on 
compact matrix 

Option available only for Draco tera flex. 

Enable splitted firmware update 
(matrix and extender) for master 
and sub part of the 576 matrix 

Option available only for Draco tera enterprise 576. 

Receive data changes by event When changes occur while Tera Tool is open (e.g. switching), the display is 
updated immediately (no need to click the button Reload in the toolbar). 

Enable “Save EXT Units Settings” 
Option for Save Status 

Enables this option in the Save Status dialog. 

 
To start the Device Finder automatically when starting the Tera Tool software, proceed as follows: 
1. Select Extras > Options in the menu bar and open the Miscellaneous tab. 
2. Tick the Device Finder on startup checkbox. 
3. Click Ok to confirm the changes. 
4. Close the Tera Tool software and restart it. 

After restarting the software, the Device Finder appears. 
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5 User Interface and Control Options 
5.1 Menu Structure 

 The main user interface elements for options and functions of the Tera Tool software are described in this 
chapter. This allows us to keep the user manual clear. Further options and functions are explicitly declared in the 
respective chapters. 
 

 
The menu structure of the Tera Tool software is subdivided into several sections: 

 

1 
2 
3 
 
4 
 
 
5 
 
 
 
6 
 
 
 
 
 
 
 

7  

 
 
 

8 
 
 
9 
 
 
 
 
 
 
 
 

10 

Fig. 9 Menu structure (Example 1) 
 

1 Menu bar 
2 Toolbar 
3 Tab bar (shows connections or configurations) 
4 Task area 
5 Task menu 
6 Task menu item 

7 Status bar (shows config version, activated Edit 
Mode and online mode) 

8 Tabs (for additional sub menus) 
9 Working area  
10 Buttons 

 
 

The following control elements are included in the menus: 

Designation Element Description 
Checkbox  Function is not active, disabled by default or by mouse click. 

 Function is active, enabled by default or by mouse click. 

Radio button  Option is not active, disabled by default or by mouse click. 

 Option is active, enabled by default or by mouse click. 

Drop-down menu  A selection list is opened by mouse click on the arrow. 

 The value (+/-) is set by mouse click on the up/down arrow. 
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The following actions are available in most of the menus: 

Button Function 
Apply Confirm changes (temporary storage of the active configuration in the volatile memory of 

the matrix). 

Cancel Reject changes. 
 
Based on the following figure, basic functions are described that are available in the working area of several menus 
for individual tabs. Further functions are explained separately in the respective chapters. 

 

 

Fig. 10 Menu structure (Example 2)  
 

1 Assigning/Copying settings 
2 Assigning/Removing elements* to/from an assignment 

or list 
3 Creating/Deleting elements* 

4 Moving elements* up/down 
5 Field for filter function 
6 Tabs (for additional functions) 

 
 

 * Element is a placeholder and stands for EXT Units, CON/CPU Devices, Extender Modules, Users, or Favorites 
(see respective configuration sections). 
 

 
These buttons for main functions are available in the lower part of the working area of several menus. 

Button Function 
Assign Settings to… Assign settings from the highlighted element to one or more other element(s). 

Copy Settings from… Copy settings from another element to the highlighted element. 

New Element Create a new element. 

Delete Element* Delete an element. 
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The following functions are available in most of the tabs or dialogs to assign elements. 

Button Function 

 Assign the selected element to an element. 

 Assign all available elements to an element. 

 Remove the selected element from an element. 

 Remove all elements from an element. 

 Change the index number of an element downwards. 

 Change the index number of an element upwards. 

 Change the index number of an element to first position. 

 Change the index number of an element to last position. 
 

Keyboard Command Function 
+ Change the index number of elements upwards. 

- Change the index number of elements downwards. 
 

5.1.1 Access Rights Menus 
In menus to assign access, available keyboard commands are displayed in the lower area of the tab menu. 

 

 
 
 
 
 
 
 
 
 
 

1 
 

Fig. 11 Menu structure (Example 3)  
 

1 Keyboard commands  
 
The following keyboard commands (always lower-case letter) are available in access assignment tabs. 

Keyboard command Function 
f  Add highlighted element to Full Access list 

v Add highlighted element to Video Access list 

n Add highlighted element to No Access list 
 
A context menu is available when clicking with the right mouse button on an element: 

• Assign Full Access rights 

• Assign Video Access rights 

• Assign No Access rights 
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5.1.2 Ports Overview and Information and Options Panel 
The information and options panel displays information and offers options for the matrix system, e.g., for the Matrix 
Status, Routing Information, I/O Port Color Coding, I/O Port Symbols, MSC and Redundancy. 

 

 

Fig. 12 Menu structure (Example 4)  
 

1 Information and options panel 
2 Display of ports at I/O boards  
3 Display of ports at the controller (CPU) board  

 

 

5.1.2.1 Colors for Controller Board Network Ports 

Network port color Description 

 
Green Port is connected. 

 
Red Port is not connected or not available. 

 
5.1.2.2 Color Coding for I/O Board Ports 
Port color Description 

 Grey Port not connected. 

 Yellow Port with video connection. 

 Green Port with KVM connection. 

 Red Faulty port. 

 Blue with green 
dots 

Port connected to another matrix via grid line. Grind lines are used (CON Device switched 
to CPU Device). 

 Blue with gray 
dots 

Port connected to another matrix via grid line. Grind lines are not used (CON Device not 
switched to CPU Device). 
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Port color Description 

 4 blue static 
squares 

Port is selected. All other ports are transparent, except those connected to the currently 
selected port. 

 Red cross CON Device to be connected does not have access rights to the respective CPU Device at 
this port. 

 Red frame Fixed port (e.g., for USB 2.0 connections). 

 
 
5.1.2.3 Color Coding for I/O Board Ports with Multi-Screen Control (MSC) 
Port color Description 

 Blue CON Device with connected keyboard and mouse in the MSC setting. 

 Light blue CON Device without connected keyboard and mouse in the MSC setting. 

 Blue frame Frame around the CON Units that are contained in an MSC setting (Screen Cluster). 

 Rose Not available, e.g., if one EXT Unit is set on position 2 and all other EXT Units are set on 
position 1 in the EXT Unit assignment. 

 Red Invalid if link 1 and link 2 of a redundant extender module are connected within the same 
block. 

 Temporarily off Display switched off. 

 
 
5.1.2.4 Symbols for I/O Board Ports 
Symbol Description 

 
Port is connected to a CPU Unit. 

 
Port is connected to a CPU Unit that is switched to a CON Unit in Private Mode. 

 
Port is connected to a CON Unit. 

 
Port is connected to a CON Unit with Shared Access to a CPU Unit. 

 
Port is connected to a CON Unit that is connected to a CPU Unit in Private Mode. 

 
Port is connected to a USB 2.0 CPU Unit. 

 
Port is connected to a USB 2.0 CON Unit. 

 
Port is configured as Cascaded CON port for cascading of matrices. 

 
Port is configured as Cascaded CPU port for cascading of matrices. 

 
UNI port is configured as CON port to connect USB 3.0 CON extender modules, for example. 

 
UNI port is configured as CPU port to connect USB 3.0 CPU extender modules, for example. 

 
Universal port without further specification. 

 
IP port but access is denied e.g., because license for IP CON software client is missing. 

 
Shows which channel is used. 
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Symbol Description 

 
A user is logged in at this CON Unit. 

 
No device is connected to this port. 

 
 

5.1.2.5 Redundancy Symbols for I/O Board Ports 
Symbol Description 

  Redundant extender module connected with interconnection port 1. 

  Redundant extender module connected with interconnection port 2. 

 Light green label Active link, switched to this interconnection port. 
 
5.1.2.6 Information Panel on the right side of the working area 
 Click a port with the left mouse button to show the EXT Unit and CPU/CON Device information of the currently 

selected port in the panel on the right side of the working area. 
 

The following information is available: 

Port 

Field Description 
EXT Unit Name Name of the Ext Unit connected to the selected port. 

EXT Unit Type Type of the selected Ext Unit. 

Port Number of the selected port, in brackets: number of connected port. 

Slot (global) Slot of I/O board of the matrix. 
 

Device 

Field Description 
Device ID ID number of the associated CON Device or CPU Device. 

Device Name Name of connected CON Device or CPU Device. 

Extender 1…8 Up to 8 assigned EXT Units per CPU/CON Device. 
 

Connections 

Field Description 
Connections List of assigned connections to selected port (Full Access or Video Access) 

 
5.1.2.7 Port’s Context Menu 
 Click a port with the right mouse button to open the context menu with additional functions for the currently 

selected port. 
 

The following context functions are available: 

Field Description 
Open EXT Unit Open the menu for definition of the currently selected EXT Unit. 

Open Device Open the menu for the definition of the currently selected CON/CPU Device. 

Extended Switch Open the menu for execution of switching operations. 

Disconnect Disconnect CON Device and CPU Device. 

Restart Extender Module Restart the extender module. 
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Field Description 
Locate Extender Module Set a time span for the LEDs at the extender module to flash. 

Restart I/O Board Restart the I/O board. 

Factory Reset I/O Board Reset the I/O board to factory settings. 
 
5.1.2.8 Information for Operating and for Support Functions 
The operation of the Tera Tool software is intuitive and corresponds to the user interface of common operating 
systems. 
The Tera Tool software contains its own support function. The integrated help texts in the working area of the Tera 
Tool software can be activated or deactivated by ticking the checkbox in the upper right corner. Auxiliary names 
(tooltips) for the menu items can be activated under Extras > Options on the Style tab. 
 

 

5.2 Description of Toolbar 
Some functions are only available if a connection to the matrix has been established (online mode). The respective 
functions are colored if available. 

 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 

 

Fig. 13 Toolbar  
 

1 Load a locally saved configuration 
2 Save a configuration locally 
3 Reload the current configuration 
4 Connect to the matrix 
5 Disconnect from the matrix 
6 Activate/deactivate the edit mode 
7 Save the active configuration on the matrix 

 

8 Download and show a predefined configuration 
saved on the matrix 

9 Upload a predefined configuration on the matrix 
10 Monitoring 
11 Flash update for single devices 
12 Overview of devices in the subnet 
13 System check 
14 Save status locally 
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5.3 Mouse and Keyboard Control 
The following mouse commands are selectable for menu functions: 

Mouse command Function 
Left mouse button Select menu, select function, open drop-down menus, enter input field, activate/deactivate 

option checkboxes, etc. 

Double-click left mouse 
button 

Open function specific selection menus. 

Right mouse button Open context specific selection menus. 
 
The following keyboard commands are available for the navigation and configuration within the menus: 

Keyboard command Function 
Left Arrow Cursor to the left 

Right Arrow Cursor to the right 

Up Arrow Line up 

Down Arrow Line down 

Page Up In input or status menus with more than one page: previous page 

Page Down In input or status menus with more than one page: next page 

Tab In input menus: next field 

Left Shift + Tab In input menus: previous field 

Spacebar • Switch in selection fields between two conditions (check mark or not). 
• Open already marked fields with editing or selecting possibility. 

Enter • Select menu item 
• In menus: save data 

Ctrl + Tab • Leave tables 
• Jump from tables into the next field 

Ctrl + Left Shift + Tab • Leave tables 
• Jump from tables into the previous field 

 

 Several functions within the menus in the menu bar can be executed with the provided keyboard commands (e.g., 
press Ctrl + s to execute Save) that are listed to the right of the respective menu item. 
 

5.4 Reload Options 
The information about the current configuration of the matrix, shown in the Tera Tool software, can be reloaded in 
different ways: 

• Press F5 on the used keyboard. 

• Click Reload in the toolbar. 

• Click Edit >Reload in the drop-down menu of the menu bar. 
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5.5 Context Function 
The Tera Tool software offers several context functions that support user-friendly and effective operation. The 
context functions are described in the respective chapters. 

Context function Action Result 
Execute context 
function 

Click with the right mouse button on a field. A context menu opens and displays 
functions available for the corresponding 
filed (if existing). 

Click with the left mouse button on the 
desired function. 

The desired function is executed. 

 

5.6 Filter Function 
Lists and tables in the Tera Tool software offer a filter function that supports a fast and smooth search. The filter entry 
field is located above the header. An active filter is indicated by a green or red filter symbol in the filter entry field. 
 

 
 1 2 

 

Fig. 14 Filter function 
 

1 Filter entry field 
2 Filter symbol (grey: filter is not active 

 green: filter is active, results were found and are displayed. 
 red: filter is active, no results were found) 

 

 

Filter function Action Result 
Activate the filter Click with the left mouse button in the filter 

entry field above the header to search in all 
columns under the filter entry field. 
Write the word or part of a word to be 
filtered. 
It is possible to search for two words with 
space in between (the space bar acts as 
AND link). 

• The filter results are shown immediately, 
and the filter symbol is green. 

• When the filter symbol is red, no search 
results were found. 

Clear the filter Delete the text in the filter entry field. • The list or table shows the complete 
content. 

• The filter symbol is displayed in gray. 
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5.7 Sort Function 
Lists and tables in the Tera Tool software offer a sorting function for fast and smooth search. An active filter is 
indicated by an arrow in the header. 

Sort Function via Mouse Click 

Sort function Action Result 
Ascending sort Click with the left mouse button once on the 

header of the column to be sorted. 
• The column is sorted in ascending order. 
• The sorting of status is indicated by an 

arrow pointing upwards. 

Descending sort Click with the left mouse button twice on the 
header of the column to be sorted. 

• The column is sorted in descending 
order. 

• The sorting is displayed by an arrow that 
points downwards. 

Cancel sort Click with the left mouse button once or 
twice on the head of the sorted column. 

The arrow disappears. 
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5.8 Report Function 
The Tera Tool software is equipped with a report function that shows the current switching status and all relevant 
parts of the matrix configuration in a PDF file. 

 The report function can be used in both online and offline mode of the Tera Tool software. 
 
1. Select File > Report... in the menu bar. 

A selection dialog appears. 

 
Fig. 15 Dialog File - Report - Define Content 
 

2. Select contents that should be included in the report (Matrix View, EXT Units, CPU Devices, CON Devices, 
Users, etc.). 

3. Click Next > to confirm the selection. 

 

 

Fig. 16 Dialog File - Report - Save Report 
 

4. Go to the preferred location for storage of the report. 
5. Click Finish to confirm the report. The report will be created as a PDF file. 
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6 Configuration of a Matrix via Tera Tool Software 

 CAUTION 

Possible loss of configuration changes 
By clicking Apply, changes are applied to the active configuration and saved in the volatile memory of the matrix. 
In the event of a sudden power failure, these changes are lost. To save changes permanently: 
save the configuration changes into the active configuration (Remote Save, see section 6.4, page 35), or perform a 
restart (see section 7.2.1, page 183). 

 

NOTICE 

A change in system-relevant parameters (e.g., change in the IP address) is immediately displayed in the Tera Tool 
software. To initialize system-relevant configuration changes on the matrix, the controller board must be restarted. 
All connections remain active but switching is not possible during the restart.  

 

 After changing the configuration of the system, we recommend that you de-register the primary controller board 
and to boot the secondary controller board until the boot process is finished. 
 

 Configurations can be saved as a file that can be stored independently of the matrix. 
We recommend saving a configuration every time the configuration has been changed. Use the Save as… function 
(see section 6.4, page 35) for that. 
 

6.1 Configuring in Online Mode 
Configurations and system settings can be edited via Tera Tool software in online mode with an active connection 
between matrix and software. Hereby, the following steps are necessary: 
 

1. Click Connect to connect the Tera Tool software with the matrix. 
After the connection is established, the current configuration of the matrix is shown.  

2. Click Activate Edit Mode in the toolbar. 
The edit mode is active. A symbol is shown in the status bar. 

3. Make any edits in the configuration and system settings (see following chapters). 
4. Click Apply to confirm the changes. 

The changes are applied immediately to the current configuration running in the volatile memory of the matrix. 
5. Click Remote Save to save the current settings into the active configuration of the matrix. 
6. Click Deactivate Edit Mode in the toolbar. 
7. Click Save Status to save the matrix status (backup file). 
8. Optionally: restart the system (depending on the settings made). 
 

 It is often sufficient to restart only the controller board instead of the matrix. This has the advantage that all 
switched connections remain active, only switching is not possible during the restart. 
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6.2 Creating/Changing Configurations in Offline Mode 
Configuration and system settings via Tera Tool software can be created/changed in offline mode without a direct 
connection to the matrix. Afterwards, the configuration must be uploaded to the matrix. 
 

Creating a New Configuration in Offline Mode 
1. Start Tera Tool software. Do not connect to any device. 
2. Click File > New in the menu line. 

 

 

Fig. 17 Dialog New configuration 
 

3. Select the version and the charset if necessary. Click Ok. The offline menu appears with all parameters that can 
be set offline (see next figure). 

Changing a locally stored Configuration in Offline Mode 
1. Click File > Open in the menu line or the symbol Open in the toolbar. 
2. Navigate to the storage location and select the desired configuration file (*.dtc). Click Open. 

The offline menu appears with all parameters that can be set in offline mode. 

 

 

Fig. 18 Menu Tera Tool in Offline Mode 
 

3. Configure the parameters as you see fit. 
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4. Click File > Save as … in the menu line and save the new configuration under a suitable name preferably in the 
directory that is stated in the Options menu for configurations (see section 6.5.1, page 40). 
or 

5. Click the symbol Save in the toolbar to save the changes to the existing configuration. 
 

Uploading a Configuration to the Matrix 
1. Click Connect to connect the Tera Tool software with the matrix. 

After the connection is established, the current configuration of the matrix is shown. 
2. Click Upload in the toolbar. The Upload wizard opens.  

 

 

Fig. 19 Dialog Upload - Connect 
 

3. Enter username and password and click the button Next >. 

 

 

Fig. 20 Dialog Upload - Select a slot 
 

4. Select the slot where you want to store the configuration. The existing configuration in this slot will be overwritten. 
5. Tick Activate configuration after upload to activate the uploaded configuration immediately. The matrix will be 

restarted. 
 

 We recommend saving the status as a backup file after uploading the matrix configuration settings. 
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6.3 Saving Options 
 To avoid loss of configuration changes in the event of a sudden power failure, we strongly recommend that you 

save the configuration changes into the active configuration via Remote Save. 
 
 Save Save as Remote save Save Status 
Saving location Local memory Local memory Permanently in the 

matrix memory 
Local memory 

File extension .dtc .dtc Internally .zip 

Target Configuration file for 
offline changes and 
as backup. Can be 
uploaded and 
activated to all tera 
matrices. 

Configuration file for 
offline changes and 
as backup. Can be 
uploaded and 
activated to all tera 
matrices. 

Saves online 
changes to non-
volatile memory. 

Snapshot of the 
whole system for 
technical analysis, 
documentation, 
configuration backup 
and offline changes. 

Saved configuration Current configuration 
as dtc file. 

Copy of current 
configuration as dtc 
file. 

Current 
configuration. 

Current configuration 
as config.dtc, 
and configurations 
stored in the slots 
Default, or File#1 to 
File#8 as 
default.dtc, or 
config01.dtc to 
config08.dtc. 

Type of matrix --- --- --- X 

Current matrix and 
extender module 
firmware 

--- --- --- X 

System settings 
(System, Access, 
Switch, Network. Date 
and Time, Matrix Grid) 

X X X X 

EXT Units, 
CPU Devices, 
CON Devices 

X X X X 

Assignments of Virtual 
CPU Devices and 
Virtual CON Devices 

X X X X 

Users & Group settings 
(access rights, 
favorites, macros) 

X X X X 

Stored configurations --- --- --- X 

Connected ports X X X X 

Switching status with 
access rights (Control -
Extended Switching) 

X X X X 

View (Matrix, Port, Grid, 
Control) --- --- --- X 

--- not available 
X available 
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6.4 Saving and Activating Configurations 
NOTICE 

By default, the last configuration that has been saved in the permanent matrix memory will be restored after the 
restart of the matrix. 

 

First starting the matrix, the factory configuration will be copied into the current configuration. There are three ways to 
save configuration changes: 

• Save the current configuration permanently in the matrix memory (Remote Save) 

• Save configuration on a local memory (Save or Save as) 

• Save the configuration in one of 9 predefined storage slots (Upload). These storage slots are all offline and not in 
use during normal operation.  
 

6.4.1 Saving the Current Configuration to the Matrix 
 By default, the last configuration that has been saved in this way will be restored after a restart of the matrix. 

 
To save the current configuration permanently in the matrix memory, proceed as follows: 
1. Click Remote Save in the toolbar. 

A query to save the configuration appears. 
2. Click Yes to confirm the saving. 

The previously active configuration is overwritten and saved in the permanent memory of the matrix. 

 

 

Fig. 21 Dialog Save Remote Changes 
 

6.4.2 Saving A Configuration Externally (Backup) 
Configurations can be saved as a file on any computer (not on the matrix). The configuration can then be changed in 
offline mode (independently of the live operation) or serve as backup (for the content, see section 6.3, page 34). 
 

To save a configuration file externally, proceed as follows: 
1. Click File > Save or File > Save As in the menu bar. 
2. Select the directory of the configuration on your storage medium where the configuration is to be saved. 
3. Enter a name for the configuration and click Save. 

 Configurations are always saved with the file extension *.dtc. 
 

Externally saved configuration files can be opened in the Tera Tool software (see next section), be uploaded to the 
matrix (see section 6.4.4, page 37) and be used as active configuration (see section 6.4.5, page 38) in the system. 
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6.4.3 Opening an Externally Saved Configuration 
1. Click Open… in the toolbar. 
2. Go to the location of the configuration file to be opened. 
3. Click the configuration file to be opened. 
4. Click Open to open the configuration file. 

 

 

Fig. 22 Dialog Open 
 

 The configuration can also be opened via drag & drop. To do this, click on the configuration file, hold down the left 
mouse button and drag the configuration file into the Tera Tool software. 
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6.4.4 Uploading an External Configuration to the Matrix 
Using the function Upload, the configuration can be saved within nine storage locations (slots) in the matrix (Default, 
File#1 to File#8). 
The configuration stored in the Default slot can be automatically loaded with each start of the matrix (for activation of 
this function see section 6.5.1, page 40). 
1. Click Upload in the toolbar. 

An access window appears. 

 

 

Fig. 23 Dialog Upload - Connect 
 

2. Enter the IP address of the matrix. 
3. Enter the username and password of an administrator. Click Next >. 

 

 

Fig. 24 Dialog Upload - Select Configuration Slot 
 

4. Under Select Configuration Slot, select the storage slot for the configuration (Default or config01 to config08). 
5. Option: to activate the uploaded configuration immediately, tick the Activate configuration after upload 

checkbox. 

NOTICE 

If you tick the Activate configuration after upload checkbox, the matrix will be restarted immediately after the 
upload process has been completed. The restart of the matrix may take several minutes, and the matrix is not 
available during the restart. 

 

6. Click Finish to save the configuration to the selected storage location. A message appears to inform about 
successful upload. 
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6.4.5 Activating a Configuration 
Previously saved configurations are loaded in this menu. In Active Configuration, the name and detailed 
information of the currently loaded configuration is displayed. The selection of the configuration to be loaded can be 
made between nine customizable configurations. 

NOTICE 

Activating a configuration will disconnect and restart the matrix. The selected configuration is loaded on restart and 
is shown in the menu as active configuration under Active Configuration in the working area. The previously 
active configuration is overwritten. 
The restart of the matrix may take several minutes, and the matrix is not available during the restart. 
 If the IP address of the matrix is different to the prior configuration, you have to reconnect the Tera Tool 

software. 
 
To activate an uploaded configuration, proceed as follows: 
1. Click Status & Updates > Activate Configuration during online-mode in the task area. 
2. Select the configuration to be activated. 

 

 

Fig. 25 Menu Status & Updates - Activate Configuration  
 

3. Click Activate to activate the selected configuration. 
A query to restart the matrix appears. 

 

 

Fig. 26 Dialog Status & Updates - Activate Configuration 
 

4. Click Yes to confirm the activation of the selected configuration. 
The matrix is restarted. The selected configuration is loaded upon restarting and is shown in the menu as active 
configuration under Active Configuration in the working area. The previously active configuration is overwritten. 
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6.4.6 Downloading a Configuration from the Matrix 
Configurations saved in the matrix can be downloaded for offline editing in this menu. 
To download a configuration from the matrix, proceed as follows: 
1. Click Download in the toolbar. 

An access window appears. 

 

 

Fig. 27 Dialog Download - Connect  
 

2. Enter the IP address of the matrix. 
3. Enter the username and password of an administrator. 
4. Click Next >. 
5. Under Select Configuration, select the storage location of the desired configuration (default or config01 to 

config08). 
6. Click Finish to download the desired configuration to the Tera Tool software. 

 

 

Fig. 28 Dialog Download - Select Configuration  
 

The downloaded configuration is automatically opened and displayed in the Tera Tool software. 
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6.5 System Settings 
 The configuration of system settings can only be done by users with administrator rights. 

. 

6.5.1 General Settings for the System Configuration 
1. Click System Settings > System in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 29 Menu System Settings - System - General  
 

The following parameters can be configured: 

System 

Field Entry Description 
Device Text Device name of the matrix (default: SWITCH_01). 

The device name is used as the host name in the network. 

Name Text Name of the configuration that is used to save the current settings (default: 
Standard). 

Info Text Additional text to describe the configuration if required (default: Factory 
settings). We recommend entering the configuration date. 

Sub Matrix Activated Defines the matrix as sub matrix. 
Note: If the matrix is defined as a sub matrix in the OSD, the user will lose 
control. Control can be recovered by using the keyboard command 
Hot Key, s, o. The OSD for the matrix that has been defined as sub matrix 
will be reopened. This works only in a cascaded system of two matrices but 
not in a grid system. 

Deactivated Function not active (default). 



Draco Tera Tool Configuration of a Matrix via Tera Tool Software 

41 

Field Entry Description 
Load Default Activated Starts the matrix after a restart or a switch-on with the configuration which 

is stored in the “Default” configuration slot. 

Deactivated Starts the matrix after a restart or a switch-on with the last saved 
configuration (default). 

Auto Save Activated Saves the current configuration of the matrix in the flash memory 
periodically. 
Note: During the saving process, the matrix will not react to commands. 
Savings take place every 600 seconds if changes of configuration or 
switching operations have been executed in the meantime. 

Deactivated Function not active (default) 

Redundancy Activated Switches automatically to the second link of a connected redundant 
CON Unit when losing the primary link of a CPU Unit (default). 
Note: This function will have to be activated: 
• for a single matrix when using redundant link connections. 
• for both matrices in a fully redundant setup. 

Deactivated Function not active 

Primary Preferred Activated Prefers the primary interconnection port Link 1 for redundant 
CON/CPU Units (default). 
We recommend that you activate this function to ensure the connection is 
switched back to Link 1 if, e.g., an interconnection cable at interconnection 
port 1 was temporarily disconnected. 

Deactivated Function not active 

Invalid I/O Boards Activated Keeps I/O boards with incorrect or invalid firmware online in the matrix. 
Note: To keep an I/O board with wrong or damaged firmware online in the 
matrix, the maintenance mode of the matrix will be activated. 

Deactivated Shuts down I/O boards with incorrect or invalid firmware automatically 
(default). 

COM Echo Activated Sends all switching commands performed in the matrix as an echo via 
serial interface. 
Note: This function should be enabled when using a media controller via 
serial interface. 

Deactivated Function not active (default) 

LAN Echo Activated Sends all switching commands performed in the matrix as an echo via LAN 
connection. 
• Note: This function should be enabled when using a media controller via 

LAN connection or when stacking two or more matrices. 

Deactivated Function not active (default) 

Old Echo Activated Translates current switching command (implemented since V02.09) 
internally into the old, already known switching commands and sends them 
as echo. 

Deactivated Function not active (default) 
 
3. Change the desired settings. 
4. Click Apply to confirm your entries. 
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6.5.2 Enabling the Automatic Creation of Real CPU and CON Devices 
On all matrices, switching extender modules follows the same principle: 

• A CON/CPU Unit (hardware) is represented by an EXT Unit (logical object) in the matrix. The EXT Unit is 
automatically created when the extender module is connected to the matrix for the first time. 

• This EXT Unit needs to be assigned to a CON or CPU Device/Real CON or CPU Device (logical object). 

• The actual switching takes place at the level of the CPU and CON Devices. 

• To facilitate switching of groups of CON or CPU Devices (logical objects), virtual CON or CPU Devices (logical 
objects) can be created. 

 

 

 

Fig. 30 Matrix system with connected hardware and logical objects  
 

The creation of Real CON or CPU Devices and the assignment of EXT Units can be made manually or automatically 
when connecting a new extender module to the matrix. 
 
1. Click System Settings > System in the task area. 
2. Click the Automatic ID tab in the working area. 

The settings for automatic creation of CPU and CON Devices and the initial values for the ID numbers of Real or 
Virtual CON or CPU Devices are set in this menu. 

 

 

Fig. 31 Menu System Settings - System - Automatic ID  
 

The following parameters can be configured: 
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Field Entry Description 
Auto Config Activated Enables the automatic creation of a new Real CPU or CON Device if new 

extender modules are connected (default). 
The new Real CON or CPU Device is assigned to the automatically 
created EXT Unit of the extender module. 

Deactivated Function not active 

ID Real CPU Device Numerical Sets start ID for automatic assignment of Real CPU Devices (default: 
1001). 

ID Virtual CPU Device Numerical Sets start ID for created Virtual CPU Devices (default: 2001). 

ID Real CON Device Numerical Sets start ID for automatic assignment of Real CON Devices (default: 
3001). 

ID Virtual CON Device Numerical Sets start ID for created Virtual CON Devices (default: 4001). 
 
3. Change the desired settings. 
4. Click Apply to confirm your entries. 

 

 The function Auto Config is enabled by default. This is very useful when configuring a matrix or matrix grid for 
the first time. After completing the configuration and checking that the whole system works as intended, we 
recommend disabling this function. This makes it easier to replace an extender module as described in section 9.2, 
page 203. 
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6.5.3 Setting the Matrix OSD Access 
1. Click System Settings > System in the task area. 
2. Click the Global OSD Settings tab in the working area. 
The Hot Key for accessing command mode and the Fast Key to open the matrix OSD are configured in this menu. 
 

 Hot Key or Fast Key set in the CON EXT Units have priority over the global settings made here. 
 

 

 

Fig. 32 Menu System Settings - System - Global OSD Settings  
 

The following parameters can be configured: 

Field Entry Description 
Hot Key Keyboard 

command 
Starts the command mode via keyboard sequence. 

Fast Key Keyboard 
command 

Opens the OSD via direct access (default: 00). 
How often the shortcut key has to be pressed depends on the specified 
key: 1x for function keys or print key, 2x for all other keys. 

Enable Chinese 
Encoding 

Activated Enables Chinese encoding for keyboard keys. 

Deactivated Function not active (Default) 

Enable Japanese 
Encoding 

Activated Enables Japanese encoding for keyboard keys. 

Deactivated Function not active (Default) 
 

3. Change the desired settings. 
4. Click Apply to confirm the changes. 
 

More information on Hot Key and Fast Key setting can be found in the OSD descriptions in the matrix and extender 
manuals. 
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6.5.4 Setting the Synchronization Mode 
Synchronization is important when using two redundant matrices (master and sub) without a matrix grid. 
1. Click System Settings > System in the task area. 
2. Click the Synchronization Mode tab in the working area.  
3. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 33 Menu System Settings - System - Synchronization Mode  
 

The following parameters can be configured: 

Field Entry Description 
LAN Echo Activated Sends all switching commands performed in the matrix as an echo via 

LAN connection. 
Note: This function should be enabled when using a media controller via 
LAN connection or when stacking two or more matrices. 

Deactivated Function not active (default). 

Synchronize Activated Synchronizes the sub matrix to the switch status of the master matrix. 

Deactivated Function not active (default). 

Echo Only Activated Synchronizes the matrix according to the echo of a second matrix. 
Note: This is a bidirectional synchronization where both matrices have to 
be configured as Synchronize with the Master IP of the respective other 
matrix. 

Deactivated Function not active (default). 

Master IP Address Numerical Sets the first network address of the master matrix (default: 
000.000.000.000). 

Master IP Address 2 Numerical Sets the second network address of the master matrix (default: 
000.000.000.000). 

 

4. Change the desired settings. 
5. Click Apply to confirm your entries. 
6. Click Deactivate Edit Mode in the toolbar.  
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6.5.5 Setting the Access Rights Configuration 
There are two different access control lists, one for users and one for CON Devices. 

• User ACL: For each user, an individual list of CPU Devices that they can access (either full or video only) can 
be created in the User Menu (see section 6.6.2, page 69). 

• CON ACL: For each CON Device, an individual list of CPU Devices that can be accessed from the assigned 
CON unit (either full or video only) can be created in the CON Device menu (see 6.9.8, page 128). 

Both can be combined with the logical functions AND and OR. 

• OR: A user at a CON unit has access to a CPU unit when either User ACL or CON ACL permit the 
connection. 

• AND: This is the most restrictive setting, only when User ACL and CON ACL both permit the 
connection, the user can at this CON unit access a CPU unit. 

 

The access configuration is set in this menu. 
1. Select System Settings > Access in the task area. 
The following window opens: 

 

 

Fig. 34 Menu System Settings - Access  
 

The following parameters can be configured: 

Field Entry Description 
Force User Login Activated Forces the user to login with a username and a password once to enter 

OSD. Thereafter the user remains logged in until they explicitly log out or 
an auto logout is affected. 
Note: If Force User Login is active, user access rights are not 
automatically active. User ACL and CON ACL can be configured 
independently. Force User Login only prevents the OSD and switching 
functionality from unauthorized access. 
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Deactivated Function not active (default). 

User ACL Activated Restricts CPU Device access according to the permissions in the ACL 
(Access Control List). 
• User login is required. 
• Switching by keyboard Hot Keys requires a prior login. 

Deactivated Function not active (default). 

CON ACL Activated Restricts CPU Device access according to the permissions in the 
respective CON Device ACL (Access Control List). No login required. 

Deactivated Function not active (default). 

OR User/CON ACL Activated The user is granted access if they either have access rights to this CON 
Unit or personal access rights as a user after logging in (extended 
access). 

Deactivated Function not active (default). 

AND User/CON ACL Activated The user is granted access if he has both access rights to this CON Unit 
and personal access rights as a user after logging in (reduced access). 

Deactivated Function not active (default). 

New User Activated Newly created users automatically receive access to all CPU Devices. 

Deactivated Function not active (default). 

New CON Activated Newly created CON Devices automatically receive access to all CPU 
Devices. 

Deactivated Function not active (default). 

Auto Disconnect Activated Disconnects the CON Device automatically from the current CPU Device 
upon opening the OSD. 

Deactivated Function not active (default). 

OSD Timeout [sec] 0 to 999 
seconds 

Period of inactivity after which OSD will be closed automatically. 
• Select 0 seconds for no timeout (default: 0 seconds). 

Auto Logout [min] 0 to 999 
minutes 

Period of inactivity of a logged-in user at a CON Device after which they 
will be automatically logged out. 
In addition to the logout process, a complete disconnection from the 
connected CPU Device occurs under Full Access and Private Mode. 
• Select 0 minutes for an automatic user logout when leaving OSD. 
• Using the setting -1 allows the user to be logged in permanently, until a 

manual logout is executed. 
The timer is not active as long as the OSD is open  
(default: 0 minutes). 

Keep CPU Activated Keeps the connection to the CPU Device active in the background after 
Auto Logout. After a new login there is no need to re-connect to the CPU 
Device. 

Deactivated Function not active (default). 

Show CPU Activated Shows the name of the currently connected CPU Device permanently in 
the upper right-hand corner. 

Deactivated Function not active (default). 
 
2. Click Activate Edit Mode in the toolbar. 
3. Change the desired settings. 
4. Click Apply to confirm your entries. 
5. Click Deactivate Edit Mode in the toolbar. 
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6.5.6 Setting Shared Operation of Sources 
This menu enables shared operation of a CPU Unit by two or more CON Units. A CPU Unit can be controlled by only 
one CON Unit at a time but can be taken over successively by other CON Units. Control of a CPU Unit by a 
CON Unit is relinquished after the expiration of an associated inactivity timer with the controlling CON Device. The 
mouse or keyboard may also be used to take over USB-HID control. 

 To allow a smooth and accurate function of the shared operation, you should use identical mice and keyboards. 
They should be connected to the same USB-HID ports of each CON Unit. The alternative is using the USB-HID 
Ghosting (see matrix user manual). 
When taking over control within 10 s, any assigned USB 2.0 EXT Unit if available, will not be switched due to security 
and stability aspects. 
The shared operation will be deactivated between CON Devices with a different priority as well as the Release Time. 
 
To configure shared operation, proceed as follows (only relevant for a single matrix but not for a matrix grid): 
1. Click System Settings > Switch in the task area. 
The switching parameters are set in this menu. 

 

 

Fig. 35 Menu System Settings - Switch  
 

The following parameters can be configured: 

Field Entry/Status Description 
Video Sharing Activated Enables the user to switch to any CPU Device as an observer, including 

ones that are already assigned to another user (observer without 
keyboard/mouse access) (default). 
Note: The switching has to be performed by pressing Space, not Enter. 
The operator only will be informed if further users connect as an observer 
to the CPU Device that is connected to his CON Device, if the option 
Update Connection Info is activated for his CON EXT Unit (see 
section 6.7.7.2, page 104). 

Deactivated Function not active (Default) 
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Field Entry/Status Description 
Force Connect Activated Enables the user to connect to every single CPU Device as an operator, 

including those that are related to another user (default). 
Note: The previous user is set to Video Only status. 
To share K/M control, Force Connect has to be activated. 

Deactivated Function not active 

Force Disconnect Activated Extends Force Connect: If the user connects as an operator to a CPU 
Device already related to another user, the previous user will be 
disconnected (default). 
Note: To share K/M control Force Disconnect has to be deactivated and 
Video Sharing has to be activated. 

Deactivated Function not active 

CPU Device Auto 
Connect 

Activated Enables automatically connecting to the next available CPU Device from 
the “Favorite list” by entering any key or clicking a mouse button when a 
CON Device is not connected to a CPU Device. 

Deactivated Function not active (default) 

CPU Device Timeout 
[min] 

0 to 999 
minutes 

Period of keyboard/mouse inactivity after which a CON Device will be 
automatically disconnected from its current CPU Device (default: 0=not 
activated). 

Keyboard Connect Activated Enables request of K/M control by keyboard event (first key stroke will be 
lost). 

Deactivated Function not active (Default) 

Mouse Connect Activated Enables request of K/M control by mouse event. 

Deactivated Function not active (Default) 

Release Time [sec] 0 to 999 
seconds 

Period of inactivity of a connected CON Device after which K/M control 
can be requested by other CON Devices connected to the CPU Device. 
Note: Set 0 for an immediate transfer in real time. 
Only one CON Device can have keyboard and mouse control at a time. 
The other CON Devices that are connected to the same CPU Device 
have a Video Only status (default: 2 seconds). 

Macro Single Step Activated Executes macro commands sequentially. 

Deactivated Function not active (default) 
 
2. Click Activate Edit Mode in the toolbar. 
3. Tick the Video Sharing checkbox. 
4. Tick the Force Connect checkbox. 
5. Tick the Keyboard Connect checkbox if taking over control by a keyboard event is to be permitted. 
6. Tick the Mouse Connect checkbox if taking over control by a mouse movement should be possible. 
7. Define a Release Time of inactivity (0 to 999 seconds) after which control can be taken over. 
8. Click Apply to confirm the changes. 
9. Click Deactivate Edit Mode in the toolbar. 
 

 Keyboard Connect and/or Mouse Connect are only effective if Force Connect and/or CPU Auto Connect are 
activated. 
If the Keyboard Connect and/or Mouse Connect options are enabled, the Keyboard Connect and/or Mouse 
Connect will not take effect until the time interval entered in the Release Time has elapsed. 
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6.5.7 Setting up the Network Configuration 
NOTICE 

Any change in system-relevant parameters (e.g., change of the IP address) is immediately displayed in the Tera 
Tool software. To initialize system-relevant configuration changes, the matrix must be restarted. Restarting the 
matrix may take several minutes, and the matrix is not available during the restart. 

 

NOTICE 

Consult your system administrator before changing the network parameters. Otherwise, unexpected results and 
failures can occur in combination with the network. 

 
1. Click System Settings > Network in the task area. 
2. Click Activate Edit Mode in the toolbar. 
The parameters for the network configuration are set in this menu. 

 

 

Fig. 36 Menu System Settings - Network - General  
 

The following parameters can be configured: 

Field Status Description 
Dual Interface Activated Disables the redundant network interface and enables two different 

network interfaces to be used, e.g., for 1x grid and 1x API or SNMP 
communication. 2x API is possible, 2x grid is not possible. 
Note: This option can be changed only in offline mode of a downloaded 
configuration. 

Deactivated Redundant network connection is enabled (default). 
 

 With enabled Dual Interface, an additional tab (Network Interface 2) opens for the second network port settings. 
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Network Settings - Controller Board 1 and 2 

Field Entry/Status Description 
DHCP Activated The network settings are automatically supplied by a DHCP server. 

Note: If DHCP is activated and there is no physical network connection 
available, the boot times might increase. 

Deactivated Function not active (default). 

IP Address Numerical IP address if DHCP is not active (default: 192.168.100.99). 

Subnet Mask Numerical Subnet mask in the form "255.255.255.0" if DHCP is not active (default: 
255.255.255.0). 

Gateway Numerical Gateway address in the form "192.168.1.1" if DHCP is not active. 

MAC Address Numerical Unchangeable, is retrieved automatically. Must be stated. 
 

Multicast 

Field Entry Description 
Multicast Numerical Multicast address if there is a a Multicast group (default: Broadcast 

255.255.255.255). 
 

Network Services 

Field Status Description 
External 
Configuration & 
Control 

Activated Enables the LAN interface at the matrix for access via Tera Tool software 
or third-party media controller (API control) (default, API service port 
5555/5565). 

Deactivated Function not active. 

SSL Support Activated Enables SSL encryption for API, Tera Tool software and matrix grid 
communication. 

Deactivated Function not active (default). 

Grid Service Activated Enables communication between matrices in a matrix grid (grid service 
port 5557/5567). 

Deactivated Function not active (default). 

Web Control Activated Enables the Tera Web Control app. 

Deactivated Function not active (default). 

Maintenance Service Activated Enables maintenance service for advanced diagnostics. 

Deactivated Function not active (default). 
 
3. Change the desired settings. 
4. Click Apply to confirm your entries. 
5. Click Deactivate Edit Mode in the toolbar. 
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6.5.8 Setting up the Dual Network Configuration 
6.5.8.1 Hardware Requirements 
• Draco tera enterprise with 480-CTRL2 

• Draco tera flex 
 

6.5.8.2 Firmware Requirements 
• MATLCPU version 04.01.211217 or later 

• MATLOS version 01.10.211220 or later  
 

6.5.8.3 Configuration Requirements 
The following points must be considered for the dual LAN configuration.  
 

Device Finder 
The Device Finder always takes the IP address of LAN 1 if clicking Connect or pressing the key Enter. There is no 
implementation which compares the IP address of the computer with the two IP addresses of the matrix and the 
Device Finder automatically selects the reachable one. 
 

IP Address and Network Configuration 
The IP addresses of the two LAN ports must not be within the same subnet. Both LAN ports must be connected to 
two different networks. The two networks must either be physically split without any connection to each other, or the 
two networks must be part of two different VLAN. This is because the two LAN ports are internally (at the matrix 
controller board) connected by a network switch. 
 

Configuration of Services 
Grid Service: The grid service may only be activated on one LAN port and must not be activated on both LAN ports 
at the same time. 
API Service: The API service is necessary for the Tera Tool software and for API access by a media controller. 
This service can be deactivated for both LAN ports, activated for one LAN port or activated for both LAN ports 
simultaneously. 
 

Syslog and SNMP 
The two Syslog and two SNMP server addresses are not fix assigned to any of the LAN ports. The matrix decides 
automatically due to the sub net which port is used. For the two Syslog servers as well as for the two SNMP servers 
you have the following options: 

• Both servers are part of the same subnet as LAN port 1. 

• Both servers are part of the same subnet as LAN port 2. 

• Server 1 is part of the same subnet as LAN port 1 and Server 2 is part of the same subnet as LAN port 2. 

• Server 1 is part of the same subnet as LAN port 2 and Server 2 is part of the same subnet as LAN port 1. 
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6.5.8.4 Dual Network Dependencies 
The availability of Tera Tool software functions depends on connected LAN port and enabled grid service when 
operating a matrix grid. 

 Grid service at LAN 1 Grid service at LAN 2 
 Connected to 

master matrix 
Connected to sub 

matrix 
Connected to 
master matrix 

Connected to sub 
matrix 

Tera Tool software 
functions LAN 1 LAN 2 LAN 1 LAN 2 LAN 1 LAN 2 LAN 1 LAN 2 
Device Finder X --- X --- --- X --- X 

View Matrix X X X X X X X X 

View Port X X X Ο X X - Ο 

View Grid X X X - X X - - 

Extended Switch X X X X X X X X 

Status Matrix Firmware X X X Ο X X Ο Ο 

Status Extender 
Firmware 

X X X Ο X X Ο Ο 

Extender Firmware on 
IO-Board 

X X X Ο X X Ο Ο 

Matrix Grid X X Ο Ο X X --- --- 

Update - Matrix 
Firmware 

X X X X X X X X 

Update - Extender 
Firmware 

X X X X X X X X 

Change Configuration X X X X X X X X 

Save Configuration X X X X X X X X 

Direct Connect to other 
Matrices 
(View Port, View Grid, 
Matrix Grid) 

X X X X X X X X 

X fully supported 
Ο  supported with limitations (e.g., some information missing) 
--- not supported (e.g., error, wrong information) 
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6.5.9 Setting the Syslog Function 
NOTICE 

For an activation of the Syslog function or changes of the IP address, a restart of the matrix or the controller board 
is necessary. Restarting the matrix or the controller board may take several minutes, and the matrix is not available 
during the restart. 

 
1. Click System Settings > Network in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the Syslog tab in the working area. 
The parameters for the Syslog function are set in this menu: 

 

 

Fig. 37 Menu System Settings - Network - Syslog  
 

The following parameters can be configured: 

Field Entry/Status Description 
Syslog Activated Syslog server for status request is active. 

Deactivated Function not active (default). 

Syslog Server Numerical IP address of the Syslog servers in the form “192.168.1.1”. 

Port Numerical Enter the Syslog port (default: 514). 

Log Level Debug Enables debug messages in Syslog (default: N). 
Note: The debug messages are exclusively for matrix diagnostics of the 
syslog server. They should only be activated after consultation with the 
manufacturer. Otherwise, an increased traffic of data might limit the 
performance of the controller board. 

Info Enables information messages in Syslog (default: N). 

Notice Enables notification messages in Syslog (default: Y). 

Warning Warning messages in Syslog (default: Y), always active 

Error Error messages in Syslog (default: Y), always active 
 

4. Change the desired settings. 
5. Click Apply to confirm the settings. 
6. Click Deactivate Edit Mode in the toolbar. 
7. Restart the matrix or the controller board. 
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6.5.9.1 Setting the Syslog Options 
This is only relevant when you wish to use Tera Tool software as syslog server. To set or activate the presetting, 
proceed as follows: 
1. Click Extras > Options in the menu bar and open the Syslog tab. 

 

 

Fig. 38 Menu Extras - Options - Syslog  
 

The following options are available: 

Option Description 
Log File Directory Default directory to store the log files. 

Log File Name Default name of the log file. 

Log File Extension Default extension for the log file. 

Daily Log Files Log files are stored every 24 hours (daily). 

Maximum Log File 
Size [KB] 

Allowed maximum size of log file. 
When reaching the maximum log file size, a new log file will be created. 

Maximum Number of 
Log Files 

Allowed maximum number of log files. 
When the maximum number of log files is exceeded, the oldest logfile will be overwritten 
with the new information (log rotate). 

Acoustic Notification Enables acoustic notification for errors. 

Autostart Starts the Syslog logging in the background when starting the Tera Tool software. 

Open Monitoring Tab Opens the monitoring tab when starting the Tera Tool software. 
 

2. Enter the appropriate data and tick the checkboxes for desired options. 
3. Click Ok to confirm the settings. 
4. Close the Tera Tool software and restart it. 
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6.5.9.2 Activating I/O Board Diagnosis 
For dedicated trouble shooting, Syslog can be enabled for selected I/O boards in this menu. 
1. Click Status & Updates > Miscellaneous in the task area. 

The I/O Board Diagnosis tab opens in the working area. 

 

 

Fig. 39 Menu Status & Updates - Miscellaneous - I/O Board Diagnosis  
 

The following functions are available: 

Button Function 
Send Sends settings to the matrix to activate the Syslog protocol for the selected I/O boards. 

Reload Reloads settings. 
 

The following options are available in the Additional selection options drop-down menu on the right upper side in 
the working area: 

Option Description 
Select All Selects all I/O boards. 

Deselect All Deselects all selected I/O boards. 
 

2. Click Activate Edit Mode in the toolbar. 
3. Select the desired I/O boards to activate the additional diagnosis. 

Messages of the selected I/O boards will be added to the Syslog protocol. 
4. For IP Gateway boards, click the button Download Diagnosis in the corresponding line. 

The Save dialog appears.  
5. Select the desired folder and enter a suitable name for the diagnosis file which is a text file that can be opened 

with every text editor.  
6. Click Send to send the settings to the matrix. 
7. Click Deactivate Edit Mode in the toolbar. 
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6.5.10 Setting the SNMP Function 
The SNMP function allows all function-critical and safety-critical elements of the matrix to be monitored and queried. 
This function complies with the RFC 1157 conformal standard. Two SNMP servers can be used at the same time. 
Enabling the SNMP function, the unencrypted SNMP monitoring (SNMPv2) is activated with Draco tera flex and 
Draco tera enterprise with 480-CTRL2. With Draco tera compact and Draco tera enterprise with 480-CTRL1, 
SNMPv1 is activated. 
When Tera Tool is used as SNMP server, an SNMPv3 User for encrypted SNMP monitoring (SNMPv3) can be set in 
the user settings (see section 6.6, page 67) and the login data for an SNMPv3 User at the SNMP server can be set in 
the default settings (see page 60). 
 

NOTICE 

When using SNMP monitoring, for reasons of access security, the use of a dedicated network according to the IT-
Grundschutz-Kompendium (IT Baseline Protection) is recommended. The read-only community for the MIB file is 
kvm. 

 

NOTICE 

For an activation of the SNMP agent function or the SNMP server function, a restart of the matrix or the controller 
board is necessary. Restarting the matrix or the controller board may take several minutes, and the matrix is not 
available during the restart. 

 
To activate the SNMP agent, proceed as follows: 
1. Click System Settings > Network in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the SNMP tab in the working area. 
 

 

 

Fig. 40 Menu System Settings - Network - SNMP  
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SNMP Agent 

Traps Description 
SNMP Agent Grants permission for an active query of the SNMP agent for traps. 

Port The SNMP port is called up automatically (default: 161). 

Configured SNMPv3 
User 

Name of the SNMP user 

Read-Only 
Community String 

The read-only community string for SNMP Get requests is kvm. This can be changed. 

 

SNMP Trap 

 The SNMP agent must be activated to enable SNMP traps. Traps are always set for both SNMP servers. 
 
Traps Description 
Traps Sends trap messages from the SNMP agent to the SNMP server. 

SNMP Server IP address of the SNMP server in the form “192.168.1.1”. 

Port SNMP port (default: 162) at the SNMP server. 

Select All Select/deselect all traps. 

Status Notification about matrix status. 

Temperature Notification about temperature changes within the matrix. 

Insert I/O Board Notification about insertion of a new I/O board into a slot. 

Remove I/O Board Notification about removal of an I/O board out of a slot. 

Invalid I/O Board Notification about the wrong firmware installed on the I/O board. 

Insert Extender • Notification about a newly connected extender module to the matrix, notification about 
a switched-on extender module. 

• Notification about a newly established link between extender module and matrix. 

Remove Extender • Notification about a removed extender module from the matrix. 
• Notification about a switched off extender module. 
• Notification about an interrupted link between extender module and matrix. 

Switch Command Notification about a performed switching operation at the matrix. 

Fan Tray 1 Notification about the fan 1 status (interface view of the matrix: left side (K048/K080) or 
bottom (K152-K576)*. 

Fan Tray 2 Notification about the fan 2 status (interface view of the matrix: right side (K048/K080) or 
top (K152-K576)*. 

Power Supply 1 Notification about the status of power supply unit 1. 

Power Supply 2 Notification about the status of power supply unit 2. 

Power Supply 3 Notification about the status of power supply unit 3. 

Power Supply 4 Notification about the status of power supply unit 4. 

* Only for Draco tera enterprise matrices. 
 

4. Tick the SNMP Agent checkbox within the SNMP Agent area. 
By activating this option, permission for an active query of the SNMP agent is granted. 

5. Tick the Traps checkbox within the SNMP Trap area. 
6. Enter the IP address of the SNMP server under SNMP Server. 
7. Tick the checkboxes of the desired traps to activate them. The traps of both receivers are linked. When you tick a 

parameter on the tab Trap Receiver 1, the same parameter is automatically ticked on the tab Receiver 2 and 
vice versa. 
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8. Click Apply to confirm the changes. 
9. Click Deactivate Edit Mode in the toolbar. 
10. Restart the matrix or the controller board. 
 
 

6.5.10.1 Setting up SNMP Options 
This is only relevant when you wish to use Tera Tool software as SNMP server. Presets for an SNMPv3 user can be 
set up for the computer on which the Tera Tool software is operated. These are set in this menu. 
To set or activate the presetting, proceed as follows: 
1. Click Extras > Options in the menu bar and open the SNMP tab. 

 

 

Fig. 41 Menu Extras - Options - SNMP  
 

The following options are available: 

Option Description 
Port SNMP port (default: 162) of SNMP server 

Log File Directory Default directory to store the log files. 

Log File Name Default name of the log file. 

Log File Extension Default extension for the log file. 

Daily Log Files Log files are stored every 24 hours (daily). 

Maximum Log File 
Size [KB] 

Allowed maximum size of log file. 
When reaching the maximum log file size, a new log file will be created. 

Maximum Number of 
Log Files 

Allowed maximum number of log files. 
When the maximum number of log files is exceeded, the oldest logfile will be overwritten 
with the new information (log rotate). 

Acoustic Notification Enables acoustic notification for errors. 

Autostart When starting the Tera Tool software, the SNMP logging will be started in the 
background. 

Open Monitoring Tab When starting the Tera Tool software, the monitoring tab will be opened. 
 

2. Enter the appropriate data and tick the checkboxes for desired options. 
3. Click Ok to confirm the settings. 
4. Close the Tera Tool software and restart it. 
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6.5.10.2 Creating an SNMPv3 User for the SNMP Server 
In the following menu, the login data for an SNMPv3 user can be set up for the SNMP server. The SNMP server 
authenticates itself to the agent using this login data. 
 

NOTICE 

Failed SNMP logging 
If the login data differs between the matrix (set up in the User Settings menu) and the SNMP server, no SNMP 
traps are transmitted. 
 Ensure the login data (username and password) in both settings are identical. 

 
To configure the login data for an SNMPv3 User at the SNMP server, proceed as follows: 
1. Click Extras > Options in the menu bar and open the SNMP tab. 
2. Click Manage SNMPv3 Users. 

A list appears with already created SNMPv3 users. 
3. Click Add User. 

A dialog window appears. 

 
Fig. 42 Menu Extras - Options - SNMP - Manage SNMPv3 Users - Add User  
 

The following parameters are required to create a new SNMPv3 user on the SNMP server: 

Option Description 
Username SNMPv3 username. 

Authentication 
Protocol 

Only SHA protocol, no selection available. 

Authentication 
Password 

Authentication password for the SNMPv3 user (case sensitive, input of minimum 
8 characters up to 16 characters). 

Privacy Protocol Only DES protocol, no selection available. 

Privacy Password Must be identical to the authentication password. 
 

4. Enter the required data and click Ok to confirm the settings. 
5. Click Close to close the users list. 
6. Click Ok in the SNMP tab to confirm your settings. 
7. Close the Tera Tool software and restart it. 
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6.5.11 Setting the LDAP Configuration (Active Directory) 
The description in this section refers to matrix firmware 04.04.240716 and newer. 

NOTICE 

To initialize the LDAP configuration changes, the matrix must be restarted. Restarting the matrix may take several 
minutes, and the matrix is not available during the restart. 

 

Hardware Requirements 

 LDAP is only available for tera flex and tera enterprise with 480-CTRL2 controller board. These units use the 
firmware named “MATLCPU” at the controller board. 
 

Tera enterprise with 480-CTRL controller boards and tera compact do not support the communication with an LDAP 
server. These units use the firmware named “MATXCPU” at the controller board. 
 

For a matrix grid, the controller board of the master matrix is decisive. The type of controller board of the sub 
matrices doesn’t matter if the master matrix has a suitable controller board. 
 

 Click Status & Updates > Status Matrix Firmware in the task area (see following figure). 
 Check the firmware in column Name of the Type CPU. 
 

 

 

Fig. 43 Menu Status & Updates - Status Matrix Firmware - Check Firmware of Controller Board  
 
The matrix can be synchronized with the directory service Active Directory regarding user authentication. This allows 
the user to log in at the matrix using login information from the Active Directory service and to contact the Active 
Directory Server for each authentication that does in fact the proper authentication. 
The connection between matrix and the Active Directory server is established via OpenLDAP and periodically 
synchronized every 5 minutes. 
The search for users to be synchronized and automatically added to the matrix configuration can either be based on 
a group or organizational unit (OU). In both cases a user requires to be at least assigned to one group: 

• In the case of the group, all users belonging to a previously defined group on the active directory server are 
added to the KVM matrix and synchronized. In this alternative, the organizational structure of the organizational 
units (OUs) is added as matrix user group to the KVM matrix configuration. This means that the organizational 
unit (OU) that includes the user can be found as a matrix user group in the KVM matrix configuration after the 
synchronization. A user can be a member of up to 17 groups. 

• In the case of the organizational unit, all users belonging to groups that are located directly under this 
organizational unit are added and synchronized. The groups can also include subgroups. The structure of the 
groups is added to the KVM matrix configuration as user group. Each group will be represented in the KVM 
matrix as a user group after the synchronization. Groups that are in sub organizational units will be ignored. 
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6.5.11.1 Configuration 
To configure and enable the synchronization to the Active Directory server, proceed as follows: 
1. Click System Settings > Network in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the LDAP tab in the working area. 
The general LDAP settings for the synchronization with the directory service Active Directory are set in this menu. 

 

 

Fig. 44 Menu System Settings - Network - LDAP  
 

The following parameters can be configured: 

Parameter Mandatory Length Restart Description 
LDAP Yes - Yes Enables or disables LDAP synchronization and 

authentication. 

Use TLS/SSL No - Yes Enables a secure transmission (transport layer security) for 
the Active Directory access. 

LDAP Server 1 Yes - Yes IP address and port (389 without TLS/SSL, 636 with 
TLS/SSL) of the respective LDAP server in the form 
"192.168.1.1". 

LDAP Server 2-4 No - Yes Optional redundant LDAP servers 2 to 4: 
LDAP server 2 is used if LDAP server 1 is not reachable. 
LDAP server 3 is used if LDAP server 2 is not reachable. 
LDAP server 4 is used if LDAP server 3 is not reachable. 
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Parameter Mandatory Length Restart Description 
Base DN Yes Max. 

256 
byte 

No The search base DN is an element of the search request that 
works in conjunction with the LDAP search scope to define 
the subtree of entries that should be considered when 
processing the search request. 
Only entries at or below the search base DN will be 
considered candidates for matching against the LDAP 
synchronization and authentication. 

Search Base Yes Max. 
256 

bytes 

No Defines the organizational unit (OU) in which the matrix 
searches for user groups and users.  
 

Config Option 1: 
If you only enter the name of the OU, the name of the OU 
has to be unique within the Base DN so that the matrix finds 
one unique object. The OU has to be placed below the Base 
DN. 
 
Config Option 2: 
If the name of this OU is not unique, enter the distinguished 
name (DN) of the OU where the matrix should search for 
users and user groups. 

Bind DN Yes Max. 
256 

bytes 

No Enter the Bind DN or User for the Bind request. 

Bind Password Yes Max. 
128 

bytes 

No Enter the password for the Bind request (password of the 
Bind user). 

 

 A matrix configuration should only include one LDAP user and one LDAP group at the same time. The LDAP user 
and the LDAP group can be created, changed, or deleted during ongoing operation: no restart of the matrix is 
required. 
 

4. Tick the LDAP checkbox. 
5. Optionally tick the Use TLS/SSL checkbox to activate this function. 
6. Enter the respective IP address and port number into the field LDAP Server (default port number: 389 (636 for 

SSL)). 
7. Optional: Enter further IP addresses and port numbers into the fields LDAP Server 2 to 4. 
8. Enter the LDAP Base DN into the respective field (e.g., dc=ihse, dc=office). 
9. Enter the LDAP Search Base into the respective field (e.g., ou=KVMMatrix). 
10. Enter the LDAP Bind DN or User into the respective field (e.g., cn=LdapUser,ou=diverse,dc=ihse,dc=office). 
11. Enter the LDAP Bind Password into the respective field. 
12. Click Apply to confirm the settings. 
13. Restart the matrix. 

 Changes done in step 4 to 7 only come into effect after a restart of the matrix. 
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6.5.11.2 Search and Synchronize Process 
The matrix searches the complete OU specified as Search Base for groups. All groups found are then imported into 
the matrix. The members of each group found are also added to the matrix. 
If a new group is found as a member of an existing group, this new group and its members are also added to the 
matrix. The members can be outside the defined search base and be both user and user groups. 
This search process continues until no new users or groups are found. The matrix repeats the search process every 
30 minutes. 
 
6.5.11.3 Results of a Search 
User Groups  
[Menu: User Settings -> Users & Groups -> Groups] 
Here you can find and check the automatically synchronized (imported) user groups. The “common name” is used for 
the user groups (limited to 32 characters). Each user group can be a member of up to 17 other user groups at the 
same time. 
 
Users 
[Menu: User Settings -> Users & Groups -> Users] 
Here you can find and check the automatically synchronized (imported) users.  
The matrix imports two different fields for each user: 
sAMAcountName or UID 
(depending on kind of LDAP server) 

Limited to 32 characters Can be used for login 

UserPrinicalName or Mail 
(depending on kind of LDAP server) 

Limited to 64 characters Can be used for login 

 
The password is limited to 32 characters and cannot be changed in the matrix. 
After successful login, the user password is temporarily stored in the matrix and serves as backup in case the LDAP 
server is not accessible. Empty means the user has never successfully logged in. 
Each user can be a member of up to 17 different user groups at the same time. 
The total number of user + user groups is limited to 256. You can check it using “System Check”. 
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6.5.12 Setting Date and Time 
1. Click System Settings > Date and Time in the task area. 
2. Click Activate Edit Mode in the toolbar. 
The parameters for the system configuration are set in this menu, based on Simple Network Time Protocol (SNTP): 

 

 

Fig. 45 Menu System Settings - Date and Time  
 

The following parameters can be configured: 

SNTP 

Field Entry/Status Description 
SNTP Activated Enables the network time server synchronization. 

Deactivated Function not active (default). 

SNTP Server Numerical SNTP server IP address (default: 000.000.000.000). 

Time Zone Region Sets your specific time zone (default: GMT + 00). 
 

Real Time Clock 

Field Description 
Date and Time* Sets date and time of the real time clock. 

Get Local Time Gets local time of this computer. 

* Date format yyyy-mm-dd. 
 

Configuring the Time Server 
To configure a time server, proceed as follows: 
3. Tick the SNTP checkbox to enable the SNTP option. 
4. Enter the IP address of your SNTP server into the SNTP Server field. 
5. Select your time zone from the Time Zone drop down list. 
6. Click Apply to confirm your settings. 
7. Click Deactivate Edit Mode in the toolbar. 
8. Restart the matrix. 

After the restart, the system time is now provided by the SNTP server. 
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Configuring the Real Time Clock without Time Server 
1. Click System Settings > Date and Time in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Set the current date in the Date and Time section. 
4. Set the current time in the Date and Time section. 

The entered time is set immediately in the settings. 
5. Option: if you want to receive the time from your currently used computer, click Get Local Time. 
6. Click Apply to confirm your settings. 
7. Click Deactivate Edit Mode in the toolbar. 
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6.6 Configuring User Settings 
 

Different types of users with different rights can be created. 
 Administrator Super User Power User Normal User 
Configuration of all devices  - - - 
Access to all devices  - - - 
Switching in Private Mode   - - 
Disconnecting a Private Mode connection  - - - 
User ACL can be limited - -   
ACL can be limited by Login Lock option - -   
Limited switching options if user ACL is 
active (requires login at CON unit) - - -  

Defining favorites     
Executing macros *    

* with restrictions 

 

6.6.1 Description of User Menu 
1. Click User Settings > Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
New users and their user settings and permissions are set in this menu. 

 

 

Fig. 46 Menu User Settings - Users & Groups - Users  
 

NOTICE 

Failed SNMP logging 
If the login data of the SNMPv3 user differs between the matrix and the SNMP server, no SNMP loggings are 
transmitted. 
 Ensure the login data (username and password) in both settings are identical (see section 6.5.10.2 on page 60). 
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The following parameters can be configured or offer information. 
 

Field Entry/Status Description 
ID Numerical Ident number of the user. 

Name/ 
sAMAccountName 

Text For administrators/power users/SNMP users it is the login name (input of 
minimum 1 character up to 32 characters). Can be used to log in to the 
OSD. 

For users imported via Tera Tool and LDAP, it is the sAMAccountName 
or UID (depending on kind of LDAP server), automatically retrieved from 
the LDAP server. Can be used to log in to the OSD. 

Full Name/ 
userPrincipalName 

Text For administrators/power users/SNMP users it is the full name (optional 
input of up to 64 characters). Can be used to log in to the OSD. 

For users imported via Tera Tool and LDAP, it is the userPrincipalName 
or Mail (depending on kind of LDAP server), automatically retrieved from 
the LDAP server. Can be used to log in to the OSD. 

Password Text For standard users (optional input of up to 32 characters, case sensitive). 
Can be used to log in to the OSD. 

For LDAP Users (case sensitive, input of minimum 1 character up to 
32 characters). Can be used to log in to the OSD. 

Priority Value Priority of the user. The priority of the user “admin”, which always exists 
by default, cannot be changed. All other users can get any priority 
between 0 and 999 (default: 999) 

Administrator Activated User role with rights for system configuration and all switching operations. 

Deactivated Function not active (default) 

Super User Activated User role with rights for switching any CON Device to any CPU Device in 
Extended Switching. 

Deactivated Function not active (default) 

Power User Activated User role with rights for switching CON Devices to CPU Devices in 
Extended Switching according to the CON or User ACL, but not in 
Private Mode. 

Deactivated Function not active (default) 

SNMPv3 User Activated User role with rights to use SNMPv3 (encrypted). 

Deactivated SNMPv3 is not enabled. 

Auto Connect Activated Re-establishes the previous user connection after login. 

Deactivated Function not active 

2 Factor 
Authentication 

Activated Enables 2 factor authentication. 
If enabling the 2 Factor Authentication for a user, this user needs a 
smartphone/tablet with an installed authentication app to login. The 
smartphone needs to use the same date and time settings as the matrix 
system. 
With the first login after enabling, a QR code (security key) will be 
generated and displayed in the OSD. A QR code scan with the 
authentication app is required to get access. After authentication, a login 
token will be created. For further logins, a token has to be requested via 
authentication app to get access. 

Deactivated Function not active. 

AD Synchronized Activated User was added through synchronization with an LAPD server. 

Deactivated User was created manually.  
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Field Entry/Status Description 
AD Group Locked Activated Locks synchronization of group attribute for an Active Directory user.  

Deactivated Function not active (default) 
 
 

6.6.2 Creating a new Standard User Account 
To create a new user, proceed as follows: 
1. Click New User. 

A selection dialog appears. 

 

 

Fig. 47 Selection menu New User  
 

2. Select a template of an existing user if applicable (Choose template) in the selection box (appears only when at 
least one user has already been created).  

3. Click Ok. 
4. Enter a name. 
5. Optionally enter a full name and a password (password is only needed for using Tera Tool software) 
6. Optionally enable the 2 Factor Authentication. 
7. Set user permissions for CPU Device access (described on following pages). 
8. Set user favorites (described on following pages). 
9. Click Apply to confirm the new user settings. 
 
6.6.2.1 Creating a Power User, Super User or Administrator Account 
1. Create a standard user as described in the previous section. 
2. Tick the respective checkbox Power User, Super User or Administrator. 
3. Click Apply to confirm the new user settings. 

 
6.6.2.2 Changing a User Account 
1. Click User Settings > Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a user in the Users list. 
4. Change the desired settings. 
5. Click Apply to confirm the changes. 
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6.6.2.3 Configuring User Access Rights 
1. Click User Settings > Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a user in the Users list. 
4. By clicking with the right mouse button once on a CPU Device in one of the respective access lists (Full Access, 

Video Access, and No Access), a context menu for selection appears in which the respective CPU Device can 
be moved, and the access rights can be changed. Alternatively, press f, v, or n to set the respective access 
rights. 

5. Click Apply to confirm the changes. 
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6.6.3 Setting User Favorites 
Individual favorite lists of CPU Devices that will be switched frequently can be created for different users in this menu. 
A favorite list can contain up to 32 different CPU Devices (from firmware V3.05). 
The switching of the favorites is done via keyboard command (see matrix user manual). 
 

1. Click User Settings> Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 48 Menu User Settings - Users & Groups - Users - Favorites  
 

Creating a Favorites List for Users 

 The list CPU Device available contains only CPU Devices the user can access according to the access rights 
configuration. 
 

To create a favorites list for any user, proceed as follows:  
3. Select the respective user for the favorites list in the Users list. 
4. Click the Favorites tab in the working area. 
5. Select the CPU Devices in the CPU Device available list that should be added to the favorites list (Favorite 

CPU Devices). By pressing and holding down Ctrl at the same time, more than one CPU Device can be 
highlighted. 

6. Click  to move the highlighted CPU Devices to the favorites list. By clicking , all CPU Devices from the 
CPU Device available list will be moved to the favorites list (Favorite CPU Devices). 

7. To remove highlighted CPU Devices from the favorites list, click . By clicking , all CPU Devices will be 
removed from the favorites list. 

8. Click  or  to change the order of the CPU Devices within the favorites list. 
Or press + or - to change the order of the CPU Devices within the favorites list. 

9. Click Apply to confirm the changes. 
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6.6.4 Setting User Macros 
In this menu macro commands for switching, disconnection or user administration can be created. Macro commands 
are created for each user separately. A macro can execute up to 16 commands successively. The execution of the 
macros is done via Hot Key and the F1 to F16 function keys and Shift+F1 to Shift+F16 (S1 to S16). 

 To execute user macros the user has to be logged in to the matrix. An admin user can execute macros only if 
Force Login is active or via OSD menu “Macro List”. 
 
1. Click User Settings > Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the user for which macros are to be created. 
4. Open the Macros tab. 

 

 

Fig. 49 Menu User Settings - Users & Groups - Users - Macros  
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The following parameters can be configured: 

Field Selection Description 
Key F1 to F16 

S1 to S16 
Selects the function key to be configured.  

Function 
(01 to 16) 

Connect 
(P1=CON, P2=CPU) 

Sets a bidirectional connection from CON Device P1 to CPU Device P2. 

Connect Video 
(P1=CON, P2=CPU) 

Sets a Video Only connection from CON Device P1 to CPU Device P2. 

Connect Private 
(P1=CON, P2=CPU) 

Sets a Private Mode connection from CON Device P1 to CPU Device P2. 

Disconnect 
(P1=CON) 

Disconnects the CON Device P1. 

Logout User Logs out the current user. 

Assign CPU 
(P1=VCPU, P2=RCPU) 

Assigns a Virtual CPU Device to a Real CPU Device. 

Assign CON 
(P1=RCON, P2=VCON) 

Assigns a Real CON Device to a Virtual CON Device. 

Push (P1=CON) Shifts the current access status (FA or VO) to CON Device P1.  

Push Video (P1=CON) Forwards the video signal of the current connection (Full Access or Video 
Only) to CON Device P1. The user’s connection remains unchanged (Full 
Access or Video Only). 

Get (P1=CON) The user’s CON Device gets a Full Access connection to the CPU Device 
that is currently connected to CON Device P1. The connection of 
CON Device P1 is changed into a Video Only connection. 

Get Video (P1=CON) The user’s CON Device gets a Video Only connection to the CPU Device 
that is currently connected to CON Device P1. The connection of 
CON Device P1 remains unchanged (Full Access or Video Only). 

Login User (P1=CON, 
P2=User) 

Logs in a certain user P1 at CON Device P2. 

MSC Connect 
(P1=Control-CON, 
P2=CON) 

Sets USB-HID control within activated MSC from the Control CON Device 
P1 to another Control CON Device P2. 

P1 CON Device 
VCPU Device 
RCON Device 
Control-CON Device 

Name of CON Device, Virtual CPU Device, RCON Device or Control-
CON Device 

P2 CPU Device 
RCPU Device 
VCON Device 
User 
CON Device 

Name of CPU Device, Real CPU Device, Virtual CON Device, User or 
CON Device 

 

5. Select in the Key field the function key for which a macro has to be created. 
6. Double-click in the Function column to display a list of all available commands. 
7. Select the desired command in the selection list. 
8. Double-click P1 columns and, if necessary, P2 column and select the respective parameters for the macro 

functions (e.g., corresponding CON Devices and CPU Devices) from the drop-down list. 
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Example: In figure 40 (see previous page) in line 2 the following elements were selected: 
 Function: Connect (P1=CON, P2=CPU) 
 P1:  03003 CON-WS 2-1 

P2: 01013 CPU-Server 3 
When the user executes this macro with Hotkey, F2, after the first command, CON-WS 2-1 is 
switched in Full Access mode to CPU-Server 3. 

 

9. Click Apply to confirm the changes. 
10. Click Deactivate Edit Mode in the toolbar. 
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6.6.5 CON Specific Selective User Access 
Users can be blocked from logging in to certain CON Devices. Requirement for the feature Login Lock is to activate 
Force User Login and Enable User ACL in the access settings (see section 6.5.5, page 46). 
Example: A user who works in a restricted area should not be able to log in at a publicly exposed workplace.  
 
1. Click User Settings> Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the appropriate user from the Users list for whom the login should be restricted. 
4. Click the Login Lock tab in the working area. 

 

 

Fig. 50 Menu User Settings - Users & Groups - Users - Login Lock  
 

Users can log in to all CON Devices that are listed under Allowed Login. They cannot log in to CON Devices that 
are listed under Locked Login (provided the functions Force User Login and Enable User ACL are active). 
To move the CON Devices from one list to the other proceed as follows: 
 

5. Select the CON Devices in the Allowed Login list that should be added to the list of locked CON Devices, 
(Locked Login). By pressing and holding down Ctrl at the same time, more than one CON Device can be 
highlighted. 

6. Click  to move the highlighted CON Devices to Locked Login list. By clicking , all CON Devices from the 
Allowed Login list will be moved to the Locked Login list. 

7. To remove highlighted CON Devices from the Locked Login list, click . By clicking , all CON Devices will be 
removed from the Locked Login list. 

8. Click Apply to confirm the changes. 
9. Click Deactivate Edit Mode in the toolbar. 
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6.6.6 Setting User Groups 
The KVM matrix allows to bundle the users of a configuration into User Groups. The groups can be used to subdivide 
the users logically or thematically. As an application example you can group all power users together. The 
configuration of User Groups at the same time increases the clarity of the configuration. 
 

General rules 
A group member always has at least the access rights of the group. For single group members the hereditary rights 
cannot be reduced.  
Users and groups count together for the total number of configurable entries. 
Manual creation: A user can be a member of only one group. A group can be a member of only one other group. 
LDAP user and groups: A user can be a member of up to 17 groups. A group can be a member of up to 17 other 
groups. 
 

To create and configure a User Group, proceed as follows: 
1. Click User Settings > Users & Groups in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the Groups tab in the upper left-hand corner of the working area. 
4. Click New Group. 

A selection window appears. 

 

 

Fig. 51 Selection menu of new user group 
 

5. Select Create a standard Group in the selection box. 
6. Click Ok. 
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Fig. 52 Menu User Settings - Users & Groups - Groups - User Assignment  
 

7. Enter a group name into the field Name. 
 

Assigning Users to a Group 
8. Select the User Group. 
9. Select a user in the User/Group available list that should be assigned to the User Group. By pressing and 

holding down Ctrl at the same time, more than one user can be highlighted. 
10. Click  to move the highlighted user to the User Group list (User/Group assigned). By clicking , all users from 

the User/Group available list will be moved to the User/Group assigned list. 
11. To remove highlighted users from the User Group list, click . By clicking , all Users will be removed from the 

User Group list. 
 
Assigning Access to CPU Devices to a User Group 
12. Select a user group from the Groups list. 
13. Click the tab CPU Device Access Control. 

 

 

Fig. 53 Menü User Settings - Users & Groups - Groups - CPU Device Assignment  
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14. By clicking with the right mouse button once on a CPU Device in one of the respective access lists (Full Access, 
Video Access, and No Access), a context menu for selection appears in which the respective CPU Device can 
be moved, and the access rights can be changed. Alternatively, press f, v, or n to set the respective access 
rights. 

15. Click Apply to confirm the configuration of the user group. 
16. Click Deactivate Edit Mode in the toolbar. 
 

 For an efficient user configuration, user settings can be assigned to other users (see description in section 6.10.1, 
page 139) or be copied from another user (see section 6.10.2, page 141). 
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6.7 Configuring Extender Modules and EXT Units 
6.7.1 Automatic Creation of EXT Units 
The matrix automatically recognizes every extender module, physically connected to the matrix with a direct cable 
connection, reads out its serial number and creates EXT Units automatically. When disconnecting the extender 
module from the original port and reconnecting it at another port, the previous assignment to a Device remains 
active. This is the Flex Port function of the matrix.  
Add-on modules are not created as independent EXT Units. The data of add-on modules is included in one EXT Unit 
together with the associated extender module. 
All EXT Units are managed in this menu. This includes the manual creation of new EXT Units (e.g. for fixed ports) 
and the deletion of existing EXT Units. 

NOTICE 

In contrast to a Flex Port, an extender connected to a Fixed Port must remain there and cannot be connected to 
another port. EXT Units with fixed ports, e.g., USB 2.0 extender modules, have to be created manually (see 
section 6.7.3, page 87). 

 

 

 

Fig. 54 Menu Extender & Devices - EXT Units  
 

The following parameters are recognized automatically (exceptions for USB 2.0 units and cascading units): 

Field Entry/Status Description 
ID Text Numerical value of the KVM extender module ID. 

The ID is provided by the extender module (serial number) and cannot be 
changed. 

Name Text Name of the EXT Unit. 

Port Number • 0 if the primary interconnection port of the extender module is currently 
not connected to the matrix. 

• > 0 if the primary interconnection port of the extender module is 
currently connected to the matrix. 
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Field Entry/Status Description 
Fixed - /  If ticked, this EXT Unit represents one fixed port extender module (e.g., 

USB 2.0 CON Unit, USB 2.0 CPU Unit). No other extender module works 
at this port. 

HDCP Active - /  If ticked, HDCP is active on the respective extender module (retrieved 
automatically). 

Assigned Device - CPU Device or CON Device assigned to an EXT Unit. 

Redundant Port -, 0 or >0 • 0 if there is no redundant port or if the redundant interconnection port 
of the extender module is currently not connected to the matrix. 

• > 0 if the redundant interconnection port of the extender module is 
currently connected to the matrix or to a matrix grid. 

• - if the extender module does not have a redundant interconnection 
port. 

 
6.7.1.1 Displaying Extender Module Firmware Version 
1. Click Extender & Devices > EXT Units in the task area. 
2. Select the EXT Unit of an extender module to be displayed. 

The Firmware Version overview is displayed on the right-hand side of the working area. 

 

 

Fig. 55 Menu Extender & Devices - EXT Units - Firmware Version  
 

 Add-on modules are shown together with the associated extender module in one EXT Unit. 
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6.7.1.2 Displaying Extender Module Type 
To display the type data of an extender module, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Select the EXT Unit of the extender module whose type is to be displayed. 
3. Click the Extender Module Type tab on the right side of the working area. 

The extender module type is displayed. 

− The Basic column stands for the extender module of the selected EXT Unit. 

− The Add-on Module column stands for the add-on module of the selected EXT Unit. 
4. Click on the button Expert View to display more parameters for input signals and output signals. 

 

 

Fig. 56 Menu Extender & Devices - EXT Units - Extender Module Type - Expert View  
 
The tabs “USB HID Ghosting” and “EDID” are CPU-specific and explained in section 6.7.6, page 92. 
 
6.7.1.3 Renaming an EXT Unit 
To rename an EXT Unit after initially connecting an extender module to the matrix, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of an extender module to be renamed. 
4. Delete the name in the Name field and enter the new name. 
5. Click Apply to confirm the changes. 
6. Click Deactivate Edit Mode in the toolbar. 
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6.7.2 Managing Extender Parameters 
Extender module related parameters can be read out, displayed, and changed in this menu. The behavior of the 
parameters depends on the individual extender modules. Please refer to the manual of the respective extender 
module to get information about what the displayed parameters mean. 
 

 

 

Fig. 57 Menu Extender & Devices - EXT Units - Read parameters  
 

The following functions are available in the Parameters tab: 

Button Function 
Open… Open locally saved parameters. 

Save As… Save the parameters locally (file Config.txt). 

Read Read the parameters of the extender module. 

Transmit Transmit the parameters to the extender module and activate. 

Reset Reset the parameters of the extender module to factory settings. 

Assign Assign the parameters to several extender modules at the same time. 
 

NOTICE 

Reading and writing parameters will result in an interruption of the connection. Do not execute this procedure in live 
operation. 
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6.7.2.1 Reading Parameters 
To read out and display parameters of an extender module, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the extender module whose parameters are to be displayed. 
4. Click the Parameters tab on the right side of the working area. 
5. Click the button Read in the toolbar of the tab. 

A notification appears. 

 

 

Fig. 58 Notification Extender & Devices - EXT Units - Reading Parameters 
 

6. Click Yes to confirm the reading. 
 

The parameters of the extender module are read out and displayed on the right side of the working area. At the 
same time, the connection will be disconnected for a few seconds. 

 

 

Fig. 59 Menu Extender & Devices - EXT Units - Displayed parameters 
 

 The parameters depend on the type and firmware version of the extender module. To find out more about 
possible extender module parameters, please refer to the respective extender module manual or contact the 
manufacturer’s technical support. 
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6.7.2.2 Changing Parameters 
To change parameters of an extender module, proceed as follows: 
1. Read the parameters as described in the previous section. 
2. Change the parameters. 
3. Click Transmit. 

A query for transmission appears. 
4. Click Yes to transmit the modified parameters to the extender module. 

The connection is interrupted for a short time. The progress of the transmission of parameters is displayed. 
5. Click Close when the transmission is completed (green line). 

 

 

Fig. 60 Menu Extender & Devices - EXT Units - Transmission finished 
 

6. Click Deactivate Edit Mode in the toolbar. 
 

 
6.7.2.3 Assigning Parameters 
To assign parameters of an extender module to another one, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the extender module whose parameters are to be displayed. 
4. Click the Parameters tab on the right side of the working area. 
5. Click Read in the toolbar of the tab. 

A notification appears. 
6. Click Yes to confirm the reading. 

The parameters of the extender module are read out and displayed on the right side of the working area. At the 
same time, the connection will be disconnected for a few seconds. 

7. Click Assign. 
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Fig. 61 Menu Extender & Devices - EXT Units - Select EXT Units 
 

8. Select the EXT Units of those extender modules the currently displayed parameters should be assigned to. By 
pressing and holding down Ctrl at the same time, more than one EXT Unit can be highlighted. 

9. Click  to move the highlighted EXT Units to the Assign settings to list. By clicking , all EXT Units will be 
moved to the Assign settings to list. 

10. To remove highlighted EXT Units from the Assign settings to list, click . By clicking , all EXT Units will be 
removed from the Assign settings to list. 

11. Click Next >. 
A query to start the assignment appears. 

 

 

 

Fig. 62 Menu Extender & Devices - EXT Units - Start parameter assignment 
 

12. Tick the Confirm to continue checkbox to confirm the start of the assignment. 
13. Click Next > to start the assignment. 

The progress of the parameter assignment is displayed. 
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Fig. 63 Menu Extender & Devices - EXT Units - Assignment finished 
 

14. Click Finish when the parameter assignment is completed (green line).  
15. Click Deactivate Edit Mode in the toolbar. 
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6.7.3 Manual Creation and Configuration of Fixed Port EXT Units 
There are three types of Fixed Port EXT Units. 

• USB 2.0 CON/CPU Unit: To connect a CON/CPU extender module via USB cable (see following 
section). 

• Cascading CON/CPU Unit:  Necessary for creating a cascaded system of two matrices (see section 6.12, 
page 153. 

• Fixed CON/CPU Unit: Useful in systems where it is necessary to be able to exchange faulty extender 
modules without any need to change the configuration. 

 
6.7.3.1 Configuring EXT Units for USB 2.0 Extender Modules 
To use USB 2.0 extender modules, the respective EXT Unit has to be created manually and be configured as fixed 
port in this menu. USB 2.0 EXT Units can be configured for independent switching or can be assigned to already 
existing CON Devices or CPU Devices. 
 

1. Select Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click New Unit. 

A selection dialog appears. 

 The selection menu only contains the entries Fixed CON Unit and Fixed CPU Unit with matrix firmware version 
5.04 or higher. 
 

 

 

Fig. 64 Dialog New EXT Unit  
 

4. Click on the arrow to open a drop-down menu and select either USB 2.0 CON Unit or USB 2.0 CPU Unit. 
An EXT Unit with an eight-digit ID will be created, starting with digit 9. 
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Fig. 65 Menu Extender & Devices - EXT Units - Extender Type - USB 2.0  
 
 

5. Enter an appropriate name for the EXT Unit in the Name field. 
6. Enter the port number of the matrix in the Port field to which the USB 2.0 stand-alone extender module is 

physically connected. 
7. Click Apply to confirm the creation of the EXT Unit. 

A dialog appears to restart the I/O board. 

 

 

Fig. 66 Dialog Activate USB Fixed Port  
 

8. Click Yes to restart the I/O board to activate the fixed port for the new EXT Unit. 
After restarting the I/O board, the parameters and settings of the USB 2.0 extender module are shown in the 
working area of the respective EXT Unit. 

9. The USB 2.0 CPU/CON EXT Unit has to be either assigned to an existing CPU/CON Device or a new 
CPU/CON Device has to be created for the assignment: 

• for a CPU Device see section 6.8, page 106 

• for a CON Device see section 6.8.8, page 113 
10. If you use parallel operation within the matrix, set the Release Time in the System Settings > Switch menu to 

10 s or more (see section 6.5.6, page 48). 
The USB 2.0 EXT Unit is now configured and can be used. 
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 Manually created EXT Units are always set as fixed port EXT Units. This configuration is necessary if you want to 
switch, e.g., USB 2.0 connections via the matrix. 
To make a fixed port available again for Flex Port EXT Units after deleting a fixed port EXT Unit, a restart of the I/O 
board is necessary. 
 
 

6.7.4 Configuring EXT Units for USB 3.0  Extender Modules 
To use USB 3.0 extender modules connected to a UNI I/O board, SFP modules based on 6.25 Gbit/s are required. 
USB 2.0 extender modules can alternatively be connected to fixed ports of I/O boards (see section 6.7.3, page 87). 

 

 

Fig. 67 Menu Extender & Devices - EXT Units - Configuring EXT Units at UNI I/O Boards 
 
To configure an I/O port for use with USB 3.0 extender modules, proceed as follows: 
1. Select Extender & Devices > EXT Units in the task area. 
2. Insert a UNI I/O board with fiber or Cat X SFPs to the matrix and connect the USB 3.0 extender module 

according to the required application. 
 

 An EXT UNIT will only be created for a port when an SFP is inserted. If the SFP is removed, the extender is 
displayed with port 0. The ID of the EXT Unit is the serial number of the I/O board plus the port number within the I/O 
board. This makes the IDs one digit longer. The appropriate types always start with “UNI”. 
 

3. To configure a UNI EXT Unit as a EXT-CON Unit: 
3.1. Select one of the UNI EXT Units in the EXT Units list that are physically connected to a USB 3.0 CON Unit. 
3.2. Select the item UNI USB CON in the Type selection box of the Extender Module Type tab. 
3.3. Click Apply to confirm the setting. 
3.4. Click Yes to restart the I/O board upon request in the dialog. 
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4. To configure an EXT Unit as a CPU Unit: 
4.1. Select one of the EXT Units in the Ext Units list that are physically connected to a USB CPU Unit. 
4.2. Select the item UNI CPU USB in the Type selection box of the Extender Module Type tab. 
4.3. Click Apply to confirm the setting. 
4.4. Click Yes to restart the I/O board upon request in the dialog. 

5. The USB 3.0 CPU/CON EXT Unit has to be either assigned to an existing CPU/CON Device or a new 
CPU/CON Device has to be created for the assignment: 

• for a CPU Device see section 6.8, page 106 

• for a CON Device see section 6.8.8, page 113 
After assigning EXT Units to CON/CPU Devices, the USB 3.0 CON/CPU Ext Units are configured and can be 
used. 

6. If you use parallel operation within the matrix, set the Release Time in the System Settings > Switch menu to 
10 s or more (see section 6.5.6, page 48). 

 

 If changing an EXT Unit from a USB CON to a USB CPU, a restart of the I/O board is necessary. 
 
 

6.7.5 Configuring EXT Units for native 3G SDI Usage 
For the use of SDI (Serial Digital Interface), the matrix has to be configured in this menu. Using SDI requires at least 
one UNI I/O board and appropriate SDI SFP modules according to the SDI video signal to be used. 

 

 

Fig. 68 Menu Extender & Devices - EXT Units - Configuring EXT Units  
 

To configure an SFP for using as an SDI input/output, proceed as follows: 
1. Select Extender & Devices > EXT Units in the task area. 
2. Insert an I/O board with SDI connectors to the matrix and connect the SDI extender module according to the 

required application. 
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 An EXT UNIT will only be created for a port when an SFP is inserted. If the SFP is removed, the extender is 
displayed with port 0. The ID of the EXT Unit is the serial number of the I/O board plus the port number within the I/O 
board. This makes the IDs one digit longer. The appropriate names always start with “UNI”. 
 

3. To configure an EXT Unit as an SDI input: 
3.1. Select one of the extender modules in the EXT Units list that are physically connected to an SDI CON Unit. 
3.2. Select the UNI CPU item in the Type selection box of the Extender Module Type tab. 
3.3. Click Apply to confirm the setting. 
3.4. Click Yes to restart the I/O board upon request in the dialog. 

4. To configure an EXT Unit as an SDI output: 
4.1. Select one of the extender modules in the Ext Units list that are physically connected to an SDI CPU Unit. 
4.2. Select the UNI CON item in the Type selection box of the Extender Module Type tab. 
4.3. Click Apply to confirm the setting. 
4.4. Click Yes to restart the I/O board upon request in the dialog. 

5. The edited EXT Units for the SDI inputs and outputs have to be either assigned to an existing CPU/CON Device 
or a new CPU/CON Device has to be created for the assignment: 

• for a CPU Device see section 6.8, page 106 

• for a CON Device see section 6.8.8, page 113 
After assigning EXT Units to CON/CPU Devices, the SDI inputs and outputs are configured and can be used. 

 

 If changing a UNI Unit from a UNI CON to a UNI CPU, a restart of the I/O board is necessary. UNI ports of type 
CON can only be assigned to CON Devices, UNI ports of type CPU can only be assigned to CPU Devices. After 
classification into CONs and CPUs, CONs can only be switched to CPUs and vice versa. It is not possible to switch a 
CON to another CON or a CPU to another CPU. 
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6.7.6 Configuring Specific CPU Extender Module Settings 
6.7.6.1 Managing USB-HID Ghosting 
This function allows specific keyboard and mice descriptors (device descriptions) to be permanently stored in the 
CPU Unit. This eliminates the need to register and deregister the keyboard and mouse on an operating system each 
time there is a shared use of a source by two or more consoles within a matrix.  
Next to the use of keyboard commands (see matrix user manual), the activation and management of the USB-HID 
Ghosting information can also be handled centrally via matrix to reach all connected extender modules at the same 
time. 

 We strongly recommend the usage of USB-HID Ghosting when configuring Multi-Screen Control. 

 

General Preparation 
To use the USBHID Ghosting management via Tera Tool software, it is required that USB-HID Ghosting has already 
been activated at at least one CPU Unit via keyboard command or the USB-HID Ghosting information is already 
available as a file with the file extension *.dhg.  

Several general options are available.  
1. Click Extender & Devices > EXT Units in the task area. 
2. Select a CPU EXT Unit and click the USB HID Ghosting tab in the working area. 

 

 

Fig. 69 Menu Extender & Devices - EXT Units - USB HID Ghosting  
 

The following functions are available in the USB HID Ghosting tab: 

Button Function 
Open… Open the locally saved USB-HID Ghosting file. 

Save As… Save the USB-HID Ghosting locally (EXT_ID-Nr.dhg file e.g. 40069453.dhg). 

Read Read the USB-HID Ghosting of the extender module. 
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Button Function 
Transmit Transmit the USB-HID Ghosting to the extender module and activate. 

Activate Activate temporarily deactivated USB-HID Ghosting. 

Deactivate Deactivate the USB-HID Ghosting. The USB descriptor is not deleted. It is still stored in 
the extender but not used. 

Reset Reset the USB-HID Ghosting of the extender module to factory settings. The USB 
descriptor will be deleted, and USB-HID Ghosting is no longer active. 

Assign Assign the USB-HID Ghosting to several extender modules at the same time 
 

NOTICE 

While reading and writing USB-HID Ghosting information, there will be a short interrupt of the USB-HID and video 
signal. 

 

Reading USB-HID Ghosting 
To read out and display the USB-HID Ghosting of CPU extender modules, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the CPU extender module with active USB-HID Ghosting to be displayed. 
4. Click the USB HID Ghosting tab on the right side of the working area. 
5. Click Read in the symbol bar of the tab. 

A query to read the USB-HID Ghosting appears. 

 

 

Fig. 70 Notification Extender & Devices - EXT Units - Reading USB-HID Ghosting  
 

6. Click Yes to confirm the reading. 
The current USB-HID Ghosting information of the CPU extender module is read out and displayed on the right 
side of the working area. At the same time, the connection will be disconnected for a few seconds. 
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Fig. 71 Display of USB-HID Ghosting information read out 
 

Loading a USB-HID Ghosting Template 
To load a USB-HID Ghosting template (file extension: *.dhg) for a further distribution proceed as follows: ??? 

1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the CPU extender module to transmit the USB-HID Ghosting to. 
4. Click the USB HID Ghosting tab on the right side of the working area. 
5. Click Open in the symbol bar of the tab. 
6. Go to the storage location of the respective template with the file extension *.dhg, select the desired template to 

be loaded and click Select in the dialog. 

 

 

Fig. 72 Selection dialog Extender & Devices - EXT Units - Opening USB-HID Ghosting template 
 

7. The USB-HID Ghosting template is displayed on the right side of the working area. 
8. Click Transmit in the symbol bar of the tab. 

A query for transmission appears. 
9. Click Yes to transmit the loaded USB-HID Ghosting to the CPU extender module. 
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The progress of the transmission is displayed. 
10. Click Close when the USB-HID Ghosting transmission is completed (green line). 

 

 

Fig. 73 Menu Extender & Devices - EXT Units - Transmission finished 
 

11. Click Deactivate Edit Mode in the toolbar. 
 

Assigning USB-HID Ghosting 
To assign any manually activated USB-HID Ghosting of a CPU extender module to any to the matrix connected CPU 
extender module, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the CPU extender module with active USB-HID Ghosting to be displayed. 
4. Click the USB-HID Ghosting tab on the right side of the working area. 
5. Click Read in the symbol bar of the tab. 

A query to read the USB-HID Ghosting appears. 
6. Click Yes to confirm the reading. 

The current USB-HID Ghosting information of the CPU extender module is read out and displayed on the right 
side of the working area. At the same time, the connection will be disconnected for a few seconds. 

7. Click Assign in the symbol bar of the tab. 
A dialog to assign the USB-HID Ghosting appears. 
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Fig. 74 Menu Extender & Devices - EXT Units - Assign USB-HID Ghosting to 
 

8. Select those EXT Units in the Available to assign settings to field that are intended to receive the USB-HID 
Ghosting information. By pressing and holding down Ctrl at the same time, more than one EXT Unit can be 
highlighted. 

9. Click  to move the highlighted EXT Units to the Assign settings to list. By clicking , all EXT Units will be 
moved to the Assign settings to list. 

10. To remove highlighted EXT Units from the Assign settings to list, click . By clicking , all EXT Units will be 
removed from the Assign settings to list. 

11. Click Next >. 
A query to start the assignment appears. 

 

 

Fig. 75 Query Extender & Devices - EXT Units - Confirm assignment 
 

12. Tick the Confirm to continue checkbox to confirm the assignment. 
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13. Click Next > to start the assignment process. 
The progress of the USB-HID Ghosting assignment is displayed. 

14. Click Finish when the USB-HID Ghosting assignment is completed (green). 

 

 

Fig. 76 Menu Extender & Devices - EXT Units - Assignment finished 
 

The USB-HID Ghosting assignment is finished. 
15. Click Deactivate Edit Mode in the toolbar. 
 

Further options: 

• To locally store existing USB-HID Ghosting information of a selected CPU EXT Unit, click Save As… in the 
symbol bar of the tab. 

• To delete existing USB-HID Ghosting information of a selected CPU EXT Unit, click Reset in the symbol bar of 
the tab. 
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6.7.6.2 Managing EDID Transfer 
By default, the CPU extender modules transmit the factory preset EDID to the sources. This information is suitable in 
most cases. The EDID can be retrieved and uploaded as a binary file to the CPU Unit. 
Next to the use of keyboard commands (see matrix user manual), the management of the EDID can also be handled 
centrally via matrix to reach all connected extender modules at the same time. 

General Preparation 
To use EDID management via Tera Tool software it is required that the EDID has already been transmitted to a 
CPU Unit via keyboard command or the EDID is already available as a file with the file extension *.bin.  

Several general options are available.  
1. Select the menu Extender & Devices > EXT Units in the task area. 
2. Select the EXT Unit of an extender module and select the EDID tab (EDID 2 for dual head) in the working area. 

 

 

Fig. 77 Menu Extender & Devices - EXT Units - EDID  
 

Button Function 
Open… Open the locally saved EDID. 

Save As… Save the EDID locally (file extension: .bin). 

Read Read the EDID of the extender module. 

Transmit Transmit the EDID to the extender module and activate the EDID. 

Reset Reset the EDID of the extender module to factory settings. 

Assign Assign the EDID to several extender modules at the same time. 
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Reading an EDID 
To read out and display the EDID of an extender module, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the extender module whose EDID is to be displayed. 
4. Click the EDID tab on the right side of the working area. 
5. Click Read in the symbol bar of the tab. 

A query to read out the EDID appears. 

 

 

Fig. 78 Query Extender & Devices - EXT Units - Reading EDID  
 

6. Click Yes to confirm the reading. 
 

The EDID of the extender module is read out and displayed. At the same time, the connection will be 
disconnected for a few seconds. 

 

 

Fig. 79 Tab Extender & Devices - EXT Units - EDID - EDID information displayed 
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Loading an EDID Template 
To load an EDID template (file extension: *.bin) for further distribution, proceed as follows: 

1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the EDID tab on the right side of the working area. 
4. Select the EXT Unit of a CPU extender module to transmit the EDID to. 
5. Click Open in the symbol bar of the tab. 
6. Go to the storage location of the respective template with the file extension *.bin, click it and click Select in the 

dialog. 

 

 

Fig. 80 Menu Extender & Devices - EXT Units - Loading EDID 
 

The EDID is displayed on the right side of the working area. 
7. Click Transmit in the symbol bar of the tab. 

A query for transmission appears. 
8. Click Yes to transmit the loaded EDID to the CPU extender module. 

The progress of the transmission is displayed. 
9. Click Close when the EDID transmission is completed (green). 

 

 

Fig. 81 Menu Extender & Devices - EXT Units - Transmission finished 
 

10. Click Deactivate Edit Mode in the toolbar. 
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Further options: 

• To locally store existing EDID of a CPU extender module whose EXT Unit is selected, click Save As… in the 
symbol bar of the tab. 

• To set the existing EDID of a CPU extender module whose EXT Unit is selected back to factory settings, click 
Reset in the symbol bar of the tab. 

 

Assigning an EDID 
To assign any manually transmitted EDID of an extender module to another one, proceed as follows: 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the extender module with the already transmitted EDID. 
4. Click the EDID tab on the right side of the working area. 
5. Read out and display the EDID (see description in section before). 
6. Click Assign in the symbol bar of the tab. 

A dialog to assign the EDID appears. 

 

 

Fig. 82 Dialog Extender & Devices - EXT Units - Assign EDID to 
 

7. Select the EXT Units of those extender modules in the Available to assign settings to field that are intended to 
receive the EDID. By pressing and holding down Ctrl at the same time, more than one EXT Unit can be 
highlighted. 

8. Click  to move the highlighted EXT Units to the Assign settings to list. By clicking , all EXT Units will be 
moved to the Assign settings to list. 

9. To remove highlighted EXT Units from the Assign settings to list, click . By clicking , all EXT Units will be 
removed from the Assign settings to list. 

10. Click Next >. 
A query to start the assignment appears. 
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Fig. 83 Query Extender & Devices - EXT Units - Confirm assignment 
 

11. Tick the Confirm to continue checkbox to confirm the start of the assignment. 
12. Click Next >to start of the assignment. 

The progress of the EDID assignment is displayed. 
13. Click Finish when the EDID assignment is completed (green). 

 

 

Fig. 84 Menu Extender & Devices - EXT Units - EDID Assignment finished 
 

The EDID assignment is finished. 
14. Click Deactivate Edit Mode in the toolbar. 
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6.7.7 Configuring Specific CON Extender Module Settings 
 

6.7.7.1 Configuring Mouse and Keyboard Settings 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON EXT Unit in the EXT Units list whose OSD Control settings have to be adjusted. 
4. Click the OSD Control Settings tab. 

The mouse and keyboard settings for the OSD Control of a CON extender module that is connected to a matrix 
are made in this menu. 

 

 

Fig. 85 Menu Extender & Devices - EXT Units - OSD Control Settings  
 

The following parameters can be configured for controlling the OSD: 

Field Entry/Status Description 
Horizontal Mouse 
Speed [1/x] 

1 to 9 Adjusts the horizontal mouse speed, 1 = slow, 9 = fast (default: 4). 

Vertical Mouse Speed 
[1/x] 

1 to 9 Adjusts the vertical mouse speed, 1 = slow, 9 = fast (default: 5). 

Double Click Time 
[ms] 

100 to 800 Adjusts the time slot for a double-click (default: 200 ms). 

Keyboard Layout Region Sets the OSD keyboard layout according to the used keyboard (default: 
German (DE)). 

Video Mode Variable or 
specific 
resolution 

Sets the resolution that is used when opening the OSD. 

Hot Key Keyboard 
command 

Starts the command mode via keyboard sequence. 

Fast Key Keyboard 
command 

Opens the OSD via direct access. 
How often the shortcut key has to be pressed depends on the specified 
key: 1x for function keys or print key, 2x for all other keys. 

 The settings for the mouse and keyboard are CON EXT Unit-specific and can be set for each CON EXT Unit. 
 
5. Change the desired settings. 
6. Click Apply to confirm your entries. 
7. Click Deactivate Edit Mode in the toolbar. 
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6.7.7.2 Setting optional OSD Functions for CON Extender Modules 
Additional to the standard OSD for extender modules connected to a matrix, there are two local OSD setting options 
that can be defined individually for each CON Extender module. 

• The standard OSD can be reduced to a smaller and translucent OSD to display only the switch menu when 
opening the OSD. 

• A second OSD can be enabled and set to show the current connection info. 

 If the Update Connection Info function is deactivated, the Connection Info only appears on the monitor when 
switching via OSD. 
 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the EXT Unit of the CON extender module whose OSD settings have to be changed. 
4. Click the Extender OSD Settings tab. 
 

 

 

Fig. 86 Menu Extender & Devices - EXT Units - Extender OSD Settings  
 

The following parameters can be configured: 

Field Entry/Status Description 
Extender Module OSD Activated Enables a smaller and translucent Switch menu with selectable CPU 

Devices displayed in the center of the monitor. 
When entering the keyboard command for opening the OSD, a selection list 
for switching CPU Devices will be displayed in the center of the monitor. 
Pressing F7 within the selection list opens the standard OSD menu 
(Default). 

Deactivated Function not active. 

Connection Info Activated Enables a small OSD on the CON extender module to show the current 
CPU Device connection after closing the OSD (default). 

Deactivated Function not active. 
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Field Entry/Status Description 
Update Connection 
Info 

Activated Updates every change of the extender module connection status by fade-in 
of the extender module OSD (e.g., sharing situation) (default). 

Deactivated Function not active. 

Display Time [sec] 
Horizontal Position 
[10 px] 

0 to 999 
seconds 

Sets the fade-in duration of the connection info (0 = unlimited, default: 10) 

-127 to 
+127 pixels 

Horizontal Update connection info position (default: -2). 
Sets the entered value x 10 px from the left border (range: 0 to +127), 
e.g., value 5 means 50 px distance to the left border. 
Sets the entered value x 10 px from the right border (range: -1 to -127), 
e.g., -5 means 50 px distance to the right border. 

Vertical Position 
[10 px] 
Display Time [sec] 

-127 to 
+127 pixels 

Vertical Update connection info position (default: 3) 
Sets the entered value x 10 px from the top border (range: 0 to +127), 
e.g., value 5 means 50 px distance to the top border. 
Sets the entered value x 10px from the bottom border (range: -1 to -127), 
e.g., value -5 means 50 px distance to the bottom border 

0 to 999 
seconds 

Sets the fade-in duration of the connection info (0 = unlimited, default: 10) 

Horizontal Position 
[10 px] 
Vertical Position 
[10 px] 

-127 to 
+127 pixels 

Horizontal Update connection info position (default: -2). 
Sets the entered value x 10 px from the left border (range: 0 to +127), 
e.g., value 5 means 50 px distance to the left border. 
Sets the entered value x 10 px from the right border (range: -1 to -127), 
e.g., -5 means 50 px distance to the right border. 

-127 to 
+127 pixels 

Vertical Update connection info position (default: 3) 
Sets the entered value x 10 px from the top border (range: 0 to +127), 
e.g., value 5 means 50 px distance to the top border. 
Sets the entered value x 10px from the bottom border (range: -1 to -127), 
e.g., value -5 means 50 px distance to the bottom border 

OSD Position Preset 
 

Selection list Selects a preset position for the connection info OSD:  
Centered, Top Left, Top Right, Bottom Left, Bottom Right, Custom 

 
5. Change the desired settings. 
6. Click Apply to confirm your entries. 
7. Click Deactivate Edit Mode in the toolbar. 
 

 For an efficient CON extender OSD configuration, OSD settings can be assigned to CON extender modules (see 
description in section 6.10.1, page 139) or be copied from a CON extender module (see section 6.10.2, page 141). 
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6.8 Setting CPU Devices 
New CPU Devices are configured in this menu including their assignment to EXT Units. 
The assignment helps to describe and switch more complex computer configurations (e.g., Quad-Head with USB 2.0) 
in the matrix. To run a CPU Device via a matrix, one or more CPU EXT Units must be assigned. 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 

The following window is displayed. 

 
Fig. 87 Menu Extender & Devices - CPU Devices - EXT Unit Assignment  
 

The following parameters can be configured: 

Field Entry/Status Description 
ID Text Ident number of the CPU Device (max. value 32767) 

Name Text Name of the CPU Device 

Virtual Device Activated Automatically set for a Virtual CPU Device. 

Deactivated Function not active (default). 

Allow Private Activated Allows switching to the respective CPU Device in Private Mode. 

Deactivated Function not active (default). 

Force Private Activated Forces switching to the respective CPU Device only in Private Mode. 

Deactivated Function not active (default). 

Fix Frame Color 
 

Selection list Shows a colored frame when switching to the respective CPU Device. 7 
colors available. 

Reference Activated Enables a reference CPU Device that passes both Device and EXT Unit 
settings to any CPU Unit that is connected to the matrix for the first time. 
Note: The reference setting should be activated for one single CPU 
Device only. 

Deactivated Function not active (default). 
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Field Entry/Status Description 
2 Step Access Activated When someone else has a Full Access connection to a particular CPU 

Device, a pop-up window appears after switching to this CPU Device. In 
the background a Video Only connection will be established (Sharing 
situation). A confirmation in the pop-up window is required to establish a 
Full Access connection to the CPU Device.  

Deactivated Function not active (default). 

Assigned Device - ID and name of the assigned Virtual CPU Device, cannot be changed, is 
retrieved automatically. 

Connected Device - ID and name of the connected CON Device, cannot be changed, is 
retrieved automatically. 

CPU Device Colors Selection list Highlights the CPU Device name according to the color setting for text 
and background. 16 colors are available. Works only if the option “Show 
CPU” is active (see section 6.5.5, page 46). 

Exclusive Access Activated Enables an access limitation for the case that a CPU Device is already 
connected via Full Access connection. When having the same priorities, 
any additional access to the CPU Device can only be established with a 
Video Only connection. Having a lower priority any additional connection 
is not possible. Only when having a higher priority, an additional Full 
Access connection can be established, and K/M control can be taken 
over. 

Deactivated Function not active (default). 

MSC Disabled Activated Disables the MSC function. When MSC is active, mouse coordinates do 
not change to absolute for this CPU Device.  

Deactivated Enables the MSC function (default). 

Access Dialog Activated When a user tries to connect to another CPU Device, the current user of 
the CPU Device gets a message and must explicitly allow shared access 
or the takeover of control. 

Deactivated Function not active (default). 

Follow Session Activated If several CON Devices are connected in sharing with one IP CPU Device 
session, the connection to all CON Devices remains intact when the 
session is switched. 

Deactivated Function not active (default). This means the shared CON Devices 
(without Full Access) are disconnected when the CON Device with Full 
Access switches to another session of the IP CPU Device. 

Display Time [sec] -99 to +99 
seconds 

Time of displaying the Access dialog: 
With positive value +1 to +99, the CPU Device is accessed after the set 
time has expired. 
With negative value -99 to 0 there is no access to the CPU Device after 
the set time has expired. 

Delay [sec] 0 to 99 
seconds 

Time until the next positive request. 
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6.8.1 Creating a new CPU Device 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click New Device.  

A selection menu appears. 

 
Fig. 88 Selection menu Extender & Devices - CPU Devices - Selection of CPU Device type 
 

4. Click OK. 
A new Real CPU Device will be created. 

5. Determine all parameters that are relevant for the CPU Device. 
6. Click Apply to confirm the creation of the CPU Device. 
 

 If creating a Virtual CPU Device, the Virtual CPU Device has to be assigned to a Real CPU Device (see section 0, 
page 110). A template is only available if there is at least one existing CPU Device. 
 

 

6.8.2 Changing Settings of a CPU Device 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a CPU Device in the CPU Device list. 
4. Change the desired settings. 
5. Click Apply to confirm the changes. 
 

6.8.3 Assigning an EXT Unit to a CPU Device 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the new CPU Device in the CPU Devices list. 
4. Select an EXT Unit in the EXT Units available list that you want to assign to the CPU Device. By pressing and 

holding down Ctrl at the same time, more than one EXT Unit can be highlighted. 
5. Click  to move the highlighted EXT Units to the EXT Units assigned list. By clicking , all available EXT Units 

from the EXT Units available list will be moved to the EXT Units assigned list. 
The assignments are displayed in the EXT Units assigned list. 

6. Click  or  to change the order of the EXT Units within the EXT Units assigned list. 
Or press + or - to change the order of the EXT Units within the EXT Units assigned list. 

7. Click Apply to confirm the assignment. 
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6.8.4 Unassigning an EXT Unit from a CPU Device 
To remove an EXT Unit assignment, e.g., for servicing or replacing a faulty extender unit, proceed as follows: 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a CPU Device in the CPU Devices list. 
4. Select one or more EXT Units in the EXT Units assigned list. 
5. To remove highlighted EXT Units from the EXT Units assigned list, click . By clicking , all CPU Devices will 

be removed from the EXT Units assigned list. 
6. Click Apply to confirm the removal. 
 
 

6.8.5 Setting CON Device Access Rights for CPU Devices 
 

 The settings made here are only considered when “CON ACL” is active (see section 6.5.5, page 46). Otherwise, 
they are ignored. 
 

1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CPU Device in the CPU Devices list which should get access rights by a CON Device.  
4. Click the CON Device Access Control tab. 

 

 

Fig. 89 Menu Extender & Devices - CPU Devices - CON Device Access Control  
 

5. By clicking with the right mouse button once on a CON Device in one of the respective access lists (Full Access, 
Video Access, and No Access), a context menu for selection appears for changing the respective CON Device 
access rights. Alternatively, press f, v, or n to set the respective access rights. 

6. Click Apply to confirm the changes. 
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6.8.6 Assigning Virtual CPU Devices 
In this menu, either one or more Virtual CPU Devices can be assigned to a Real CPU Device. 
With a Virtual CPU Device, the effort of switching several CON Devices to the same CPU Device can be reduced. If 
several CON Devices are connected to a Virtual CPU Device that is assigned to a Real CPU Device, you only have 
to change the Real CPU Device once and all CON Devices will receive the video signal of the new Real CPU Device. 
 

Some important remarks 
- A Real CPU Device can be assigned to several Virtual CPU Devices. 
- A Real CPU Device can still be connected individually, even if it has been assigned to a Virtual CPU Device. 
- Power, Super or Administrator role is necessary to change Virtual Device assignments. 
- Virtual CPU Device assignments can be changed during normal operation by Tera Tool, OSD, API command 

or macro. 
 

NOTICE 

If the Auto Send checkbox is ticked in the lower left corner of the working area, the switching operations will be 
performed immediately without user confirmation by clicking Send. 

 
1. Click Assignment > Virtual CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 90 Menu Assignment - Virtual CPU Devices  
 

The following functions are available: 

Button Function 
Send Send assignments to the matrix 

Reload Reload changes 
 

 The selection boxes in the Real CPU Device column contain a filter function for an easy selection of a single 
CPU Device from a larger pool of CPU Devices. 
 

3. Select a Virtual CPU Device in the Virtual CPU Device list. 
4. Double-click in the Real CPU Device column to display a list of all available Real CPU Devices. 
5. Select a Real CPU Device in the selection list. 
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6. Click Send to send the assignment to the matrix. 
The Tera Tool software offers the option to switch directly from the Assignment menu to the definition menu to 
check specific settings for the respective Real CPU Device or Virtual CPU Device. 
 Click with the right mouse button on the respective Real CPU Device or Virtual CPU Device and select Open 

CPU Device in the context menu. 
The definition menu for the CPU Device settings is opened (see page 106). 

 
 

6.8.7 Setting CPU Device Groups 
The KVM matrix permits to bundle the CPU Devices of a configuration into CPU groups. The groups can be used to 
subdivide the CPU Devices logically or thematically. As an application example you can group all CPU Devices 
together that are connected to a specific matrix within a matrix grid. The configuration of CPU groups at the same 
time increases the clarity of the configuration. 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the CPU Device Groups tab in the working area. 

 

 

Fig. 91 Menu Extender & Devices - CPU Devices - CPU Groups  
 
 

6.8.7.1 Creating a new CPU Device Group 
4. Click New Group. 
5. Enter a CPU Device group name into the field Name. 
6. Click Apply to confirm the creation of the group. 
 

 After creating the first group, a template is available in a selection box that appears after clicking New Group. 
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6.8.7.2 Assigning a CPU Device to a CPU Group 

 A Device can only be assigned to one group at the same time. The OSD can only show one group layer. 
Therefore, you should not assign a group to another group. 
 

1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the CPU Device Group tab in the working area. 
4. Select the CPU Device Group to be assigned with a CPU Device. 
5. Select a CPU Device in the list CPU Device/Group available that you want to assign to the CPU Device Group. 

By pressing and holding down Ctrl at the same time, more than one CPU Device can be highlighted. 
6. Click  to move the highlighted CPU Devices to the CPU Device/Group assigned list. By clicking , all 

CPU Devices from the CPU Device/Group available list will be moved to the CPU Device/Group assigned list. 
7. To remove highlighted CPU Devices from the CPU Device/Group assigned list, click . If clicking , all 

CPU Devices will be removed from the CPU Device/Group assigned list. 
8. Click Apply to assign the CPU Device to the CPU Device Group. 
 
 

6.8.7.3 Configuring CON Device Access Rights for CPU Device Groups 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the CPU Device Groups tab in the working area. 
4. Select a CPU Device Group in the CPU Device Groups list. 
5. Click the tab CON Device Access Control. 

 

 

Fig. 92 Menu Extender & Devices - CPU Devices - CON Device Access Control  
 

6. By clicking with the right mouse button once on a CON Device in one of the respective access lists (Full Access, 
Video Access, and No Access), a context menu for selection appears for changing the respective CON Device 
access rights. Alternatively, press f, v, or n to set the respective access rights. 

7. Click Apply to confirm the changes. 
8. Click Deactivate Edit Mode in the toolbar. 

 For an efficient CPU Device configuration, settings can be assigned to other CPU Devices (see description in 
section 6.10.1, page 139) or be copied from another CPU Device (see section 6.10.2, page 141). 
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6.8.8 Configuring CPU Access to Virtual Machines (VDI)  
An IP/SIRA CPU extender requires an individual configuration (session) to be able to connect to a source (computer, 
CPU, virtual machines) via TCP/IP network.  

 

 

Fig. 93 Function of an IP/SIRA CPU Unit  
 

The configuration is performed solely via Draco tera matrix and consists of three parts: 
1. Creating IP Session Configs 
2. IP CPU EXT Unit and IP CPU Device configuration 
3. Assignment of the configured IP Session Config to the IP CPU Device (creating one or several 

Session Devices) 
 

  



Configuration of a Matrix via Tera Tool Software Draco Tera Tool 

114 

6.8.8.1 Configuration of an IP Session Config 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the tab IP Config Session. 

 

 

Fig. 94 Menu Extender & Devices - CPU Devices - Tab IP Session Config  
 

The figure above shows all possible parameters, but not all are available for all remote access types. The following 
table contains the common ones that are almost always present. For more details about the remote access protocols 
ask your network administrator or refer to information that is freely available on the internet. 

Field Entry/Status Description 
ID Number Ident number of the IP Session Config 

Name Text Name of the IP Session Config 

Type Text Type of remote access 

User Name Text Name of IP Session user 

Password Text Password of IP Session user  

Domain Text If the user is part of a domain, enter the domain here. 

Hostname/IP Address Text/Number Hostname or IP address of the IP CPU extender 

Port Number The standard port of the chosen remote access type is preset here. You 
can enter another port. 

Resolution Text/Number Resolution of the IP Session window, you can choose between several 
resolutions, Fullscreen means the window covers the whole screen, 
default is 1920x1080. For type VNC there are two additional entries: 
FitScreen and AutoScreen. 

Connect Timeout [sec] Number Determines how long the CPU unit waits for the establishment of a 
connection. 0 means default value (5s). 

Sound Activated Audio is transmitted, you can choose between Local (Default) or 
Remote. 

Deactivated Function not active (Default). 

SSO Login Activated Single-Sign On is enabled. 

Deactivated Function not active (Default)  
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4. Click the button New Config.  
A new IP Session Config will be created. 

 Generally, an IP Session Config can be used for multiple IP CPU extenders. 
 

 

 

Fig. 95 Menu Extender & Devices - CPU Devices - Creating new config  
 

5. Name the IP Config in the input field Name. 
6. Select the Type of remote access in the corresponding field. The displayed parameters change accordingly.  

 

 

Fig. 96 Menu Extender & Devices - CPU Devices - Adjusting new RDP config  
 

7. Insert a User Name and Password for the IP session user. The user can be a local user or part of a domain. 
7.1. If the user is a domain user, enter the Domain name into the corresponding field. 

8. If the network port of the remote access type is not the standard one (e.g. RDP port: 3389), enter the respective 
port into the input field Port.  

9. The remote connection runs in a window. Select the size of the window with Resolution. FullScreen means that 
the window fills out the entire screen. Default means 1920 x 1080. 

10. Tick Dual-Head to enable Dual-Head operation. 
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11. Set a time for how long the IP CPU unit should wait for the setup of a connection with Connect Timeout. 0 
means default value (5 seconds). 

12. If you want to transmit digital HDMI audio, check the box Sound. You can choose Local (Default) or Remote. 
13. Tick SSO Login if applicable to enable Single Sign On support of the system.  
14. Click the button Apply to confirm your configuration settings.  

 
6.8.8.2 Configuration of an IP CPU Extension Unit 
Described here is only the configuration of the network settings of the IP CPU extender.  
1. Ensure that the IP CPU extender is physically connected to the Draco tera matrix and switched on. It can take up 

to 30 seconds until it is registered at the matrix.  
2. Click Extender & Devices > EXT Units in the task area. 
3. Click Activate Edit Mode in the toolbar. 
4. Select the IP EXT CPU Unit to be configured in the list and open the tab Server Settings. 

 

 

Fig. 97 Menu Extender & Devices - CPU Devices - Server Settings of IP CPU extender  
 

5. Click the button Read to show the current network settings of the selected IP CPU EXT Unit. 
6. Enter a Hostname into the corresponding input field. 
7. When you want to use a DHCP server, check the box DHCP. 
8. Configure the remaining server settings: 

• Mandatory settings: Address, Subnet Mask, Gateway, NTP Server, Time Zone and Keyboard Layout. 
• Optional setting: DNS Server 

9. Click Apply to confirm the settings.  
10. If you have not done so already, create an IP CPU Device (see section 6.8.1, page 108) and assign the IP CPU 

EXT Unit to it. 
More information on IP CPU extenders is contained in the manual Draco Sira CPU (L488). 
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6.8.8.3 Assignment of configured IP Session Configs to an IP CPU Device 
There are two possibilities to assign an IP Session Config to an IP CPU Device: 

- Directly (only one IP Session Config possible) 
- With the button Configure IP CPU (for multiple IP Session Configs) 

Directly 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select an IP CPU device in the list. 

 

 

Fig. 98 Menu Configure IP CPU - Assign IP Config Session to an IP CPU Device  
 

4. Select an IP Session Configuration in the field IP Direct Config. 
5. Click on Apply.  
 

With the button Configure IP CPU 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the button Configure IP CPU. The following window opens. 

 

 

Fig. 99 Menu Configure IP CPU - Select an IP CPU Device  
 

4. Select an IP CPU Device and click Next >. 
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Fig. 100 Menu Configure IP CPU - Add new Session Device  
 

5. Click the button Add new Session Device.  
A new Session Device is created. 

 

 

Fig. 101 Menu Configure IP CPU - New Session Device created  
 

6. Double-click in the corresponding field in the column IP Session Config. A drop-down list of IP Session Configs 
appears. 

7. Select the desired IP Session Config. 
8. When there are no IP Session Configs or not the right ones, click the button Add new IP Session Config and 

create a suitable IP Session Config as described in section 6.8.8.1, page 114. 
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Fig. 102 Menu Configure IP CPU - Session Device complete  
 

9. After selecting the IP session Config, click the name field and rename the Session Device. 
10. Create more Session Devices if you like or click the button Finish. 

The IP CPU Unit is now configured and can be used.  
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6.9 Setting CON Devices 
A CON EXT Unit has to be assigned to a CON Device. Switching operation is only possible between CON Device 
and CPU Device. All steps to create switchable CON Devices are described in this section. Several Real CON 
Devices can be assigned to a Virtual CON Device to reduce operation efforts (see section 6.9.10, page 131). 
New CON Devices are created in this menu including access rights and assignment to EXT Units. To run a 
CON Device via a matrix, one or more CON EXT Units must be assigned. 
 

1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 
Fig. 103 Menu Extender & Devices - CON Devices - EXT Unit Assignment  
 

The following parameters can be configured: 

Field Entry/Status Description 
ID Text Ident number of the CON Device (max. 32767). 

Name Text Name of the CON Device. 

Priority 0 to 999 Priority of the CON Device. 
Note: There is no K/M sharing between CON Devices with a different 
priority and the release time does not come into account. CON Devices 
with lower priority can never switch to a CPU Device when a CON Device 
with higher priority is connected (not even Video Only). When the CON 
Device with lower priority was first connected to the CPU Device, it 
remains in Video Only mode when a CON Device with higher priority is 
switched to the CPU Device. 

Virtual Device Activated Automatically set for a Virtual CON Device. 

Deactivated Function not active (default) 

Allow User ACL Activated Enables activation of the User ACL at the local CON Device. 

Deactivated Function not active (default) 
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Field Entry/Status Description 
Force Login Activated Forces the user to login with a username and a password once to enter 

OSD. Thereafter the user remains logged in until they explicitly log out or 
an auto logout is affected. 
Note: When using the Force Login function, CON ACL and User ACL 
are not automatically active. User ACLs have to be activated separately. 
When the Force Login function is activated and a user is logged in, only 
the user favorites are available. The CON favorites are not accessible. 

Deactivated Function not active (default) 

LOS Frame Activated • When the video signal between source and the CPU Unit or the 
connection between matrix and the CON Unit is lost, an orange frame 
will be displayed. 

• When switching to a CPU Unit without video signal, a blank screen will 
appear surrounded by an orange frame. 

Deactivated Function not active (default) 

Show Macro List Activated Show the macro list instead of the CPU Device selection list. 

Deactivated Function not active (default) 

OSD Disabled Activated Disables OSD access for the respective CON Device (executing macros 
and favorite switching is still possible). Requires the deactivation of the 
“Extender Module OSD” (see section 6.7.7.2, page 104). 

Deactivated Function not active (default) 

Video Off Activated Switches off the video signal after 60 sec without connection to the 
CPU Device so that the monitor can go into stand-by mode. 

Deactivated Function not active (default) 

Show Disconnect Activated Shows a message if the connection to the CPU Device is lost. 

Deactivated Function not active (default) 

Assigned Device - ID and name of the assigned Virtual CPU Device, cannot be changed, is 
retrieved automatically. 

Connected Device - ID and name of the connected CPU Device, cannot be changed, is 
retrieved automatically. 

Allow CPU Scan Activated Allows a scan mode with an automatic change of the video signal for the 
favorite list (CPU Devices) of the respective CON Device or a logged in 
user. 
Note: An active scanner can be stopped by a mouse or keyboard event. 
You gain Full Access for the currently switched CPU Device if Force 
Connect is activated. 

Deactivated Function not active (default) 

Force CPU Scan Activated Forces a scan mode with an automatic change of the video signal for the 
favorite list (CPU Devices) of the respective CON Device or a logged in 
user. Scanning cannot be stopped if this function is active. 

Deactivated Function not active (default) 

Scan Time [sec] 0 to 99 
seconds 

Retention period until switching to the next CPU Device. 

Port Mode Activated Replaces the favorite list by a port list where the ports from 1 to 999 can be 
directly selected at each matrix or matrix grid. 
Note: The selection only works for CPU Devices and has to be made 
according to the switching of favorites. 
When using Port Mode, CON and User favorites will be deactivated. 

Deactivated Function not active (default) 
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Field Entry/Status Description 
Redundancy Off Activated Function not active 

Deactivated Switches automatically to the second link of a connected redundant 
CON Unit when losing the primary link of a CPU Unit (default). 

Reference Activated Enables a reference CON Device that inherits both Device and EXT Unit 
to any CON Unit that is connected to the matrix for the first time. 
Note: We recommend that you activate the reference setting for one 
single CON Device only. 

Deactivated Function not active (default) 

CPU Device Colors Selection list Highlights the CPU Device name according to the color setting for text 
and background (only relevant when the option “Show CPU” is active (see 
section 6.5.5, page 46). Select between 16 colors. 

Fix Frame Color  Selection list Shows a colored frame at the CPU Device. Select between 7 colors. The 
colored frame of the CPU Device is displayed with priority to the one of 
the CON Device. 

Direct Link Fallback Activated When the CON and CPU Units are not only connected via matrix (via 
primary ports) but also directly (via secondary ports), in case of a matrix 
failure the system switches automatically to the direct connection. 

Deactivated Function not active (default). 

Switch with EDID Activated Upon switching in Full Access mode to a CPU Device, the EDID of the 
monitor connected to the CON unit is automatically transferred to the 
CPU unit (not in sharing constellations or Video Only switching). 

Deactivated Function not active (default) 

   
Only visible when using a matrix with firmware from version 6 on 

CPU Info Activated Shows all connected CON Devices with logged-in users in OSD. 

Deactivated Function not active (default)  

Disable Disconnect Activated Disables ability to disconnect the current connection via hotkey. 

Deactivated Function not active (default)  
 

6.9.1 Creating a new CON Device 
1. Click New Device.  

A selection menu appears. 

 

 

Fig. 104 Selection Menu Extender & Devices - CON Devices - New CON Device  
 

2. Click OK. 
A new Real CON Device will be created. 



Draco Tera Tool Configuration of a Matrix via Tera Tool Software 

123 

3. Determine all parameters that are relevant for the CON Device. 
4. Click Apply to confirm the creation of the CON Device. 
 

 If creating a Virtual CON Device, the Virtual CON Device has to be assigned to a Real CON Device (see section 
6.9.10, page 131). 
 

 A template is only available if there is at least one existing CON Device. 
 

6.9.2 Changing Settings of a CON Device 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a CON Device in the CON Device list. 
4. Change the desired settings. 
5. Click Apply to confirm the changes. 
 

6.9.3 Assigning EXT Units to a CON Device  
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device from the CON Devices list you wish to assign EXT Units to. 

 

 

Fig. 105 Menu Extender & Devices - CON Devices - EXT Unit Assignment  
 

4. Select the EXT Unit from the EXT Units available list you wish to assign to the CON Device. 
5. Click  to move the highlighted EXT Unit to the EXT Units assigned list. By clicking , all EXT Units from the 

EXT Units available list will be moved to the EXT Units assigned list. 
6. Optional: Click  or  to change the order of the EXT Units within the EXT Units assigned list. 

Click Apply to confirm the assignment. 
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6.9.4 Unassigning an EXT Unit from a CON Device 
To remove an EXT Unit assignment, e.g., for servicing or replacing a faulty extender unit, proceed as follows: 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select a CON Device from the CON Devices list. 
4. Select one or more EXT Units in the EXT Units assigned list. 
5. To remove highlighted EXT Units from the EXT Units assigned list, click . By clicking , all EXT Units will be 

removed from the EXT Units assigned list. 
6. Click Apply to confirm the removal. 

 

6.9.5 Setting CPU Device Access Rights for CON Devices 
 

 The settings made here are only considered when “CON ACL” is active (see section 6.5.5, page 46). Otherwise, 
they are ignored. 
 

1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device to be modified from the CON Devices list. 
4. Click the CPU Device Access Control tab. 
 

 

 

Fig. 106 Menu Extender & Devices - CON Devices - CPU Device Access Control  
 
5. By clicking with the right mouse button once on a CPU Device in one of the respective access lists (Full Access, 

Video Access, and No Access), a context menu for selection appears for changing the respective CPU Device 
access rights. Alternatively, press f, v, or n to set the respective access rights. 

6. Click Apply to confirm the changes. 
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6.9.6 Setting CON Device Favorites 
Individual favorites list of CPU Devices to be switched frequently can be created for a CON Device in this menu. The 
list “CPU Device available” contains only CPU Devices for which the CON Device has access right according to the 
CON ACL. A favorites list can contain up to 32 different CPU Devices (from firmware V3.05). 
The switching of the favorites is done via keyboard commands (see matrix user manual). 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device for which a favorites list is to be created. 
4. Click the Favorites tab. 
 

 

 

Fig. 107 Menu Extender & Devices - CON Devices - Favorites  
 

5. Select the CPU Devices in the CPU Device available list that should be added to the favorites list (Favorite 
CPU Devices). By pressing and holding down Ctrl at the same time, more than one CPU Device can be 
highlighted. 

6. Click  to move the highlighted CPU Devices to the favorites list. By clicking , all CPU Devices from the 
CPU Device available list will be moved to the favorites list (Favorite CPU Devices). 

7. To remove highlighted CPU Devices from the favorites list, click . By clicking , all CPU Devices will be 
removed from the favorites list. 

8. Optional: Click  or  to change the order of the CPU Devices within the favorites list. 
9. Click Apply to confirm the changes. 
 

 For an efficient favorite configuration, favorite settings can be assigned to CON Devices (see description in 
section 6.10.1, page 139) or can be copied from a CON Device (see description in section 6.10.2, page 141). 
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6.9.7 Setting CON Device Macros 
In this menu macro commands for switching, disconnection or user administration can be created. The macro 
commands are created for each CON Device separately. 
A macro can execute up to 16 switching commands successively. 32 macros can be configured. 
The execution of the macros is done by entering a keyboard command by pressing the Hot Key and the function keys 
F1 to F16 (see matrix user manual) and Shift+F1 to Shift+F16 (S1 to S16). 
 

 The macros can also be used to switch to CPU groups. 
 
To create a macro for the selected CON Device, proceed as follows: 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device for which a CON Device macro is to be created. 
4. Click the Macros tab. 
 

 

 

Fig. 108 Menu Extender & Devices - CON Devices - Macros  
 
The following parameters can be configured: 

Field Selection Description 
Key F1 to F16 

S1 to S16 
Selects the function key to be configured. 

Function 
(01 to 16) 

Connect 
(P1=CON, P2=CPU) 

Sets a bidirectional connection from CON Device P1 to CPU Device P2. 

Connect Video 
(P1=CON, P2=CPU) 

Sets a Video Only connection from CON Device P1 to CPU Device P2. 

Disconnect 
(P1=CON) 

Disconnects the CON Device P1. 

Logout User Logs out the current user. 

Assign CPU 
(P1=VCPU, P2=RCPU) 

Assigns a Virtual CPU Device to a Real CPU Device. 

Assign CON 
(P1=RCON, P2=VCON) 

Assigns a Real CON Device to a Virtual CON Device. 

Push (P1=CON) Shifts the current access status (FA or VO) to CON Device P1. 

Push Video (P1=CON) Forwards the video signal of the current connection (Full Access or Video 
Only) to CON Device P1. The user’s connection remains unchanged (Full 
Access or Video Only). 
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Field Selection Description 
Function 
(01 to 16) 

Get (P1=CON) The user’s CON Device gets a Full Access connection to the CPU Device 
that is currently connected to CON Device P1. The connection of CON 
Device P1 is changed into a Video Only connection. 

Get Video (P1=CON) The user’s CON Device gets a Video Only connection to the CPU Device 
that is currently connected to CON Device P1. The connection of CON 
Device P1 remains unchanged (Full Access or Video Only). 

Login User (P1=CON, 
P2=User) 

Logs in a certain user P1 at CON Device P2. ??? 

MSC Connect 
(P1=Control-CON, 
P2=CON) 

Sets USB-HID control within activated MSC from the Control CON Device 
P1 to another Control CON Device P2. 

P1 CON Device 
VCPU Device 
RCON Device 
Control-CON Device 

Name of CON Device, Virtual CPU Device, RCON Device or Control-
CON Device 

P2 CPU Device 
RCPU Device 
VCON Device 
User 
CON Device 

Name of CPU Device, Real CPU Device, Virtual CON Device, User or 
CON Device 

 
5. Select in the Key field the function key (F1 to F16, S1 to S16) for which a macro is to be created. 
6. Select in the Function column the commands that should be part of the macro. The selection list will be opened 

by a double-click on the empty fields in all three columns. 
7. Select the respective parameters for the macro functions (e.g., corresponding CON Devices or CPU Devices) in 

the P1 and P2 columns. 
8. Click Apply to confirm your entries. 
 
For efficient macro configuration, the following context functions are available: 
 When clicking on the Macros tab, macros can be assigned to other CON Devices using the Assign Settings 

to... function (see description in section 6.10.1, page 139) and be copied from other CON Devices using the 
Copy Settings from... function (see description in section 6.10.2, page 141). 

 When clicking on the macro list, commands of the selected key can be copied into the cache by using the Copy 
Key Macros function. You can paste the commands from the cache into another key by using the Paste Key 
Macros function and you can reset all commands of the selected key by using the Delete Key Macros function. 
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6.9.8 Setting Access Rights for Logging in to a CON Device 
Users can be blocked from logging in for certain CON Devices. 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device that is assigned to the CON unit(s) for which the login should be locked in the 

CON Device list. 
4. Click the Login Lock tab in the working area. 
 

 

 

Fig. 109 Menu Extender & Devices - CON Devices - Login Lock  
 

5. Select the Users in the Allowed Login list that should be added to the list of locked Users (Locked Login). By 
pressing and holding down Ctrl at the same time, more than one User can be highlighted. 

6. Click  to move the highlighted User to the Locked Login list. All users in this list cannot log in at the CON 
Unit(s) that has/have the selected CON Device assigned to. By clicking , all Users from the Allowed Login list 
will be moved to the Locked Login list. 

7. To remove highlighted Users from the Locked Login list, click . By clicking , all Users will be removed from 
the Locked Login list. 

8. Click Apply to confirm the changes. 
9. Click Deactivate Edit Mode in the toolbar. 
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6.9.9 Configuring a GPIO CON Module 
Functions for an external switching solution connected to a GPIO add-on module are set in this menu. 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device of the CON extender module with GPIO add-on module to define the functions of the 

pins. 
4. Click the GPIO tab in the working area (only present when a GPIO add-on module is used). 
 

 

 

Fig. 110 Menu Extender & Devices - CON Devices - GPIO 
 

5. Double-click in the Function column of the pin to be defined. 
A selection menu is opened. 

6. Select Favorites as a function for the pin. 
7. Double-click in the Parameter column of the selected pin. 

A selection menu is opened. 
8. Select the favorite CPU Device from the Favorite CPU Devices list. 
9. Click Apply to confirm the changes. 
 

 Defining a macro for a pin is done in the same way. 
 

 
More information on GPIO add-on modules is contained in the manual 474-Add-on Modules. 
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To set keys for an external switching solution, proceed as follows: 
1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device of the extender module with GPIO add-on module to define the functions of the pins. 
4. Click the GPIO tab in the working area. 
5. Double-click in the Function column of the pin to be defined. 

A selection menu is opened. 
6. Select Key as function for the pin. 
7. Double-click in the Parameter column of the selected pin. 

A menu opens. 

 

 

Fig. 111 Menu Extender & Devices - CON Devices - GPIO - Keyboard Scan Codes 
 

8. If required, click the arrow under Keyboard Layout and select the desired keyboard layout in the opened 
selection list. 

9. Tick the checkbox for the desired key under Modification Keys or click the arrow under Key Code and select 
the desired key in the opened selection list. 

10. Click Ok to confirm the settings. 
11. Click Apply to confirm the settings. 
12. Click Deactivate Edit Mode in the toolbar. 
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6.9.10 Assigning Real CON Devices to a Virtual CON Device 
In this menu, several Real CON Devices can be assigned to a Virtual CON Device. 
This function reflects changes in permission made to Virtual CON Devices onto Real CON Devices. Virtual 
CON Devices can be switched in the same way as Real CON Devices. Real CON Devices that are assigned to a 
Virtual CON Device that is connected to a CPU Device will all receive the shared video signal. The last assigned 
CON Device will also have control of the keyboard and mouse. 
 

NOTICE 

If the Auto Send checkbox is ticked in the lower left corner of the working area, the switching operations will be 
performed immediately without user confirmation as is the case when clicking Send. If a Real CON Device is 
assigned to a Virtual CON Device, the settings for the Virtual CON Device for priority, CON ACL, macros and 
favorites are valid. The settings of the Real CON Device are ignored. 

 
1. Click Assignment > Virtual CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 112 Menu Assignment - Virtual CON Devices  
 

The following functions are available: 

Button Function 
Send Sends assignments to the matrix 

Reload Reloads changes 
 

 The selection boxes in the Virtual CON Device column contain a filter function. 
 

3. Select the required Real CON Device in the Real CON Device list. 
4. Click in the Virtual CON Device column to display a list of all available Virtual CON Devices. 
5. Select the required Virtual CON Device in the selection list. 
6. Click Send to send the assignment after confirmation to the matrix. 
7. Click Deactivate Edit Mode in the toolbar. 
The Tera Tool software offers the option to switch directly from the Assignment menu to the definition menu to 
check specific settings for the respective Real CON Device or Virtual CON Device. 
 Click with the right mouse button on the respective Real CON Device or Virtual CON Device and select Open 

CON Device in the context menu. The definition menu for the CON Device settings is opened (see page 113). 
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6.9.11 Configuring Multi-Screen Control 
When using MSC, switching up to eight connected sources can be performed at one sink with only one connected 
mouse or keyboard. The sink can consist of up to eight CON Units and accordingly up to eight monitors, or up to 
sixteen monitors when using dual head extender modules. In a matrix system, MSC can be set up at multiple sinks. 
The CON Units of a sink with MSC must all be physically connected to the same block of 8 ports on the I/O board. 
When using one of these I/O boards (480-C8, 480-S8 or 480-V8), the block size is limited to 4 ports (port 1 to 4, or 
port 5-8). 
One of the CON Devices is designated for USB-HID control of the connected sources, below referred to as “Control 
CON Device”. Control CON Devices refer to the extender modules within the MSC that are connected to keyboard and 
mouse for operation. If the USB-HID control has to be performed via several USB-HID devices, several CON Devices 
have to be defined as Control CON Device. 
Smooth switching of sources with the mouse is performed by dragging the mouse pointer beyond the respective 
display to an adjacent display in an arrangement of displays. The displays can be arranged side by side, in a grid 
layout, or completely free. Alternatively, switching can be performed via keyboard commands according to the ID 
number in the MSC setup. 

NOTICE 

When using CON Units with the possibility to connect a local source in a MSC environment, the local switching will 
be disabled. 

 

 The connected sources need to support absolute mouse coordinates. Else a specific mouse driver needs to be 
installed. 
 

 CON Units that have already been configured for MSC can be connected all together to other blocks of 8 ports at 
another I/O board. In this case any further configuration is not necessary, their functionality will remain as set 
previously. 
 

 

 

 

Fig. 113 Menu Assignment - Multi-Screen Control  
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The following parameters can be configured: 

Field Entry/Status Description 
Manual Activated Reduces switching to manual switching with hotkeys. Disables automatic 

switching with mouse, necessary for Multi-Head installations. 

Deactivated Function not active (default) 

ACL Activated Enables CON Device and User Access control lists (CON ACL and User 
ACL). 

Deactivated Function not active (default) 

Arrangement Selection To select the layout type (Free, Horizontal, Block) 

Dual-Head Extender 
(module) 

Activated Enables configuring two displays for the dual head extender module 

Deactivated Function not active (default) 

Enabled Activated Enables the respective display for MSC. 

Deactivated Function not active (default) 

Control Activated Enables the CON Device for USB-HID control of other CON Devices if 
access is permitted. 

Deactivated Function not active (default) 

Owner Selection • Shared (default) permits access from a Control CON Device to all other 
CON Devices including other Control CON Devices. 

• Defines which Control CON Device is authorized to operate this CON 
Device. Only Control CON Devices appear in this list. 

Frame 0 to +/- 999 
seconds 
 

Negative value: Sets the keyboard/mouse inactivity time after which a red 
frame flashes in the display with current mouse/keyboard control. 
This frame remains active until mouse/keyboard are used. 
Positive value: Sets the inactivity time after which a frame flashes briefly 
when the mouse is dragged into this display. 

 
Configuring Multi-Screen Control 

 To configure more than four CON Devices for MSC, the free layout has to be used. If the horizontal or block 
layout is used for up to four CON Devices, the CON Units have to be connected to the ports 1 - 4 or 5 - 8 of the 
respective I/O board. E.g., if connecting four CON Units to ports 1, 2, 5, and 6 of an I/O board, configuring MSC for 
these CON Devices will not be possible. 
 
1. Click Assignment > Multi-Screen Control in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the block of four or eight ports in the list of the working area that should be configured for MSC. 

Only blocks of four or eight ports that contain at least one CON Unit are shown. 
4. Tick the Manual checkbox if the USB-HID switching is to be restricted to keyboard commands (see matrix user 

manual, section “Switching via Multi-Screen Control”). Manual switching allows the use of multi-head consoles. 
5. In the Arrangement field, select the layout for the CON Devices you want to configure. Select as follows: 

• Horizontal: horizontal arrangement for a maximum of four CON Units 

• Block: block arrangement for a maximum of four CON Units 

• Free: free arrangement for a maximum of eight CON Units (The free arrangement permits a flexible 
positioning of the screens for diverse applications.) Move the displays from the Available Screens field to 
the arrangement field. 
The fields for the configuration of the individual displays will be arranged accordingly. 

 We recommend using always the free arrangement type. 
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6. If the CON Unit to be configured is a dual head extender module, tick the Dual-Head Extender checkbox to 
activate the option. 
An additional display appears in the Available Screens field. 

7. Tick the Enable checkboxes for all CON Devices to be enabled for MSC. 
Enabled CON Devices are shown as light blue screens in the arrangement field. 

8. Tick the Control checkbox for one or more CON Devices to be enabled as Control CON Device. 
Enabled Control CON Devices are shown as dark blue screens in the arrangement field. 

9. Use the Frame function to configure a red frame that flashes on the display with current mouse control in two 
scenarios: after a specified time of inactivity (-x sec.) permanently or when entering the display with the mouse 
pointer after a specified time (+x sec.) briefly. The frame can be activated individually for each screen by using a 
timer with negative or positive values. 
9.1. Double-click in the respective CON Device in the Frame column. 
9.2. Select a positive or negative value (seconds. 

10. Click Apply to confirm the settings. 
A dialog appears querying a restart of the I/O board. 

11. Click Yes to restart the I/O board. 
12. Wait until the boot process of the matrix is finished and the status LED 1 flashes green. 
13. Click Remote Save in the toolbar. 
 

 All Control CON Devices are enabled to control USB-HID of all other CON Devices in the setup. To restrict 
access to other CON Devices, see the following section. 
 
Access Restriction when using Multiple Control CON Devices 
To enable access to a display for only one Control CON Device, proceed as follows: 
1. Double-click on the selection box within the Owner column of the Control CON Device and select the name of 

this Control CON Device. 
2. Double-click on the selection box within the Owner column of all CON Devices whose display should be only 

accessible by one Control CON Device and select the name of this Control CON Device. 
The mouse can now be used to access those displays whose CON Device is enabled for access by the assigned 
Control CON Device. 

3. Click Apply to confirm the settings. 
A dialog appears querying a restart of the I/O board. 

4. Click Yes to restart the I/O board. 
5. Wait until the boot process of the I/O board is finished and the status LED 1 flashes green. 
6. Click Remote Save in the toolbar. 
 

 No simultaneous USB-HID sharing of multiple Control CON Devices 
Example: In a setup of 8 CON Devices, if CON Device 1 and 2 are each Control CON Devices and six other "non-
Control CON Devices" are configured, both Control CON Devices can access the displays of CON Device 3 to 8 if 
they are configured with Owner = Shared. 
However, Control CON Device 1 and 2 cannot access the display of a "non-Control CON Device" at the same time. 
The Control CON Device that first had USB-HID control is reset to its "own" display when the second Control 
CON Device takes over. 
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Changing Multi-Screen Control 

 Changes of the MSC are permitted only if the USB-HID control is switched to the Control CON Device. 
 
1. Switch the USB-HID control to the Control CON Device. 
2. Select the ports setup in the list whose MSC should be changed. 
3. Make edits at the configuration and system settings. 
4. Click Apply to confirm the changes. 

A dialog appears querying a restart of the I/O board. 
5. Click Yes to restart the I/O board. 
6. Wait until the boot process of the I/0 board is finished and status LED 1 flashes green. 
7. Click Remote Save in the toolbar. 
 

Deleting Multi-Screen Control 

 Changes of the MSC are permitted only if the USB-HID control is switched to the Control CON Device. 
 
To delete the MSC for a setup, proceed as follows: 
1. Switch the USB-HID control to the Control CON Device. 
2. Select the ports setup in the list for which the MSC should be deleted. 
3. Tick the Enable checkboxes for all CON Devices to remove the checkmarks. 
4. Tick the Control checkbox for all CON Devices to remove the checkmarks. 

The disabled Control CON Devices are shown as gray screens in the arrangement field and the MSC is disabled. 
5. Click Apply to confirm the changes. 

A dialog appears querying a restart of the I/O board. 
6. Click Yes to restart the I/O board. 
7. Wait until the boot process of the I/O board is finished and the status LED 1 flashes green. 
8. Click Remote Save in the toolbar. 
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Configuring Multi-Head Sources for Multi-Screen Control 

NOTICE 

A Multi-Head configuration for Apple Mac sources is not supported due to limitations of the macOS. 
 
For the use of Multi-Head sources, an additional configuration of the CPU Devices is mandatory. The configuration of 
CPU Devices which are connected to single head sources is not mandatory. 
 

NOTICE 

 For the use of Multi-Head sources, all CPU extenders have to be connected by video and USB cable to the 
source. 

 The monitor arrangement of the CPU Device has to be configured in exactly the same way as the graphics card 
settings of the connected source. The monitor arrangement of the physical monitors at the workplace does not 
matter and can be ignored.   

 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CPU Device to be configured. 
4. Click the Monitor Arrangement tab. 

 

 

Fig. 114 Menu Extender & Devices - CPU Devices - Monitor Arrangement  
 

5. Enter the resolution of the total desktop area into the fields Total Desktop Resolution. For instance, if there are 
4 graphic card outputs with a resolution of 1920x1080 each, you have to enter 7680 under Width and 1080 
under Height. The light blue gird symbolizes the total desktop area. 

6. Select the individual resolution of the graphic card output from the selection list in the field Resolution 1 (e.g., 
1920x1080). This is the graphic card output the CPU Device is connected to. 

7. Enter the respective pixel coordinates that particular screen in the MSC arrangement into the fields Offset X and 
Offset Y. 
Note: Offset: X=0/Y=0 defines the upper left corner. 
For instance, you have to enter 1920 for a shift of 1920 pixels to the right into the field Offset X. 
The corresponding screen will be positioned accordingly within the light blue grid. 
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8. If the CPU Device to be configured as a dual head extender module, tick the Dual-Head Extender checkbox to 
activate the option. Enter the resolution of the 2nd graphic card output and the offset information in the field 
Resolution 2. 

9. For some operating systems it is necessary to activate the option Multiplier. This is mandatory if you cannot 
reach all areas of the desktop with your mouse cursor. 

10. Click Apply to confirm the settings. 
A dialog appears to restart the extender module. 

 

 

Fig. 115 Dialog Monitor Arrangement - Restart Extender  
 

11. Click Yes to restart the extender module with the new configuration. 
The CPU Device is now configured for the Multi-Head operation. 

12. Click Deactivate Edit Mode in the toolbar. 
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6.9.12 Enabling Direct Link Fallback 
Direct Link Fallback needs redundant CON and CPU Units. Link 1 port of both units is connected to the matrix. Link 2 
port of the Con Unit is directly connected to Link 2 port of the CPU Unit. In case of a matrix failure, it is still possible to 
work with the directly connected computer/CPU.  

 

 

Fig. 116 Illustration of Direct Link Fallback 
 

This function is enabled in the menu for CON Devices. 
1. Click Extender & Devices > Con Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 117 Menu Extender & Devices - CON Devices 
 

3. Select a CON Device that has an EXT Unit assigned to which represents a CON Unit with a direct connection to 
a CPU Unit. 

4. Tick the function Direct Link Fallback.  
5. Click Apply. 
 
  



Draco Tera Tool Configuration of a Matrix via Tera Tool Software 

139 

6.10 Assigning/Copying Settings 
These functions are available for settings of: 

- Users 
- CON EXT Units 
- CPU Devices 
- CON Devices 
- Favorites 

The process is always the same, only the selection menus for settings vary. 
 

6.10.1 Assigning Settings 
This function is described using CPU Devices as an example. 
1. Click Extender & Devices > CPU Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CPU Device whose settings are to be assigned to another CPU Devices. 
4. Click Assign Settings to… below the CPU Device list. 

Step 1 appears: select the parameters whose settings are to be assigned to other CPU Devices. 

 

 

Fig. 118 Menu Extender & Devices - CPU Devices - Select parameters 
 

5. Tick the checkboxes to select the desired settings. 
 

NOTICE 

The value of a setting which is not selected in the “Select Settings” step is not copied to the target. This means the 
value of this setting remains as it is. 

 

6. Click Next >. 
Step 2 appears: select the target CPU Devices. 



Configuration of a Matrix via Tera Tool Software Draco Tera Tool 

140 

 

 

Fig. 119 Menu Extender & Devices - CPU Devices - Assign Settings to… 
 

7. Select the CPU Device in the Available to assign settings to list to which the settings are to be assigned. By 
pressing and holding down Ctrl at the same time, more than one CPU Device can be highlighted. 

8. Click  to move the highlighted CPU Device to the Assign settings to list. By clicking , all CPU Devices will be 
moved to the Assign settings to list. 

9. To remove highlighted CPU Devices from the Assign settings to list, click . By clicking , CPU Devices will be 
removed from the Assign settings to list. 

10. Click Finish. 
The settings are immediately assigned (copied) to the selected CPU Devices. 

11. Click Deactivate Edit Mode in the toolbar. 
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6.10.2 Copying Settings 
This function is described using CON Devices as an example. 
1. Click Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Select the CON Device to copy the settings to. By pressing and holding down Ctrl at the same time, more than 

one CON Device can be highlighted. 
4. Click Copy Settings from below the CON Device list. 

Step 1 appears: selection of the parameters whose settings are to be copied. 

 

 

Fig. 120 Menu Extender & Devices - CON Devices - Select parameters 
 

5. Tick the checkboxes to select the desired parameters. 
6. Click Next >. 

Step 2 appears: select the CPU Device whose settings are to be copied. 
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Fig. 121 Menu Extender & Devices - CON Devices - Copy Settings 
 

7. Select the CON Device in the selection list from which the settings are to be copied. 
8. Click Finish. 

The settings are immediately copied to the previously selected CON Devices. 
9. Click Deactivate Edit Mode in the toolbar. 
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6.11 Configuring IP Gateway Connections 
The configuration of IP Gateways and the connection via IP to another IP Gateway is set in this menu. Each IP 
Gateway board is internally managed with eight ports for up to eight connections over a 1G channel to establish 
connections to other IP Gateway boards or to an IP Gateway extender.  
To set an IP Gateway connection between two matrices, it is only necessary to configure the master matrix. For a 
connection to an IP Gateway extender in another network than the matrix, the matrix and the extender need to be 
configured using the Tera Tool software.  
 

 It is possible to reprogram the IP Gateway board so that it no longer has IP functionality. It is then a normal grid 
board that can be used in existing matrix grids. 
 

 

 

Fig. 122 Menu System Settings - IP Gateway  
 

6.11.1 Setting an IP Gateway Connection for a Grid 
 We strongly recommend setting up IP Gateway connections only via master matrix.  

 
1. Connect to the master matrix. 
2. Click System Settings > IP Gateway in the task area. 
3. Click Activate Edit Mode in the toolbar. 
4. Click the slot with the IP Gateway board under Slot for which an IP Gateway connection has to be set. 
5. By default, the channel type is set to Grid. If the channel type in the line of a source port that has to be used for 

matrix grid connection via IP Gateway is set to EXT Unit, double-click on the corresponding selection box of the 
port to be configured within the Type column and select Grid. 

6. Double-click in the respective Select Channel field. 
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Fig. 123 Menu System Settings - IP Gateway - Select Grid Channel  
 

A drop-down menu is opened listing all available channels of other matrices in the subnet.  
A channel is available when the type is set to Grid. Stated are the device (matrix) name, the slot of this matrix 
that contains an IP gateway board and the port number.  

7. Click on the desired channel in the list.  
8. The data of the selected channel are read and automatically entered in the selected channel line in this menu. 

 

 

Fig. 124 Menu System Settings - IP Gateway - Selected Grid Channel  
 

9. Click Apply to confirm the selection. 
The data of the selected master matrix channel (01) are read and sent to the selected channel of the IP Gateway 
board of the sub-matrix to be connected. The data of the master matrix channel is automatically entered into the 
line of the selected grid channel at the sub-matrix (see following figure). 
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Fig. 125 Menu System Settings - IP Gateway - Filled in grid channel in sub matrix 
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6.11.2 Setting an IP Gateway Connection for an IP Gateway CON Unit 
 

6.11.2.1 IP Gateway CON in the same Network 
1. Connect a computer or laptop to the matrix and start Tera Tool. 
2. Click Activate Edit Mode in the toolbar. 
3. Click System Settings > IP Gateway. 
4. Create at least one EXT Unit channel. By default, the channel type is set to Grid. Double-click on the 

corresponding selection box of the channel to be configured within the Type column and select EXT Unit.  
In the following figure channels 6 and 7 are of the type EXT Unit. 

 

 

Fig. 126 Menu System Settings - IP Gateway with EXT Unit channels 
 

5. Click System Settings > IP Extender. 

 

 

Fig. 127 Menu System Settings - IP Extender 
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6. Click the button Search IP Extender.  
The Search IP Extender dialog appears, listing all IP Gateway CONs that are recognized in the same subnet. 

7. Click the desired IP Gateway CON. The network settings are displayed. 

 

 

Fig. 128 Dialog Search IP Extender with changed hostname and IP address 
 

8. Change the hostname if desired. 
9. Set the IP address if DHCP has to be deactivated. 

 If using a system without DHCP server, we recommend deactivating DHCP and entering a static IP address 
different from the default IP address 192.168.100.81. 
 Note: The IP Gateway CON will restart and will only be found when connecting to the respective network. 
  

10. Click the down arrow  to assign a destination. 
A window appears showing all channels available for IP Gateway CON connection via IP. 

 

 

Fig. 129 Dialog Select Destination 
 

11. Select the desired channel in the list. 
12. Click Ok to confirm the selection. 

The selected destination is stated in the Destination field. 
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Fig. 130 Dialog Search IP Extender - Destination set 
 

13. Click Apply, Reload and Close. 
The IP Gateway Channels table now looks like this: 

 

 

Fig. 131 Channels table with connected IP Gateway CON unit 
 

 By clicking Reload, the MAC address of the extender was automatically retrieved and written into the table. 
 

The assigned IP Gateway CON is listed in the System Settings > IP Extender menu. 

 

 

Fig. 132 Menu System Settings - IP Extender  
 

 The port number stated here is derived from the slot the IP Gateway board is in (here: slot 8). The 8 channels are 
numbered in the same way as 8 ports of an I/O board in this slot would be numbered.  
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6.11.2.2 IP Gateway CON Unit in a different Network than Matrix and/or IP Gateway board 
You have to configure the matrix with the IP Gateway board and the IP Gateway CON Unit using the Tera Tool 
software. How this is done is described in detail in the IP Gateway manual. 

 
6.11.3 Setting an IP Gateway Connection for Draco CON App 
The Draco CON App is a client software for access to Draco tera matrices over IP. It is equivalent to an IP CON unit. 
Running it on your computer, you can access another computer via matrix and a CPU unit. 
 
Requirement 

- The version of the firmware MATLETC of the IP Gateway board must be at least D00.42.240417.  
Proceed as follows: 
1. Connect to the matrix. 
2. Click System Settings > IP Gateway in the task area. 
3. Click Activate Edit Mode in the toolbar. 
4. Click the slot with the IP Gateway board under Slot for which an IP Gateway connection has to be set. 

There are two possibilities:  
- Creating a Dynamic EXT Unit which is useful when you want to access more than one matrix. All matrices 

and the Draco CON app have to be in the same subnet. 
- Creating an EXT Unit when you want to access only one matrix. The app is configured and treated in the 

same way as an IP Gateway CON extender that means a fixed connection between IP gateway board and 
Draco CON app is created. 

Dynamic EXT Unit 
1. By default, the channel type is set to Grid. Double-click on the corresponding selection box of the port to be 

configured within the Type column and select Dynamic EXT Unit. 
2. Click Apply.  

This is all you have to do; no further settings are necessary.  

EXT Unit 
1. Double-click on the corresponding selection box of the port to be configured within the Type column and select 

EXT Unit. 
2. Type in IP address and port of the device (notebook, laptop, etc.) where the Draco CON App is or will be installed 

if known. 
3. Click Apply.  
Configuration and operation of Draco CON App is described in the IP Gateway manual. 
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6.11.4 Deleting an IP Gateway Connection 
 We strongly recommend deleting IP Gateway connections only via master matrix. 

 
1. Connect to the master matrix. 
2. Click System Settings > IP Gateway in the task area. 
3. Click Activate Edit Mode in the toolbar. 
4. Click the slot with the IP Gateway board under Slot of which an IP Gateway connection has to be deleted. 

5. Click the red cross  in the respective line to delete the connection of an IP Gateway board. 
The connection settings are deleted on both IP Gateway boards. 

 

6. Click Deactivate Edit Mode in the toolbar. 
 
 

6.11.5 Reprogramming an IP Gateway Board 
An IP Gateway board can be converted into a normal Grid board without IP functionality to be included in existing 
matrix grids. This is achieved by changing the firmware of the board. Please contact our Tech Support for suitable 
firmware files. 
 

1. Click Status & Updates > Miscellaneous in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click the tab Convert I/O Board Firmware. 

 

 

Fig. 133 Menu Status & Updates – Miscellaneous – Convert I/O Board Firmware 
 

The following window appears. 
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Fig. 134 Menu Convert I/O Board Firmware – Choose Conversion Mode 
 

4. Select the conversion mode IP Gateway to Grid in the drop-down menu. 
5. Click Next. 
 

 

 

Fig. 135 Menu Convert I/OBoard Firmware – Select I/O Board(s) 
 

Slot and current firmware type of each IP Gateway board is listed. 
6. In the column Update tick all IP Gateway boards you wish to convert.  
7. Click Next. 
8. Click Browse and go to the location of the firmware file.  
9. Select the firmware file MATLLNC.tfw and click Select. 
10. Click Update. 

The conversion process starts, progress is displayed, and log messages appear in the white field. 
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11. Click Save Log Messages if you want to store the log messages. 
12. When the conversion is finished, click on Finish. 
13. Follow the instructions on-screen and restart the IP Gateway board(s). 

They can now be used as simple Grid boards without IP functionality in existing matrix grids. 
 

It is of course possible to reverse this process using the same wizard. 
 Proceed as described above. In step 4 select Grid to IP Gateway instead of IP Gateway to Grid.  
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6.12 Configuring Matrix Cascading 
This method of cascading allows a switchable connection between two matrices via so called Tie Lines. 
This kind of configuration may become necessary if certain important connections should be distributed to several 
matrices due to maintenance reasons. 
A Tie Line connects physically one fixed Cascading CON Ext Unit of matrix 1 with one fixed Cascading CPU Ext Unit 
of matrix 2 and vice versa. 
 

 
Fig. 136 Illustration of Matrix Cascading  
 
Before connecting Tie Lines to the matrices, you first have to create fixed EXT Units for Cascading CON and 
Cascading CPU on both matrices as well as Cascading CON Devices and Cascading CPU Devices that can then 
be switched within the cascaded environment.  
 

 Ensure that the Tie Lines will only be connected after finishing the configuration. 
 

6.12.1 Activating the Sub Matrix Option 
To be able to open the OSD on both matrices, it is necessary to define one matrix as sub matrix, the other is named 
master matrix.  
1. Connect to the defined sub matrix and click Activate Edit Mode in the toolbar. 
2. Click System Settings > System in the task area. 

 

 

Fig. 137 Menu System Settings - System (extract) 
 

3. Tick the Sub Matrix checkbox in the working area. 
4. Click Apply to confirm the sub matrix option. 

 The OSD of the sub matrix will immediately freeze and will be only accessible by using the keyboard command 
Hot Key, s, o. 
 

 

cable connection 
switched connection 



Configuration of a Matrix via Tera Tool Software Draco Tera Tool 

154 

6.12.2 Creating Cascading EXT Units and Devices 
This needs to be done at both matrices (master and sub). For each Cascading CON EXT Unit at the master matrix 
there must be a Cascading CPU EXT Unit at the sub matrix and vice versa. Cascading EXT Units are fixed units that 
means you have to state a connection port. Note down the port numbers and the type (CON or CPU) so that it is later 
possible to connect a cable between a Cascading CON port and a Cascading CPU port. For each EXT Unit, create a 
suitable Device for switching. 
 

At the master matrix: 
Creating Cascading EXT Units 
1. Connect to the master matrix. 
2. Click Activate Edit Mode in the toolbar. 
3. Click Extender & Devices > EXT Units in the task area. 
4. Click New Unit. 

A selection dialog appears. 

 

 

Fig. 138 Menu Extender & Devices - EXT Units - Choose EXT Unit type  
 

5. Select Cascading CPU Unit or Cascading CON Unit in the Choose template selection box. 
6. Click OK. 

A new Cascading CPU or CON Unit will be created. The ID number starts with 9 and the box Fixed is ticked.  

 

 

Fig. 139 Menu Extender & Devices - EXT Units - Cascading CPU Unit 
 

7. Enter an appropriate name for the Cascading CPU/CON Unit into the Name field. 
8. Enter the port number of a free port of the matrix into the Port field. 
9. Click Apply to confirm the creation. 
10. Create as many Cascading CPU and Cascading CON EXT Units as needed. Remember to note down the port 

number and type of the Cascading EXT Units. 
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Creating CON and CPU Devices 
This function is described using CPU Devices as an example. 
1. Click Extender & Devices > CPU Devices in the task area of the master matrix. 
2. Click New Device. 

A selection dialog appears. 
3. Select Create a Real CPU Device and click OK. 

 

 

Fig. 140 Menu Extender & Devices - CPU Devices - Cascading CPU Device  
 

4. Enter an appropriate name for the Cascading CPU Device into the Name field. 
5. Select the previously configured Cascading CPU EXT Unit in the EXT Units available list. 
6. Click  to move the highlighted Cascading CPU EXT Unit to the EXT Units assigned list. 
7. Click Apply. 
8. Proceed in the same way to create a CPU Device or a CON Device for each Cascading EXT Unit. 
9. Click Deactivate Edit Mode in the toolbar and close the Tera Tool Software. 
10. Restart all I/O boards on which any CON Units or CPU Units have been configured (see section 7.2.3, page 185) 

or alternatively restart the master matrix (see section 7.2.1, page 183). 
 

At the submatrix 
1. Connect to the sub matrix. 
2. Click Activate Edit Mode in the toolbar. 
3. Create as many Cascading CON EXT Units as you have created Cascading CPU EXT Units on the master 

matrix. Proceed in the same way as described for the master matrix. Note down the port numbers and type of 
each unit. 

4. Create as many Cascading CPU EXT Units as there are Cascading CON EXT Units on the master matrix. 
5. Click Apply to confirm the creation of all Cascading CPU and CON EXT Units. 
6. Create a CPU Device for each CPU EXT Unit you created and assign a cascading CPU EXT Unit to each. 
7. Click Apply to confirm the creation of the CPU Devices. 
8. Create a CON Device for each CON Ext Unit you created and assign a cascading CON EXT Unit to each. 



Configuration of a Matrix via Tera Tool Software Draco Tera Tool 

156 

9. Click Apply to confirm the creation of the CON Devices. 
10. Click Deactivate Edit Mode in the toolbar. 
11. Restart all I/O boards on which any CON Units or CPU Units have been configured (see section 7.2.3, page 185) 

or alternatively restart the sub matrix (see section 7.2.1, page 183). 
 

6.12.3 Connecting the Tie Lines 
1. Make sure that a list of ports with Cascading EXT Units and their types (CON or CPU) is ready at hand. 
2. Connect a port of the master matrix with a Cascading CON Unit to a port of the sub matrix with a Cascading CPU 

Unit and vice versa using interconnection cables. This ensures switching ability between the two matrices. 
The Matrix Cascading is now configured and can be used. The use of cascading is described in the matrix user 
manuals. 
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6.13 Configuring Matrix Grid 
A matrix grid to connect two or more matrices can be configured in this menu. This kind of configuration may become 
necessary if the number of ports in the entire system has to be increased or if certain important connections should 
be distributed to several matrices due to reasons of redundancy. 
The connections between two matrices have to be established by so called grid lines that are connected between 
particular I/O ports as connecting links. The grid lines can be used bidirectionally and can respectively handle a full 
access connection of a CON Device to a CPU Device. 
The number of grid lines in the system specifies whether a CON Device can be switched to a CPU Device in Non-
Blocking Access or in Blocking Access and has to be separately determined for each grid environment. 
In this case Non-Blocking Access means that a grid line for a cross-matrix switching operation of a CON Device to a 
CPU Device is available at any time. 
Whereas Blocking Access means that for a certain switching operation no grid line may be available according to the 
switching status within the grid. The result will be that no cross-matrix switching will be possible. 
 

Administration of Settings 
Within a matrix grid you have to differ between settings that have to be made locally for each matrix and settings that 
can be made globally so that they are valid for the whole matrix grid. 
The settings in the following menus have to be made separately for each matrix or within the master matrix to affect 
all matrices in the matrix grid: 
System, Access, Switch, Network, Date + Time, SNMP, Matrix Grid 
The settings in the following menus have to be made globally and only once within the matrix grid: 
EXT Units, CPU Devices, CON Devices, User, CON Macros, User Macros, CON Favorites, User Favorites, 
Virtual CPU Devices, Virtual CON Devices, Multi-Screen Control 
 

 If global settings are made in the respective menus, they will be immediately available on each matrix within the 
matrix grid. 
 

General Preparation 
The following requirements have to be fulfilled before starting the matrix grid configuration: 

• First configure all matrices that have to be added to the grid the first time. 

• Ensure that for both the existing matrices in the matrix grid and the new matrix a suitable configuration file is 
available. 

• Save the current configuration as backup, and upload it to e.g., configuration slot 8. 

• The Matrix Grid function (Bundle 4) must be activated on all matrices to be connected to the grid by a license key 
(see section 6.15). Please contact the technical support of the manufacturer if the Matrix Grid function is missing 
(not ticked). 

• Firmware V03.10 or newer must be installed on all matrices to be connected to the matrix grid, but with the same 
firmware on each matrix. For using IP Gateway boards for grid lines, firmware V04.04 or newer is necessary. 

• All matrices to be connected to the grid must be within the same TCP/IP network (see section 6.5.7, page 50). 

• Port 5556/5566 needed for network communication must not be blocked by a firewall. 
 

 The Tera Tool offers a Grid Wizard for online configuration of matrix grids (see section 6.13.1, next page) that can 
be stored in the configuration slots of the matrix. For complex matrix systems, it is possible to set up offline matrix 
grids (see section 6.13.2, page 157) and to check if all is setup failure free.  
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6.13.1 Configuring Matrix Grid online 
To configure the matrix grid online, proceed as follows: 
1. Click System Settings > Matrix Grid in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 
Fig. 141 Menu System Settings - Matrix Grid  
 

3. Click Start Grid Wizard (online) in the working area. 

 

 

Fig. 142 Menu Matrix Grid - Configuration Wizard - General Remarks and Preparation  
 

4. Verify the requirements and tick the checkboxes. 
5. Click Next >. 
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Fig. 143 Menu Matrix Grid - Configuration Wizard - Matrix Configuration  
 

6. Click Add new matrix to grid below the matrix list. 
7. Fill out the required fields for each matrix (IP address/Hostname, User and Password). 
8. Press the Tabulator key to enable the Verify button. 
9. Click Verify to check network availability. 
10. Click Next >. 

 

 

Fig. 144 Menu Matrix Grid - Configuration Wizard - Grid Name  
 

11. Enter the Grid Name for the matrix grid. 
12. Optionally tick the Grid Info (optional) checkbox to enter a description for the matrix grid. 
13. Click Next >. 
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Fig. 145 Menu Matrix Grid - Configuration Wizard - Matrix Grid  
 

14. Enter a unique name under Device for each matrix in the grid. 
15. Check the number of ports for each matrix. 
16. Click Verify to verify the matrix data. 
17. Click Next >. 

 

 

Fig. 146 Menu Matrix Grid - Configuration Wizard - ID Handling  
 

18. Optional: If using a media control through the API of the matrix, tick the Keep Device IDs. 
19. Click Next >. 
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Fig. 147 Menu Matrix Grid - Configuration Wizard - Activate Matrix Grid  
 

20. Select the configuration slot for storing the matrix grid configuration. All matrices in the grid use the same slot. 
21. Click Activate Matrix Grid to activate the matrix grid on all matrices connected to the master matrix. 
22. Go to the storage location for the merged matrix grids and select the desired folder. Click Save. 

 

 

Fig. 148 Menu Matrix Grid - Configuration Wizard - Matrix Grid activated  
 

 Run the System Check (see section 9.3.10, page 219) to identify duplicated Device IDs. Change duplicated 
device IDs manually to avoid issues. 
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6.13.2 Configuring Matrix Grid offline 
To configure the matrix grid offline, proceed as follows: 
1. Firstly, connect the computer sequentially to each matrix that is to be part of the grid (including master matrix), 

start Tera Tool and save the current configuration using the Save button in the toolbar in the format *.dtc on 
your computer. 

2. Without connection to a matrix, start Tera Tool. 
3. Click System Settings > Matrix Grid in the task area. 

 

 

Fig. 149 Menu System Settings - Matrix Grid (offline) 
 

4. Click Start Grid Wizard (offline) in the working area. 
5. Verify the requirements and tick the checkboxes. 

 

 

Fig. 150 Menu Matrix Grid - Configuration Wizard (offline) - General Remarks And Preparation 
 

6. Click Next >. 
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Fig. 151 Menu Matrix Grid - Configuration Wizard (offline) - Matrix Configuration 
 

7. Click Add configuration below the matrix list. 
8. Go to the storage location where you have stored the current configuration of each matrix (see step 1). 
9. Select the first configuration and click Open. 

 

 

Fig. 152 Dialog Matrix Grid - Configuration Wizard (offline) - Select Configuration 
 

10. Repeat selecting further configurations if required and click Open. 
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11. Click Next >. 

 

 

Fig. 153 Menu Matrix Grid - Configuration Wizard offline) - Enter grid name  
 

12. Enter the Grid Name for the matrix grid. This name must be unique if you run different matrix grids in the same 
network. 

13. Optionally, tick the Grid Info (optional) checkbox to enter a description for the matrix grid. The info field of all 
matrices in the grid will be changed to this setting. 

 We recommend ticking the Grid info checkbox. Otherwise, each matrix keeps its own info field with maybe 
different content. 
 

14. Click Next >. 

 

 

Fig. 154 Menu Matrix Grid - Configuration Wizard (offline) - Enter matrix data  
 

15. Enter a unique name under Device for each matrix in the grid. 
16. Enter the number of ports by double-clicking the Ports field and selecting the number from the list. 
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17. When all matrices show Valid in the Info field, click Verify to verify the matrix data. 
18. Click Next >. 

 

 

Fig. 155 Menu Matrix Grid - Configuration Wizard (offline) - ID Handling  
 

19. Optional: If using a media control through the API of the matrix, tick the Keep Device IDs. 
20. Click Next >. 

  

 

Fig. 156 Menu Matrix Grid - Configuration Wizard (offline) - Go to output directory  
 

21. Click Browse to select the output directory for storing the configurations for each matrix of the matrix grid. 
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Fig. 157 Menu Matrix Grid - Configuration Wizard (offline) - Select storage location 
 

22. Select the desired folder and click Select. 
23. Click Merge Configurations. 

 

 

Fig. 158 Menu Matrix Grid - Configuration Wizard (offline) - Merge Configurations  
 

Messages appear in the Update Messages field. 
24. Optionally, click Save Log Messages if the messages should be saved (recommended). 
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Fig. 159 Menu Matrix Grid - Configuration Wizard (offline) - Merge Configurations 
 

25. Click Finish to close the Wizard. 
The output directory contains now a configuration file for each matrix. Each matrix has its own configuration file. 

26. Open the configuration files in Tera Tool and check them. Pay particular attention to the following elements: 
- EXT Units 
- CPU Devices 
- CON Devices 
- User & Groups 

 Run the System Check (see section 9.3.10, 219) to identify duplicated Device IDs. Change duplicated device IDs 
manually to avoid issues. 
 
27. Once the configuration files have been checked, they can be uploaded to each matrix and activated (see section 

6.4.4, page 37). We strongly recommend uploading the files to the same configuration slot at all matrices in the 
grid. 

 

6.13.3 Modifying Matrix Grid Configuration 
The Grid Wizard is used to change the grid including the name change of a matrix. It is important that all matrices are 
active and online when performing changes to a grid and that the master matrix is used. 
1. Make sure that all matrices are switched on and connected to the grid. 
2. At the master matrix, open the Grid Wizard in the menu System Settings > Matrix Grid. 
3. In step 2 Matrix Configuration (see Fig. 143 on page 159) you can add new matrices, delete a matrix or change 

the order. 
4. In step 3 Grid Name (see Fig. 144 on page 159) you can change name and info field of the grid. 
5. In step 4 Matrix Grid (see Fig. 145 on page 160) you can change the name of a matrix. Bear in mind that the 

name must be unique. 

 When a matrix is part of a matrix grid, it is not possible to change the name in the normal way (via System 
Settings > System > General, only via Grid Wizard. 
 

6. Complete the Grid Wizard and finally click Activate Matrix Grid and Finish. 

NOTICE 

The entire grid (all matrices part of the grid) restarts immediately and is not available during this time.  
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6.13.4 Deleting Matrix Grid Configuration 
1. Make sure that all matrices of the grid are switched on and online. 
1. At the master matrix, open the Grid Wizard in the menu System Settings > Matrix Grid. 
2. Click Next > to get to step 2 Matrix Configuration. 

 

 

Fig. 160 Menu Matrix Grid - Configuration Wizard (offline) - Matrix Configuration 
 

3. Click the Delete button for each matrix to delete all matrices form the grid.  

 

 

Fig. 161 Menu Matrix Grid - Configuration Wizard (offline) - All matrices deleted 
 

4. Click Next > several times until you get to step 6: Activate Matrix Grid. 
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Fig. 162 Menu Matrix Grid - Configuration Wizard (offline) - Select grid configuration   
 

5. Select the slot where the configuration of the grid to be deleted is stored.  
6. Click the button Activate Matrix Grid. 

A configuration file without grid settings overwrites the existing grid configuration file on all matrices. 
 

NOTICE 

The entire grid (all matrices part of the grid) restarts immediately and is not available during this time.  
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6.14 Export and Import Options 
The matrix offers the ability to read out available data of e.g., extender modules, CPU Devices, CON Devices, users, 
etc. from the configuration file for export and import via Tera Tool software. 

 Exported data are always saved in .csv format that allows offline editing with common spreadsheet applications. 
 

6.14.1 Export Options 
1. Click File > Export in the menu bar. 
The following menu opens. 

 

 

Fig. 163 Dialog File - Export - Select Type  
 

2. Select the type to be exported. Each type has to be exported individually. 
3. Click Next >. 

 

 

Fig. 164 Dialog File - Export - Export Data to CSV File  
 

4. Go to the desired location for the exported data. 
5. Enter a name for the exported CSV file. 
6. Click Finish to confirm the export. 
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6.14.2 Import Options 
 Importing data is only possible into offline configuration files of the type (*.dtc). 

 

NOTICE 

The individual parts of a configuration file relate to each other. If you want to import several types of data into a 
configuration file, it is very important that you stick to the same sequence as displayed in the Select Type list (see 
following figure). 
For example, when you want to import the types of EXT Unit and CPU Device, always import the EXT Unit *.csv file 
first and then the CPU Device *.csv file and not vice versa. 

 
1. Open a locally saved configuration file or create a new configuration file. 
2. Click File > Import in the menu bar. 

 

 

Fig. 165 Dialog File - Import - Select Type  
 

3. Select the type of data to be imported.  
4. Click Next >. 

 

 

Fig. 166 Dialog File - Import - Import data into *.dtc file  
 

5. Go to the location of the desired *.csv file to be imported. 

6. Select the *.csv file to be imported. 
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7. Click Finish to confirm the import. 
If data of the type to be imported already exists in the current configuration, a dialog appears. 

 

 

Fig. 167 Dialog File - Import - Import CSV File to Config 
 

8. Click the corresponding button to overwrite the specified data or not. 
 

NOTICE 

When importing/exporting the types of IP Session Config and User, no passwords are imported/exported. 
An export is no complete backup and cannot replace the functions Save or Save Status.   
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6.15 License Management 
In this menu, the matrix can be upgraded with new function bundles by means of license keys. 

 To obtain license keys to upgrade matrix functions, contact your distributor. 
 
 

To activate a function bundle, proceed as follows: 
1. Click Status & Updates > Miscellaneous in the task area. 
2. Click the License Management tab. 
 

 

 

Fig. 168 Menu Status & Updates - Miscellaneous - License Management  
 

3. Enter your license key in the working area under Activate License in the License Key field. 
4. To activate the license key, click Activate. 

The new functions will be immediately enabled, a restart of the matrix will not be necessary. 
 

 Please note that the license key is case sensitive. If the key is not accepted, check for hidden blanks or wrong 
case. 
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6.16 Saving Configuration Status 
6.16.1 Saving a Status 
A snapshot of the whole system will be saved as .zip file on the computer on which Tera Tool is running. Content, 
see section 6.3, page 34. 
 

1. Click Save Status in the toolbar to read out the overall status of the device and store it locally. 
A dialog appears. 

 
1 appears only if a grid exists 
2 appears only if the option was enabled under Extras > Options > Miscellaneous 

 

Fig. 169 Dialog Save Status - Saving Option 
 

2. Choose the status option to be saved. 
3. Click Next >. 

 

 

Fig. 170 Menu Save Status - Choose Directory 
 

4. Go to the directory where you want to save the status file. 
5. Click Next >. 
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Fig. 171 Menu Save Status - Anonymization  
 

6. Tick the Anonymize checkbox to anonymize your personal data when saving the status file if necessary (not 
recommended for backup). 
If you want to use the status file as a backup, do not tick the Anonymize checkbox. 

 

 We recommend not ticking any options in the Save Status dialog for normal use or backup. These options are 
only for troubleshooting and our tech support team will ask for an option if necessary. 
 

7. Click Next >. 

 

 

Fig. 172 Menu Save Status - Save EXT Unit Settings  
 

8. Do not tick the Save EXT Units Settings checkbox unless having been prompted to do so. 
9. Click Next >. 
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Fig. 173 Menu Save Status - Save Log Files  
 

10. Click Next >. 

 

 

Fig. 174 Menu Save Status - Save Status  
 

11. Wait until all steps show green checkmarks and the “Saving status successful” message is displayed. 
12. Click Finish to complete the status saving process. 
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6.16.2 Opening a Locally Saved Configuration Status 
1. Click Device > Load Status… in the menu bar. 

 

 

Fig. 175 Menu Device - Load Status 
 

2. Go to the storage location of the status file to be opened. 
3. Click the status file to be opened. 
4. Click Open to open the status file. 
 

 The status can also be opened via drag & drop. To do so, open the file browser, go to the storage location of the 
status file, click on the status file, hold down the left mouse button and drag and drop the status file into the Tera Tool 
software. 
 

 
 

6.16.3 Uploading a Locally Saved Configuration Status 
1. Open a locally saved status. 
2. Perform the uploading process (see section 6.4.4, page 37). 
 

 Uploading the opened status will only save the config.dtc as current configuration to the matrix (including the 
switch status). Other information contained in the zip file like matrix and extender firmware is not loaded.  
 
If you want to upload further configurations saved in the zipped status file, proceed as follows: 
1. Extract the zipped status file. 
2. Click Open, go to the storage location of the extracted configuration files, select the file to be uploaded and click 

Open in the dialog. 
3. Click Upload and proceed as described above. 
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7 Operation via Tera Tool Software 
7.1 Switching Operation via Tera Tool Software 
7.1.1 Extended Switching 

 Switching operations can only be performed in online mode. That means an active network connection is required 
between the matrix and the Tera Tool software. 
At least power user rights are required according to the CON Device ACL or User ACL. 
In a matrix grid, all switching operations must be performed at the master matrix. 
 

 
You have three options to perform switching operations for the matrix via Tera Tool software.  
 

Possibility 1 
1. Click Control > Extended Switch in the task area. 
2. Click Activate Edit Mode in the toolbar. 
All CON Devices and the associated CPU Device connections, if present, are shown in columns in the working area 
in this menu. 

 

 

Fig. 176 Menu Control - Extended Switch  
 

Button/checkbox Function 
Send Sends effected switching operations to the matrix after user confirmation. This button is 

disabled when the checkbox Auto Send is ticked. 

Reset Disconnects all existing connections within the matrix. 

Reload Reloads switching status. 

Auto Send If ticked, the switching operations will be performed immediately without user 
confirmation. The button Send is disabled. 

Hide Devices without 
EXT Unit Assignment 

If ticked, only CON Devices and CPU Devices that are assigned to EXT units are shown. 

Hide inactive Devices If ticked, only active CON Devices and CPU Devices are shown. 
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 If the Auto Send checkbox is ticked, the switching operation will be performed immediately without user 
confirmation. 
 

To perform a switching operation, proceed as follows: 
 To set a full KVM connection between a CON Device and a CPU Device, double-click on the corresponding 

selection box within the Full Access column and select the requested CPU Device. 
 To set a Video-only connection between a CON Device and a CPU Device, double-click on the corresponding 

selection box within the Video Access column and select the requested CPU Device. 
 To set a Private Mode connection between a CON Device and a CPU Device, double-click on the 

corresponding selection box within the Private Access column and select the requested CPU Device. 
 

 If a CON Device does not have access rights for a CPU Device, it will not appear in the list. 
 

 
Possibility 2 
1. Click View > Matrix in the task area or select View > Port when using a matrix grid. 
 

 

 

Fig. 177 Menu View - Matrix  
 

The following symbols may be shown in the connection overview: 

Symbol Description 

 CON Device is connected via Shared Access with at least one further CON Device to the 
same CPU Device. The CON Device has Full Access at the moment. 

 CON Device is connected via Shared Access with at least one further CON Device to the 
same CPU Device. The CON Device has a Video Access connection at the moment. 
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To perform switching operations between CON and CPU Devices proceed as follows: 
2. Move the mouse cursor to the port that has to be switched. 
3. Hold down the left mouse button and move the cursor to the port that has to be connected to the initial port. The 

current cursor movement will be displayed by a black auxiliary line. 
4. Release the left mouse button. 

A selection menu to select the available switching type (Full Access, Video Access or Private Mode) will be 
opened. Private Mode will only be shown if the option “Allow Private” is enabled for the selected CPU Device. 

5. Select the desired switching type. 
The switching operation will be immediately executed. At the same time all EXT Units that are assigned to the 
involved Devices will be switched. 

 

 If a port is shown with a red cross on Matrix View, the CON Device does not have access rights to the 
CPU Device connected to that port. 
 

 
To disconnect the existing connection between CON Device and CPU Device, proceed as follows: 
1. Click with the right mouse button on the port that is to be disconnected. 
2. Click the Disconnect function in the context menu. 

The connected ports will be immediately disconnected. At the same time all further connections of the extender 
modules assigned to the involved Devices will be disconnected. 

 

Possibility 3 
1. Click Control > Presets in the task area. 
2. Select the switch preset in the right column of the working area that has to be loaded. 
3. Click Send on the lower right of the working area to activate the selected switch preset. 

The preset is sent to the matrix and executed.  
 

 A switch preset can only be activated in online mode. 
 
How switch presets are defined is described in section 7.1.3 on the next page. 
 

7.1.2 USB 2.0 Switching 
Switching of USB 2.0 extender modules basically works like switching of KVM extender modules. The following 
scenarios to switch USB 2.0 extender modules are possible. 
1. An EXT Unit with USB 2.0 will be created and assigned to an already existing Device with existing KVM EXT 

Units (see section 6.8.3, page 108 or section 6.9.3, page 123). 
2. A separate Device for the EXT Unit with USB 2.0 will be created without assigning a KVM EXT Unit to that 

Device. This possibility offers a separate switching of the USB 2.0 signal (see section 6.8.1, page 108 or 
section 6.9.1, page 122). 

 

 Switching of USB 2.0 signals uses Extended Switching functionality (see section 7.1.1, page 178). 
When using parallel operation within the matrix, set the Release Time in the System Settings > Switch menu to 
10 s or more (see section 6.5.6, page 48). Otherwise, the connection of the USB 2.0 extender module will not be 
established due to security and stability reasons. 
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7.1.3 Defining Switch Presets 
Switch presets to switch the matrix without loading a new configuration can be created and activated in this menu. 
This is a function of the Tera Tool software, not of the matrix. The presets are locally saved on your computer. 
1. Click Control > Presets in the task area. 

2. Click  (New) in the right column of the working area to open a new switch preset. 
3. You are asked if the existing connections should be taken over for the new switch preset. When you click Yes, 

the table contains the existing connections as shown in Fig. 178. When you click No, the CPU Device columns 
are empty. 

 

 

Fig. 178 Menu Control - Presets - New switch preset opened 
 

4. To set a connection for a CON Device, click in the line of the CON Device in the column of the desired 
connection type (Full Access, Video Only or Private Mode). The drop-down menu that appears contains all 
possible CPU Devices and the entry Disconnect CPU. 

5. Click on the desired CPU Device to set the connection type or on Disconnect CPU to disconnect the CON 
Device. 

 When you leave a line empty, the connection of the corresponding CON Device remains unchanged upon 
executing the preset. 
 

6. Click  (Save) in the right column of the working area to save the created switch preset. 
A save dialog appears. 

7. Enter a name for the new switch preset. 
8. Click Ok in the save dialog to confirm the new preset. 

The new switch preset is listed in the right column. The bottom of this column contains information about the 
preset and the current configuration of the matrix. 
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Copying a Switch Preset 
1. Click Control > Presets in the task area. 
2. Right-click on a switch preset in the right column and click the Save as... option in the context menu. 
3. Enter a name for the copied switch preset and click OK. 
 

Deleting a Switch Preset 
1. Click Control > Presets in the task area. 
2. Select the switch preset to be deleted. 

3. Click  (Delete) in the toolbar to the column Presets to delete the current switch preset or right-click the switch 
preset and click the Delete... option in the context menu. 

4. Confirm the deletion. 
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7.2 Restarting and Powering down Functions via Tera Tool Software 
NOTICE 

Possible damage of boards or the matrix 
The file system check phase when the matrix is restarted (indicated with 2x white LEDs) is a very sensitive 
process. 
If the matrix is switched off while restarting, the respective boards may be damaged in its function. 
 Do NOT power off the matrix while the file system is being checked. 

 

NOTICE 

Possible loss of the current configuration 
If the matrix is restarted or shut down (indicated with 1x off/1x yellow LEDs), the current configuration is saved. 
If the matrix is powered off while shutting down or restarting, the matrix may restart with factory settings. 
 Do NOT power off the matrix while shutting down or restarting. 

 

7.2.1 Restarting the Matrix or Matrix Grid 
To perform a restart of the matrix, proceed as follows: 
1. Click Device > Advanced Service > Restart Matrix in the menu bar. 

An access window appears. 

 

 

Fig. 179 Dialog Log in administrator 
 

2. Enter the username and password of an administrator. 
3. Click Ok. 

A query to restart the matrix appears. 

 

 

Fig. 180 Dialog Restart Matrix  
 

4. Click Yes to restart the matrix. 
The current configuration is saved in the permanent memory of the matrix, and the matrix will be restarted. 

 

 If using this function in a matrix grid, the complete matrix grid will only be restarted when the master matrix is 
restarted. In the case of redundant controller boards, both controller boards will restart. 
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7.2.2 Restarting the Controller Board 
To perform a restart of the controller board, proceed as follows: 
1. Click View > Matrix in the task area. 
2. Click with the right mouse button on the symbol of a network port of the controller board to be restarted. 

A context menu appears. 
3. Click the Restart Controller Board function in the context menu. 

 

 

Fig. 181 Menu View - Matrix - Restart Controller Board 
 

An access window appears. 

 
Fig. 182 Dialog Log in administrator 
 

4. Enter the username and password of an administrator. 
5. Click Ok. 

The controller board is restarted, and the symbols of the network ports are red for a short time in the overview. 
When the symbols of the network ports are green again, the restart of the controller board was successful. 
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7.2.3 Restarting an I/O Board 
1. Click View > Matrix or View > Port in the task area. 
2. Click with the right mouse button on the symbol of any port of the I/O board to be restarted. 

A context menu appears. 

 

 

Fig. 183 Menu View - Matrix - Restart I/O Board  
 

3. Click the Restart I/O Board function in the context menu. 
 

A query to restart the I/O board appears. 

 
Fig. 184 Dialog Restart I/O Board  
 

4. Click Yes to restart the selected I/O board. 
The I/O board is restarted, and the I/O board will disappear for a short time in the overview. When the I/O board 
and the extender modules are visible again, the restart of the I/O board was successful. 
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7.2.4 Restarting an Extender Module 
There are two possibilities to restart an extender module. 

Possibility 1 
1. Select View > Matrix or View > Port in the task area. 
2. Click with the right mouse button on the symbol of the extender to be restarted. 

A context menu appears. 

 

 

Fig. 185 Menu View - Matrix - Restart Extender  
 

3. Select the Restart Extender function in the context menu. 
 

 Note: The extender module will be restarted immediately without user confirmation. The extender module symbol 
will disappear for a short time in the overview. When the symbol is visible again, the restart was successful. 
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Possibility 2 
1. Select Extender & Devices > EXT Units in the task area. 
2. Click Activate Edit Mode in the toolbar. 

 

 

Fig. 186 Menu Extender & Devices - EXT Units  
 

3. Select the EXT Unit in the EXT Units list whose extender module has to be restarted. 
4. Click Restart Extender Module in the lower part of the working area. 

A query for the restart appears. 

 

 

Fig. 187 Dialog Extender & Devices - Restart Extender  
 

5. Click Yes to restart the extender module. 
The port number of the EXT Unit will show 0 for a short time. When the correct port number appears again, the 
restart of the extender module was successful. 

6. Click Deactivate Edit Mode in the toolbar. 
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7.2.5 Powering Down the Matrix 
 In a matrix grid, all matrices shut down when you shut down the master matrix. 

 

To shut down a matrix, proceed as follows: 
1. Select Device > Advanced Service > Shut down Matrix in the menu bar. 

An access window appears. 

 

 

Fig. 188 Dialog Log in administrator 
 

2. Enter the username and password of an administrator. 
3. Click Ok. 

A query to shut down the matrix appears. 

 

 

Fig. 189 Dialog Shut down Matrix  
 

4. Click Yes to start the shutdown. 
The current configuration is saved in the permanent memory of the matrix, and the matrix will be shut down. 
After shutting down, a notification to power off the matrix appears. 

 

 

Fig. 190 Notification Switch off Matrix  
 

5. Click OK and switch off the matrix using the power switch at the rear panel. 
 

NOTICE 

When the matrix has been shut down but not switched off, the fans run uncontrolled with maximum speed and 
noise. 
 Do not forget to switch off the matrix using the power switch at the rear panel. 

 



Draco Tera Tool Tera Web Control 

189 

8 Tera Web Control 
Tera Web Control is a possibility to switch KVM signals within a Draco tera matrix system via web browser. 

8.1 Preconditions and Requirements  
Hardware 
All components of the matrix (controller board, I/O boards) have to be of the new generation, that means: 

• All Draco tera flex devices are supported. 

• Only Draco tera enterprise devices with new components are supported. 

• Draco tera compact devices are not supported at all.  

• Only one matrix is supported so far. 
Firmware 

• Matrix firmware version F05.04 or higher is required (firmware parts: MATLCPU, MATLIO8). 

• Matrix firmware part WEBCTL is required (minimum version: 01.02) 
License 

• To use Tera Web Control at least 1 license is required. 
Configuration 

• Tera Web Control function is an option and has to be activated manually. 
 

8.1.1 How to Check Firmware and License 
1. Start the Tera Tool software and connect to the matrix. 
2. Click Status & Updates > Status Matrix Firmware in the task area.  

 

 

Fig. 191 Menu Status & Updates - Status Matrix Firmware 
 

3. Click Status & Updates > Miscellaneous in the task area. 
4. Click the License Management tab. 
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Fig. 192 Menu Status & Updates - Miscellaneous - License Management 
 

8.1.2 Activating Tera Web Control  
5. Click Activate Edit Mode in the toolbar. 
6. Click System Settings > Network in the task area.  

 

 

Fig. 193 Menu System Settings - Network 
 

7. Under the heading Network Services in the lower part of the window, tick the checkbox Web Control. 
8. Restart the controller board (see section 7.2.2, page 185); it is not necessary to restart the matrix. 
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8.2 Opening and Closing a Connection 
1. Connect a laptop or touch panel to the controller board of the matrix using a Cat X cable or use a WiFi 

connection. 
2. Open a browser and type in the IP address of the controller board of the matrix. 

 

 

Fig. 194 Connecting to the matrix  
 

3. Press the Enter key. 
The following input mask appears. 

 

 

Fig. 195 Login to Tera Web Control  
 

4. Enter username and password. It is also possible to enter only a username that has no password assigned to.  
5. Click on the button Login. The following window appears. 

 

 

Fig. 196 Tera Web Control - Landing page 
 

The access rights are automatically adopted from the matrix and cannot be changed. Super, power and standard 
users without assigned layouts cannot log in (only administrators can). 
6. To close Tera Web Control, click on the arrow down head in the upper right-hand corner and then on Logout. 

 If you close the browser without logging out, it can take up to 2 minutes until the license/connection is released. 
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8.3 Configuration of Tera Web Control 
8.3.1 General Settings 
1. Move the mouse pointer over the arrow down  in the upper right-hand corner.  
2. In the pop-up menu click Settings. 

 

 

Fig. 197 Tera Web Control - Setting options 
 

The following options are available: 

Option Entry Description 
Language Button Selection of a language, a change here will be immediately executed. 

Show Layouts Panel Activated Displays the layout names at the bottom of the Tera Web Control window. 

Deactivated Function not active. 

Show Presets Panel Activated Displays the presets panel on the right-hand side of the Tera Web Control 
window (when Switch View is deactivated). 

Deactivated Function not active. 

Switch View Activated Displays the presets panel on the left-hand side of the Tera Web Control 
window (and the CPU selection list on the right-hand side). 

Deactivated Function not active. 

Show Legend Activated Displays a legend of colors and symbols for screens at the bottom of the 
left column. 

Deactivated Function not active. 

Layout Magnet 
Enabled 

Activated Enables magnetic function between screens in the layout editor. 

Deactivated Function not active. 
 

3. Choose the desired language and activate the desired options. 
4. Click the button Close. 
You can at any time activate/deactivate the following options with buttons in the uppermost line: 

Button Option 

 Show Layouts Panel 

 Show Presets Panel 

 Switch View 
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8.3.2 Creating Layouts 
1. Move the mouse pointer over the arrow down  in the upper right-hand corner.  
2. In the pop-up menu click Layout Designer. 

 

 

Fig. 198 Tera Web Control - Layout Designer, no layout selected 
 

The symbols in the uppermost line of the column on the left side have the following meanings: 

Symbol Description 

 Copies the selected layout. 

 Creates a new empty layout. 

 Deletes the selected layout after confirmation. 

 
There are two ways to create a new layout: 

- Creating a new, completely empty layout. 
- Copying an existing one and changing the name. 

 Click the symbol  above the list of layouts to create a new, empty layout. 
 
or 

 Click on an existing layout in the Layouts list to select it and click the symbol  to copy it. 
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Fig. 199 Tera Web Control - Layout Designer, new layout created 
 

1. Enter a name for the new layout in the field Layout Name. 
2. Set Ratio and Orientation for the screens. The selected values remain until you change them. 
3. Enter a value for Width; the Height is automatically set according to the ratio. 
 

 The width of a screen must be at least 36 pixels. Screens smaller than this size cannot be processed. 
 

4. Select CON Devices in the list and drag and drop them to the grey area. You can arrange them freely as you like. 
 

 The size of the screens in relation to the overall grey area is insignificant since the display later in the browser is 
automatically adapted to the window (automatic zoom). 
 

5. Click the button Copy in the line below the grey area to copy the selected screen and Paste to paste it into the 
grey area. 

6. Click the button Delete to delete the selected screen. 
7. Save the layout by clicking Apply Layout in the bottom right-hand corner. 
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8.3.3 Assigning a User to a Layout 
At least one user has to be assigned to a layout. Different user types have different rights as stated in the following 
table. 
 Administrator Super User Power User Normal User 
Can use Layouts and Presets     
Can switch in Private Mode   - - 
Can disconnect a Private Mode connection   - - 
Can log in without an assigned Layout  - - - 
Can restart the Web Control service  - - - 
Can manage TLS Certificate  - - - 
User ACL can be limited - -   
ACL can be limited by Login Lock option - -   
Limited switching options if user ACL are 
active (requires login at CON unit) - - -  

 
1. Click User Assignment in the menu line. 

The settings here are only taken into account if the global user ACL is not active and the Allow User ACL option 
is active on the CON device. 

 

 

Fig. 200 Tera Web Control - User Assignment  
 

2. Select a User in the User available list that you wish to assign to the layout. By pressing and holding down Ctrl 
at the same time, more than one user can be highlighted. 

3. Click  to move the highlighted users to the User assigned list. By clicking , all users from the User available 
list will be moved. 

The User available list features a filter function (see section 5.6, page 28). 
4. Click Apply Layout to confirm the settings or continue to create presets for the layout. 
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Some information on access rights – User ACL versus CON ACL 
- You can use either User ACL or CON ACL. A combination of both is not possible.  
- CON ACL or User ACL has to be activated globally (via System Settings > Access). 
- Options for access rights: 

a) If User ACL or Force User Login is active, access 
rights and favorites of the logged in user are valid 
(user who is logged in at Tera Web Control). 
 

b) If User ACL and Force User Login are deactivated and CON ACL is 
active, access rights and favorites of the CON you want to switch are 
valid. 

 
c) If CON ACL, User ACL and Force User Login are deactivated, 

access rights will be ignored and favorites of the CON you want to 
switch are valid. 

 
d) If at the CON Device the option Allow User ACL is active, a standard 

user has to log in at the CON unit. Power users do not have to log in 
and their user access rights are valid. 
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8.3.4 Creating Presets for a Layout 
1. Click Presets in the menu line.  

 

 

Fig. 201 Tera Web Control – Creating a Preset  
 

Symbol/Character Description 

 Creates a copy of the selected preset. 

 Creates a new preset 

 Deletes the selected preset. 

- Nothing happens; the CON Device remains in its current state. 

D The CON Device is disconnected from the CPU Device. 

F The CON Device is switched in Full Access mode to the selected CPU Device. 

V The CON Device is switched ín Video only mode to the selected CPU Device. 

P The CON Device is switched in Private mode to the selected CPU Device. 
 

2. Click on the symbol  to create a new preset. 
3. Enter a name for the preset in the corresponding field. 
4. Click the arrow down in the selection field in the column CPU Device of a CON Device. A list with suitable CPU 

Devices appears. 
5. Select the desired CPU Device. The radio button F (Full Access) is automatically selected. Click V (Video Only) 

or P (Private) if possible, to change the connection mode. 
6. You can disconnect a CON Device by selecting the radio button in column D. By selecting -, the CON Device 

remains in its current state when the preset is executed. 
7. After having created all the presets, click on Apply Layout. 
The creation of one layout is finished. You can create as many layouts as you like.  
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8.3.5 Importing/Exporting Layouts 
1. Click the button Export Layouts in the bottom left-hand corner.  

All layouts are downloaded onto your computer in one file named default.wcl. 

 

 

Fig. 202 Tera Web Control – Export of layouts  
 

2. Click the button Import Layouts.  
The Open Dialog appears. 

3. Go to the location of an export file (*.wcl). 

4. Select the desired *.wcl file and click Open in the dialog. 

A message appears. 
 

 

 

Fig. 203 Tera Web Control – Import of layouts  
 

5. Click Yes if you really want to import the layouts. All existing layouts will be deleted. 
6. Click No when you want to keep the existing layouts and abort the import process. 
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8.4 Operation using Tera Web Control 
8.4.1 Selecting a Layout 

The layouts for any user are predefined by an administrator and cannot be changed. The button  in the 
uppermost line switches the display of layout buttons on and off. They appear in a row at the bottom of the display. 
The first one is highlighted and displayed in the main area.  
1. Click the desired layout button. 
 

 

 

Fig. 204 Tera Web Control - Layout buttons  
 

 

8.4.2 Switching an Individual CON Device 
1. Click on the screen of the CON Device in the layout you want to switch. 

A list with available CPU Devices opens on the left-hand side. With the button  in the uppermost line, the 
location of the CPU list can be toggled between left and right.  

 

 

Fig. 205 Tera Web Control - Switching of CON Device to CPU Device 
 

2. Filter the CPU list if necessary. 
2.1. Enter a search name (is remembered for further switching). 
2.2. Switch between All (CPUs) and Favorites (is remembered for further switching) by clicking on the 

respective button. 
3. Click a CPU Device in the list or the button Disconnect CON. When you click a CPU Device, a popup window 

with switching options appears. 
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Fig. 206 Tera Web Control - Switching Options 
 

 Only administrators and super users can switch to a CPU Device in Private Mode. For power and standard users, 
the button Private Access is not visible. 
 

4. Click on one of the available options.  
The switching is executed directly, and a message appears for a few seconds in the lower part of the display. 

 

 

Fig. 207 Tera Web Control - Switching executed  
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8.4.3 Switching via Preset 
The Presets are predefined by an administrator and cannot be changed. They are listed on the right-hand side. If not, 

click the button  in the uppermost line. With the button  the location of the Presets list can be toggled 
between left and right. 
 

1. Click a Preset. 
When Preview is active (default setting), the status is displayed in the main area as if the Preset were executed 
and the buttons in the lower right-hand corner are enabled. 

 

 

Fig. 208 Tera Web Control - Preview of selected Preset  
 

2. To execute the Preset, click the button Apply Preset. 
3. Click the button Cancel to go back to the original display. 
When Direct is active instead of Preview, a Preset will immediately be executed after clicking it without further 
prompting. 
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9 Maintenance via Tera Tool Software 
9.1 Sending an OSD Message to CON Devices 

 In case a maintenance for a CPU/CON Device is required in operation mode, the respective user can be informed 
by an OSD message on the monitor of its CON Device. Sending a message is described using a CON Device 
selection as an example 
 

1. Click Extender & Devices > CON Devices in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Click Send OSD Message to… below the CON Devices list 

A dialog to create a message appears. 

 

 

Fig. 209 Menu Extender & Devices - CON Devices - Send OSD Message to… - Message  
 

4. Enter your message in the Message field (maximum 62 characters). 
5. Select the value in Display Time [sec] to set the display time of the message. 
6. Click Next >. 

 

 

Fig. 210 Menu Extender & Devices - CON Devices - Send OSD Message to… - Select CON Devices  
 

7. In the Available list, select the CON Device which should receive the message. By pressing and holding down 
Ctrl at the same time, more than one CON Device can be highlighted. 
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8. Click  to move the highlighted CON Device(s) to the Send message to… list. By clicking , all CON Devices 
will be moved to the Send message to… list. 

9. To remove highlighted CON Device(s) from the Send message to… list, click . By clicking , all CON Device(s) 
will be removed from the Send message to… list. 

10. Click Finish. 
The message is immediately sent to all selected CON Device(s). 

11. Click Deactivate Edit Mode in the toolbar. 
 
 

9.2 Replacing Extender Modules 
 The physical replacement has to be performed before unassigning an extender module and assigning another 

extender module. We recommend deactivating the function Auto Config before starting to replace the module. 
 
The replacement of extender modules for CON/CPU Devices is described using a CPU Device as an example. 
1. Click System Settings > System in the task area. 
2. Click Activate Edit Mode in the toolbar. 
3. Deactivate the function Auto Config if necessary. 
4. Disconnect the old extender module from the matrix and connect the new one to the same port. 
5. Click Extender & Devices > CPU Devices in the task area. 
6. Select the CPU Device whose assigned extender module (EXT unit) was replaced. 
7. Click Extender Replacement below the CPU Device list. An unassign/assign dialog appears. 

 
 1 2 
Fig. 211 Menu Extender & Devices - CPU Devices - Extender Replacement - Unassign EXT Unit  
 

1 EXT Unit of new extender (not assigned to a device because Auto Config is not active)  
2 EXT Unit of disconnected extender 

 
 

 
8. Select the EXT Unit of the disconnected extender module in the EXT Units Assigned list. 
9. To remove the highlighted extender module from the EXT Units Assigned list, click . 
10. Click Next >. Step 2 appears. 



Maintenance via Tera Tool Software Draco Tera Tool 

204 

 
Fig. 212 Menu Extender & Devices - CPU Devices - Extender Replacement - Assign EXT Unit 
 

11. Select the EXT Unit of the new extender module from the EXT Units Available. 
12. Click  to move the highlighted EXT Unit to the EXT Units Assigned list. 
13. Click Finish. 

The new extender module is assigned to the CPU Device. 
14. Click Deactivate Edit Mode in the toolbar. 
 
  



Draco Tera Tool Maintenance via Tera Tool Software 

205 

9.3 Querying a Status via Tera Tool Software 
9.3.1 Device Status 
The connections to the matrix are displayed in this menu. 
 Click View > Matrix in the task area to display the current connections. 

 

 

Fig. 213 Menu View - Matrix 
 

 If a port is currently selected, the port is shown with four static blue squares. All other ports are greyed out, except 
those connected to the currently selected port. 
A selection can be cleared by clicking Clear Selection in the lower part of the panel on the right side of the working 
area or by clicking in any empty area. 
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9.3.2 Port Status Matrix Grid 
In this menu the connections and the switching status between the various CON and CPU Devices are shown within 
the matrix grid. 
The port view is divided into different grid matrices. As a result, each matrix is displayed in an optimized view of 
24 ports per line to be able to also show a larger number of ports. 
 Click View > Port in the task area to display the current connections. 

 

 

Fig. 214 Menu View - Matrix  
 
Another possibility is to click View > Grid which shows an overall view of the complete matrix grid. 
 

 Functions, colors, and symbols used in the Port or Grid View are identical to those in the port status of the Matrix 
View see section 5.1.2, page 23. 
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9.3.3 Network Status 
 Put the mouse pointer over a network port of the controller board without clicking.  

The corresponding network status will be displayed in a small box or 
 

 Click on a network port of the controller board. 
The network status will be displayed in the upper right-hand corner permanently. 

 

 

 

Fig. 215 Menu View - Matrix - Network Information Box 
 

The following information is available: 

Entry Description 
IP Address IP address if DHCP is not active. 

Subnet Mask Subnet mask if DHCP is not active. 

Gateway Gateway address if DHCP is not active. 

MAC Address MAC address. 

Status Connected when shown in green, not connected when shown in red. 
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9.3.4 Matrix Firmware Status 
The firmware status of the components of the matrix is displayed in this menu. 
 Click Status & Updates > Status - Matrix Firmware in the task area to query the current firmware status. 

 

 

Fig. 216 Menu Status & Updates - Status - Matrix Firmware  
 
The following items are displayed: 

Column Description 
Slot Slot number of the I/O board or controller board 

Name • Name of the matrix or I/O board. 
• Name of the chassis firmware or I/O board firmware. 

Type Type of the firmware 

Ports Number of ports. 

Serial Number Serial number of the I/O board or controller board 

Version Installed firmware version. 

Status Status of the chassis or I/O board. 
 
The tree view can be expanded and collapsed by clicking with the left mouse button once on the + and - symbols in 
the Name column to show and hide detailed information. 
By clicking with the left mouse button once on the + and - symbol in the upper right corner of the working area, you 
can expand and collapse all information in the tree view.  
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9.3.5 Extender Module Firmware Status 
Information about extender modules and their firmware versions are contained in this menu.  
1. Click Status & Updates > Status - Extender Firmware in the task area. 

The Extender View is displayed. 
The tree view can be expanded and collapsed by clicking with the left mouse button once on the + and - symbols in 
the ID column to show and hide detailed information. 
By clicking with the left mouse button once on the + and - symbol in the upper right corner of the working area, you 
can expand and collapse all information in the tree view. 
 

 

 

Fig. 217 Menu Status & Updates - Status Extender Firmware - Extender View 
 

The following information about the extenders is displayed:  

Column Description 
ID Serial number of the extender module 

Name Name of the EXT Unit 

Port Port number of the matrix the extender module is physically connected to. 

Type Type of extender module (CON or CPU Unit) 

Device Name of the CON Device/CPU Device the EXT Unit is assigned to. 

Version Installed firmware version of each component 
 
2. Click on the button Component View to display the firmware versions of the different components in another 

way (see figure on next page). 
3. Click the button Extender View to go back to the display as illustrated in the figure above. 
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Fig. 218 Menu Status & Updates - Status Extender Firmware - Component View 
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9.3.6 Extender Module Firmware Status on I/O Board 
The extender modules firmware currently stored in the memory on the I/O board via extender module firmware 
update in Parallel Mode is displayed with its name, type, and version in this menu. The firmware can be passed to 
the extender modules if necessary, using the update step 2 of the Parallel Mode (see page 226). 
1. Click Status & Updates > Status - Extender Firmware in the task area. 
2. Click the Extender Firmware Status on I/O Board tab in the working area. 
The tree view can be expanded and collapsed by clicking with the left mouse button once on the + and - symbols in 
the Name column to show and hide detailed information. 
By clicking with the left mouse button once on the + and - symbol in the upper right corner of the working area, you 
can expand and collapse all information in the tree view. 
 

 

 

Fig. 219 Menu Status & Updates - Status Extender Firmware - Extender Firmware on I/O Board  
 
The following information is displayed: 

Column Description 
Slot Slot number of the I/O board 

Name Name of the I/O board and the extender module firmware 

Type Type of the I/O board and the extender module firmware 

Mem Usage/Version • Free memory on the I/O board (in MB) 
• Version of stored extender firmware 
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9.3.7 Syslog Monitoring 
The Syslog function can be used to log device (matrix, MV42, SIRA-CPU, SNMP boards) activities, switching 
operations and surveillance of the function of critical components like fans or power supply units according to the 
settings. During logging the activities are written continuously into log files and stored locally. 
Logging of system activities depends on the settings. With enabled option, the logging starts by default when the 
Monitoring tab is opened. Logging remains active as long as the tab is open but ends when the Tera Tool software 
is closed. 
 

NOTICE 

Syslog messages are transmitted via UDP. Therefore, the port used for Syslog messages within the network used 
should not be blocked, e.g., by a firewall. 

 

 The procedure for activating the Syslog function is described in section 6.5.9, page 54. 

 
To open the Syslog monitoring, proceed as follows: 
 Click Monitoring in the toolbar. 

The logged Syslog messages are displayed in the working area and are continuously recorded into a logfile. 

 

 

Fig. 220 Menu Monitoring - Syslog  
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Filter Function 
To filter relevant messages from the multitude of logged activities of the matrix, the extender modules and the 
chassis, the Syslog monitoring offers several filter options. 
 

To set and activate a filter, proceed as follows: 
1. Tick the respective checkbox(es) to set the desired filter option(s). 
2. Click Filter to apply the filter settings. 
3. Click Clear to reset the filter settings. 
 

The following filter options are available: 

Option Description 
Date Messages for a defined date range will be filtered. 

Facility Messages for a defined facility will be filtered. 

Severity Messages for a defined severity will be filtered. 

Host Messages for a defined host will be filtered. 

Message Messages with defined text parts will be filtered. 

App Name Messages of a defined app will be filtered. 

Proc ID Messages of a defined Proc ID will be filtered. 

Msg ID Messages of a defined Msg ID will be filtered. 
 

 Filter options are not valid within the locally stored log files. 

 

Recording Function 
Several options are available for the messages displayed in the Syslog file. 
 To save the displayed messages (filtered or unfiltered), click Save trace. 

The messages are saved in a Syslog file (file extension: *.csv). 

 To clear the view with the displayed messages, click Clear trace. 
The recorded messages will be kept. 

 To pause the display of messages, click Pause. 
During the pause, the messages will be recorded continuously. 

 To display the messages recorded in the background during the pause, click Pause again. 
All messages recorded in the background will be displayed immediately. 

 
  



Maintenance via Tera Tool Software Draco Tera Tool 

214 

Find Function 
The find function can be used to find specific Syslog messages from a variety of logged activities and relevant 
messages from the matrix, extender modules, and chassis. 
 

To find specific Syslog messages, proceed as follows: 
1. Click Monitoring in the toolbar. 
2. Click the Find tab in the working area. 

The filtered Syslog messages are displayed in the working area. 
 

 

 

Fig. 221 Menu Monitoring - Syslog - Example for search result  
 

3. Enter a search term in the Find Message search field. 
4. Click Find Next. 

The first message with the entered search term is highlighted. 
5. Click Find Next again to find another message with this search term. 

The next message with the entered search term is highlighted. 
6. To go back to the previous search result, click Find Previous. 
 

 Possible search terms would be, e.g., the port ID (e.g., Port=160), API, etc. Find Next and Find Previous will be 
swapped when the end is reached.  
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9.3.8 SNMP Monitoring 
The SNMP function allows all function-critical and safety-critical elements of the matrix, the extender modules, and 
the chassis to be monitored and queried. This function complies with the RFC 1157 conformal standard. 
 

NOTICE 

When using SNMP monitoring, for reasons of access security, the use of a dedicated network according to the IT-
Grundschutz-Kompendium (IT Baseline Protection) is recommended. The default read only community for the MIB 
file is kvm. This can be changed. 

 

 The procedure for activating the SNMP agent or configuring an SNMP server is described in section 6.5.10,  
page 57. 
 
To open the SNMP monitoring, proceed as follows: 
1. Click Monitoring in the toolbar. 
2. Click SNMP in the task area. 

The logged SNMP messages are displayed in the working area and are simultaneously recorded into a logfile. 

 

 

Fig. 222 Menu Monitoring - SNMP  
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Filter Function 
To filter relevant messages from the multitude of logged activities of the matrix, the extender modules and the 
chassis, the SNMP monitoring offers several filter options. 
 

To set and activate a filter, proceed as follows: 
1. Tick the respective checkbox(es) to set the desired filter option(s). 
2. Click Filter to apply the filter settings. 
3. Click Clear to reset the filter settings. 
 

The following filter options are available: 

Option Description 
Date Messages for a defined date range will be filtered. 

Severity Messages for a defined severity will be filtered. 

Host Messages for a defined host will be filtered. 

Type of Trap Messages for a defined trap will be filtered. 

Message Messages with defined text parts will be filtered. 
 

 Filter options are not valid within the locally stored log files. 

 

Recording Function 
Several options are available for the messages displayed in the SNMP log. 
 To save the displayed messages (filtered or unfiltered), click Save trace. 

The messages are saved in a SNMP file (file extension: *.csv). 

 To clear the view with the displayed messages, click Clear trace. 
The recorded messages will be kept. 

 To pause the display of messages, click Pause. 
During the pause, the messages will be recorded continuously. 

 To display the messages recorded in the background during the pause, click Pause again. 
All messages recorded in the background will be displayed immediately. 
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Find Function 
The find function can be used to find specific SNMP messages from a variety of logged activities and relevant 
messages from the matrix, extender modules, and chassis. 
 

To find specific SNMP messages, proceed as follows: 
1. Click Monitoring in the toolbar. 
2. Click SNMP in the task area. 
3. Click the Find tab. 

The recorded SNMP messages are displayed in the working area. 

 

 

Fig. 223 Menu Monitoring - SNMP - Example for search result  
 

4. Enter a search term in the Find Message search field. 
5. Click Find Next. 

The first message with the entered search term is highlighted. 
6. Click Find Next again to find another message with this search term. 

The next message with the entered search term is highlighted. 
7. To go back to the previous search result, click Find Previous. 
 

 Possible search terms would be, e.g., temperature, fan, or the serial number of an extender module (e.g., 
40131237). Find Next and Find Previous will wrap around when the end is reached. 
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9.3.9 Redundancy Function 
Extender modules with redundant ports for interconnection cables can be simultaneously operated with both ports at 
a single matrix or a matrix grid (from firmware version V03.01). 
The ports labeled with Link 1 at the extender modules is meant for the primary interconnection. If the interconnection 
on CON Unit or CPU Unit side is interrupted due to any problem, the interconnection will be automatically re-
established through the second port labeled with Link 2. 
For this kind of redundancy function, there is no need for any configuration of the matrix or the extender modules. 

 By default, the matrix switches automatically between both links when this function is active. Manual switching is 
not possible. For manual switching by key command or API command, the redundancy function must be deactivated. 
 

 

 

 

Fig. 224 Menu View - Matrix  
 

To check the connection status of the redundant extender modules, proceed as follows: 
1. Click View > Matrix in the task area. 
2. Tick the Show Redundant Links (L1/L2) checkbox under Routing Information on the right side of the working 

area. 
3. Expand the Redundancy menu in the panel on the right side of the working area to receive the respective 

legend information. 
Redundant ports are highlighted in the matrix view with L1 and L2. The respectively active link is highlighted with 
a light green label. 
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9.3.10 System Check 
The system check offers a diagnostic function for checking the device configuration. The feature indicates non-
optimal as well as incorrect settings and displays issues instructions. The system check is only used to check 
plausibility and does not make any active configuration changes. 
The following configuration parts are checked: 

• Matrix Firmware 

• Extender Module Firmware 

• Multi-Screen Control 

• EXT Units 

• CPU Devices 

• CON Devices 

• Users 

• Macros 

• System Configuration 

• Matrix Grid 
 

The following notification levels can be shown: 

Level Description 
Info Information about system parts. 

Ok System checks completed without any abnormalities. 

Warning System checks revealed abnormalities in the configuration that point to incomplete parts 
of the configuration, firmware differences, duplications, or unconnected extender modules 
but without being system critical. 

Error System checks reveal errors in the configuration that can have both functional and 
system-critical influences on the system. 

 

NOTICE 

If the messages Warning or Error are generated by the system check function, the respective problem will be 
described, and an issue instruction will be provided. 

 

NOTICE 

The system check of the matrix may take several minutes. The KVM system and the Tera Tool software can be 
used without restrictions during this time. 

 
To start the system check, proceed as follows: 
1. Click System Check in the tool bar. 

A query appears to check the system. 

 
Fig. 225 Dialog Validate System  
 

2. Click Yes to start the system check. 
A report is displayed after the system check. 
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Fig. 226 Report System Check  
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9.3.11 Network Check 
The network check checks the availability of the ports available in the network. 

NOTICE 

Available ports are shown in green. If a port is not available, the corresponding entry appears in red, and 
instructions are displayed. 

 
To start the network check, proceed as follows: 
1. Click Extras > Network Check in the menu bar. 

A query appears with an input field for the IP address of the matrix to be queried. 
2. Enter the IP address of the matrix. 
3. Click Start network check to start the network check. 

The availability of the ports is shown after a short moment. 

 
Fig. 227 Dialog Network Check - Available ports  
 

 Reasons for unavailability of network ports are often: 
- The firewall blocks the connection. 
- The service is not activated in the matrix network configuration (see section 6.5.7, page 50). 
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9.4 Updating the Matrix Firmware 
NOTICE 

To process successful firmware updates and avoid failures: 
 Only use computers to update the matrices that are not integrated into the KVM system. 
 Ensure that the computer used for the update is not set into standby mode or sleep mode during the update. 
 Save your configuration locally before starting the update. 
 Proceed an update via wired LAN connection for reasons of network stability. 

 

NOTICE 

Ensure that all USB 2.0 extender modules are only connected to the provided ports (fixed ports) before you start 
the matrix update. Non-compliance may affect the stability of the update. 

 

NOTICE 

Possible firmware update interrupt with IP gateway boards or IP gateway modules: 
If disconnecting/connecting a plug from/to the IP gateway port during the firmware update of this board or module, 
the update process is disrupted. 
Do not disconnect/connect the IP gateway while updating the firmware of the IP gateway board/module. 

 

 The firmware update of MATLOS.tfw has to be performed step by step. After each firmware update, the matrix 
has to be restarted, e.g., if you want to update your current firmware MATLOS version F01.05 to F01.08, proceed as 
follows: 
 Update with version F01.06 and restart the matrix. 
 Then update with version F01.07 and restart the matrix. 
 Then update with version F01.08 and restart the matrix. 
 

 If required, the update files can be requested from the TechSupport department. 

 
The firmware of the matrix can be updated in this menu. 
 

 

 

Fig. 228 Menu Status & Updates - Update Matrix Firmware  
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The following information is displayed in the working area: 

Option Description 
Name • Name of the chassis or I/O board. 

• Name of the chassis firmware or I/O board firmware. 

Type Type of the chassis firmware or I/O board firmware 

Current Version Installed firmware version 

Update Version Firmware version available for the update 

Status Module availability 

Update Selected/deselected for firmware update 
 
The following options are available in the Additional selection options drop-down menu on the right upper side in 
the working area: 

Option Description 
Expand Tree View Expand the tree view to show detailed information. This allows you to select or deselect 

individual firmware to be updated. 

Collapse Tree View Collapse the tree view to hide detailed information. An individual selection of firmware to 
be updated is not possible. 

Select All Select all available firmware to be updated. 

Deselect All Deselect all selected firmware. 
 

 When a firmware file is loaded, an additional entry appears for each suitable type of firmware, e.g., Select 
MATLOSD. 
 
 
Preparation 

 If the Syslog function has not been set yet, we recommend activating the Syslog function (see section 6.5.8, page 
52) before updating the firmware to log the update in case of update errors. 
  

 We recommend using a central location for firmware files, e.g., by using the Tera Tool software’s option menu 
under Extras > Options > Default Settings > Firmware Directory. 
 

 

Performing the Update 

NOTICE 

Possible damage of boards or the matrix 
A running update process (indicated with 2x white LEDs) is a very sensitive process. 
If the matrix is switched off while an update process is running, the respective boards and the matrix will be 
damaged in their function. 
 DO NOT power off the matrix while an update process is running. 

 
To update the matrix firmware, proceed as follows: 
1. Click Status & Updates > Update - Matrix Firmware in the task area. 
2. Click the button Browse to select a firmware file. 

All updateable components of the matrix will be automatically selected and highlighted in green. 
3. Click Update in the lower part of the working area to start the update. 
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A query to save the matrix status appears. 

 
Fig. 229 Dialog Save matrix status 
 

 Depending on the firmware type to be updated, the matrix may not be available during the update process. 
 

4. Click Save Matrix Status to save the matrix status locally or click Skip if the status is already saved. 
5. The progress of the update is displayed in the working area. 

After the update, a query to restart the matrix appears. 
 

 
Fig. 230 Dialog Restart matrix 
 

6. Click Yes to restart the matrix. 
 

Restarting the matrix may take several minutes, and the matrix is not available during the restart. The updated 
firmware is displayed in the working area. 

 
Updating Matrices in a Matrix Grid 
We strongly recommend the following procedure: 
1. Update all sub matrices without restarting them. 
2. Update the master matrix and restart it. All submatrices will also be restarted. 
 

NOTICE 

If any error messages appear during the update process, the matrix and the entire grid should under no 
circumstances be restarted. Repeat the update step and if an error appears again, contact the manufacturer’s 
technical support. 
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9.5 Updating the Extender Module Firmware 
9.5.1 Updating the Extender Module Firmware via Matrix 
To update connected extender modules via matrix, the extender modules have to be connected to the matrix with 
interconnection port 1. Most firmware parts of the extender modules can be updated via matrix, except for the 
xxxMSD firmware type that has to be updated via Mini-USB service port if necessary. 
 

 An update of the xxxMSD firmware is usually not necessary. In rare cases, an update may be necessary to 
expand the functionality of certain extender modules for specific requirements. In this case, please contact the 
manufacturer’s technical support in advance. 
 

 If required, the update files can be requested from the manufacturer’s technical support. 
 

 Please refer to the user manual of the respective extender module if a manual firmware update of extender 
modules has to be performed. 
 

 

Preparation 

 If the Syslog function has not been set yet, we recommend activating the Syslog function (see section 6.5.8,  
page 52) before updating the firmware to log the update in case of update errors. 
  

 We recommend using a central location for firmware files, e.g., by using the Tera Tool software’s option menu 
under Extras > Options > Default Settings > Firmware Directory. 
 

 

NOTICE 

Possible failures when updating the extender module firmware 
In case the xxxMSD firmware part of one or more extender modules require an update, there may be dependencies 
between the new contents of xxxMSD firmware files and other extender module firmware files. In this case, 
installing other firmware files before updating xxxMSD firmware files could lead to failed updates. 
To process successful firmware updates: 
 Please check the release notes of the firmware package for dependencies between the extender module 

firmware files. 
 If you got information from the manufacturer’s technical support that an update of xxxMSD firmware files of 

certain extender modules is required, please update these firmware files via Mini-USB service port of the 
respective extender module (see next section 9.5.2). 

 
There are two possibilities to update the extender modules via matrix: 

• Parallel Mode: 
By default, used for parallel updates of several extender modules. 
The extender modules of all selected I/O boards are updated in parallel. 
Advantage: The Parallel Mode offers the fastest method for updating the extender modules. 

• Sequential Mode: 
Option to update extender modules sequentially, extender module by extender module, after the update of the 
previous extender module is completed. 
Advantage: The Sequential Mode offers the possibility to update individual extender modules and individual 
firmware parts of an extender module. This is useful for e.g. testing specific extender modules to verify whether 
the new firmware meets the requirements before installing it on all extender modules. 

 

 We recommend updating the firmware of the extender modules via Parallel Mode. 
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Performing the Update in Parallel Mode (Standard Update) 
Before the actual update process, all firmware files have to be uploaded to the respective I/O boards to which the 
extender modules to be updated are connected. 

Step 1: Uploading the new Extender Module Firmware to the Memory on the I/O Board 
Proceed as follows: 
1. Click Status & Updates > Update - Extender Firmware in the task area. 

The Parallel Mode for the standard update will be selected by default and the Upload Firmware tab will be 
opened. 

 

 

Fig. 231 Menu Status & Updates - Update Extender Firmware - Parallel Mode - Upload  
 

2. Click Browse to select and open the firmware file. 
If newer firmware is available, appropriate firmware parts will be automatically selected for the upload in the 
Selected column. 

3. Click Upload to start the upload and distribution of the update files. 

 By performing the upload process, no update files will be installed. The update process can be performed later.  
 

A query appears to update the extender module firmware upon finishing the upload process successfully. 
4. Click Yes. 

The Update Firmware tab will open immediately. 
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Step 2: Updating the Extender Module Firmware by passing the Extender Module Firmware from the Memory 
of the I/O Board on to the Extender Modules 

 When updating an identical or an older firmware version than the version currently installed, the Enable 
Downgrade checkbox in the upper part of the working area must be ticked. 
 

To update the extender module firmware via standard update, proceed as follows: 
1. Click Update to start the update. 

 Just before the update process, all I/O boards will be set into Service Mode and retrieved gradually after finishing 
the respective updates. During Service Mode, all matrix functions are disabled on the I/O boards on which an update 
is currently performed. An OSD picture indicates the activation of the Service Mode and is displayed on all monitors 
connected to those CON Units that are connected to the matrix. 
 

2. The progress of the update is displayed in the working area. 
3. Check the update messages in the message field after the update process to see if the updates for all extender 

modules have been installed correctly. 

 

 

Fig. 232 Menu Status & Updates - Update Extender Firmware - Parallel Mode - Update  
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Performing the Update in Sequential Mode (Expert Update) 
In Sequential Mode, individual firmware to be updated can be selected/deselected in this menu. 
 

1. Click Status & Updates > Update Extender Firmware in the task area. 
2. Select the Sequential Mode option in the upper part of the working area. 
3. Click Browse and select and open a firmware file. 

All updateable firmware will be automatically selected and highlighted in green. 

 

 

Fig. 233 Menu Status & Updates - Update Extender Firmware - Sequential Mode  
 
The following information is displayed in the working area: 

Option Description 
ID Serial number of the extender module 

Name Name of the EXT Unit and the extender module firmware 

Port Port number of the matrix the extender module is physically connected to 

Type Type of the CON/CPU Unit and firmware type 

Device Name of the CON Device/CPU Device the EXT Unit is assigned to 

Current Version Installed firmware version 

Update Version Firmware version available for the update 

Update Select/deselect for firmware update 
 

 Firmware types to be updated or firmware conflicts are highlighted in color: 
 Extender firmware version conflict 
 Manual update of EXTMSD/EXTIMSD recommended* 
 Wrong module (CPU/CON mismatch) 
 Undefined type 

* Only for firmware versions older than V2.25 (EXTMSD) and V1.13 (EXTIMSD) and only if instructed by the 
manufacturer's technical support or if the release notes indicate dependencies between extender module firmware 
files. EXT*MSD requires manual update via the Mini-USB service port at the extender modules 
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The following options are available in the Additional selection options drop-down menu in the upper right-hand 
corner of the working area: 
 

Option Description 
Expand Tree View Expand the tree view to show detailed information. This allows you to select or deselect 

individual firmware to be updated. 

Collapse Tree View Collapse the tree view to hide detailed information. An individual selection of firmware to 
be updated is not possible. 

Select All Select all available firmware to be updated. 

Deselect All Deselect all selected firmware. 
 
4. Click Update in the lower part of the working area to start the update. 
 

 In Sequential Mode the extender module that is being updated is set into Service Mode, all others continue to 
run and can be used. The I/O boards are not affected and continue to run. An OSD picture indicates the activation of 
the Service Mode and is displayed on the monitor connected to the CON Unit that is currently updated. This is a 
rather new function. With older matrix firmware, the complete I/O board with all connected extenders is set into 
Service Mode. 
 

After the update of the respective extender module is completed, the Service Mode of the extender module or of 
all extender modules will be quit. 

5. After the update, check the messages in the message box to ensure that the updates for all extender modules 
were installed correctly. 

 

 

Fig. 234 Menu Status & Updates - Update Extender Firmware - Sequential Mode  
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9.5.2 Updating the Extender Module Firmware via Mini-USB Service Port 
 

 
To perform a firmware update of extender modules using the Tera Tool software, proceed as follows. 
1. Run the Tera Tool software. 
2. Click Flash Update in the toolbar. 

 
Fig. 235 Flash Update - Start  
 

3. Click Extender Module Update via Mini-USB flash drive. 
The update dialog appears. 

 

 

Fig. 236 Flash Update - Search Extender Module  
 

4. Power up the extender module. 
5. Connect the extender module to the computer running the Tera Tool software using a Mini-USB cable. 
6. Click Search Extender Module. 

The flash drive of the connected extender module is displayed in the drive overview. 
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Fig. 237 Flash Update - Select Flash Drive 
 

7. Select the flash drive of the extender module. 
8. Click Next >. 

The identification of the extender module type automatically starts. 
After successful identification, the extender module specific firmware is displayed in the Status Log area. 

 

 

Fig. 238 Flash Update - Identification of Extender Module Type 
 

9. Click Next > after successful identification. 
 
  



Maintenance via Tera Tool Software Draco Tera Tool 

232 

 

 

Fig. 239 Flash Update - Update Extender Module - Select files  
 

10. Click Browse… to go to the location where the update files are stored. 
11. Select the desired update file and click Select in the selection dialog. 

The firmware available for the extender module is displayed. 
Firmware requiring any update will be automatically highlighted. 

 

 

Fig. 240 Flash Update - Update Extender Module - Load files  
 

12. Click Update to start the update process. 

 After the update of an MSD firmware, the extender module will automatically be restarted. 
 

A green highlighted message appears when the firmware update has been completed. 
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Fig. 241 Flash Update - Update Extender Module - Firmware update completed  
 

13. Click Next > to verify the update. 
14. Manually power off the extender module and power it on again. 

The extender module restarts, and validation begins automatically. The completion of the validation is displayed 
in the Status Log area. 

 

 

Fig. 242 Flash Update - Firmware Check - Firmware verification completed  
 

15. Click Finish. 
The firmware update of the extender module is completed. 
A dialog appears offering to update another extender module. 

16. Click Yes to update another extender module or click No and Finish to quit the Update dialog. 
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9.6 Resetting the Matrix and the I/O Boards 
9.6.1 Resetting the Matrix to the Factory Settings 

NOTICE 

If you perform a factory reset, all current settings and all configurations stored in the matrix will be lost. This also 
applies to the network parameters (reset to default IP address) and the admin password (default password: admin). 

 

NOTICE 

If a firmware update has been carried out since the delivery, the latest installed firmware version is retained. 
 
To perform a reset of the matrix, proceed as follows: 
1. Select Device > Advanced Service > Factory Reset > Factory Reset in the menu bar. 

 
Fig. 243 Device submenus  
 

An access window appears. 
2. Enter the username and password of an administrator. 
3. Click Ok. 

A query to reset the matrix appears. 
4. Click Yes to reset the device. 

The matrix restarts and is reset to factory settings. 
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9.6.2 Resetting a specified or all I/O Board(s) to the Factory Settings 
 

NOTICE 

If a firmware update has been carried out since the delivery, the latest installed firmware version is retained. 
 
To perform the reset of an I/O board, there are two possibilities: 

• Resetting a specified I/O board 

• Resetting all I/O boards 
 

Resetting a single I/O Board 
1. Select View > Matrix in the task area. 
2. Click with the right mouse button on any port of the I/O board to be reset. 

A context menu appears. 

 

 

Fig. 244 View - Matrix - Context menu  
 

3. Select the Factory Reset I/O Board function in the context menu. 
A query to reset the I/O board appears. 

 
Fig. 245 Dialog Factory Reset of one I/O Board 
 

4. Click Yes to reset the I/O board. 
The I/O board is reset to factory settings. 

 

Note: The I/O board will disappear for a short time in the overview. When the I/O board and the extender modules 
are visible again, the reset of the I/O board was successful. 
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Resetting all I/O Boards 
1. Select Device > Advanced Service > Factory Reset > Factory Reset of I/O Boards in the menu bar. 

 
Fig. 246 Device Submenus  
 

An access window appears. 
2. Enter the username and password of an administrator. 
3. Click Ok. 

A query to reset all I/O boards appears. 

 
Fig. 247 Dialog Factory Reset of all I/O Boards  
 

4. Click Yes to reset all I/O boards. 
All I/O boards are reset to factory settings. 
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10 Glossary 
The following terms are commonly used in this manual or in video and KVM technology. 

Term Description 
Auto Disconnect Matrix function that allows an automatic disconnect between a CON Device and a 

CPU Device if the OSD is opened via this CON Device. 

Auto Logout Matrix function that describes the duration of keyboard and mouse inactivity after the user 
has been logged out from the OSD at this CON Device and disconnected from the CPU 
Device. 

Cat X Interface to connect any Cat 5e (Cat 6, Cat 7) cable. 

CON Device Logical object that summarizes several EXT Units of physical extender modules (CON 
Units) to switch more complex sink systems via matrix. 

CON Timeout Matrix function that allows an automatic disconnect of the own CON Device from the 
connected CPU Device after a predefined time. 

CON Unit Decoder extender module to connect to the console (monitor(s), keyboard, and mouse; 
optionally also with USB 2.0 devices). 

Console Monitor, keyboard, mouse, media control, external switching solution, etc. 

CON ACL Console Access Control List is a list that shows the respective switching rights for the 
various CON Devices. 

CPU Auto Connect Matrix function that allows an automatic connection establishment between the own 
CON Device and a random CPU Device that is available. 

CPU Device Logical object that summarizes several EXT Units of physical extender modules (CPU 
Units) to switch more complex source systems via matrix. 

CPU Timeout Matrix function that allows the user to disconnect after a predefined period of inactivity 
from the respective CPU Device. 

CPU Unit Encoder extender module to connect to a source. 

DDC Display Data Channel (DDC) is a serial communication interface between monitor and 
source. It allows data exchange via monitor cable and an automatic installation and 
configuration of a monitor driver by the operating system. 

Dual Access A system to operate a source from two sinks (consoles). 

Dual Head A system with two video connections 

EXT Unit Logical object for representing and managing an extender module physically connected 
directly to the matrix. Add-on modules, if applicable, are included in the EXT Unit of the 
respective extender module. Dual head extender modules will be managed as two 
independent EXT Units. 

Fiber Interface to connect single-mode or multi-mode fiber cables. 

Force Connect Matrix function that allows you to switch with the own CON Device to a CPU Device that is 
already used and in doing so taking keyboard and mouse control. The connected 
CON Device so far loses K/M control but keeps video control. 

Force Disconnect Matrix function that allows you to switch with the own CON Device to a CPU Device that is 
already used and in doing so to take KVM control. The connected CON Device so far 
loses complete KVM control. 

HDMI An interface for all-digital transmission of audio and video data. 

KVM Keyboard, video and mouse 

Keyboard Connect Matrix function that allows taking over the keyboard control of an inactive CON Device. 

Macro Keys Programmable keys that can execute a stringing together of commands to the matrix. 

Mouse Connect Matrix function that allows taking the mouse control of an inactive CON Device. 

MTBF Mean Time Between Failure (MTBF) is measured in power-on hours. 
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Term Description 
Multi-mode 50 μm multi-mode fiber cable. 

MSC Control of USB-HID of up to eight sources at one sink with only one connected mouse or 
keyboard. The sink can consist of up to eight monitors, or up to sixteen monitors when 
operating dual head sources. In a matrix system, Multi-Screen Control (MSC) can be set 
up at multiple sinks. 

Non-Blocking Access Matrix configuration where no user can be disturbed by the activity of another user. 

OSD The On-Screen Display is used to display information or to operate a device. 

OSD Timeout Matrix function that closes the OSD automatically after a predefined period of inactivity. 

POH Power-on hours correspond to the average operating time 

Quad-Head A system with four video connections 

Release Time Matrix function that allows a CON Device that is connected with the same CPU Device to 
release the K/M control after a predefined time. 

Service Mode Defined maintenance condition that allows updating of extender modules that are 
connected to the matrix. 

SFP SFPs (Small Form Factor Pluggable) are pluggable interface modules for Gigabit 
connections. SFP modules are available for Cat X and fiber interconnect cables. 

Single Head A system with one video connection 

Single-mode 9 μm single-mode fiber cable 

Tie Line Communication connection in a cascading system of two matrices. 

USB-HID USB-HID devices (Human Interface Device) allow for data input.  
Typical USB-HID devices include keyboards, mice, graphics tablets and touch screens. 
Storage, video, and audio devices are not HID. 

User ACL User Access Control List is a list that shows the respective switching rights for the various 
users. 

Video Sharing Matrix function that allows switching from the user’s CON Device to any CPU Device with 
video. 
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13 Change Log 
This table offers an overview of the most important changes available through firmware updates, such as new functions, changed configuration or operation. 
 

Edition Date Software 
version 

Chapter New functions/changes 

Rev 0 2025-06-06 V 6.0.1.0 
2025-04-02 
Web Control 
1.2.0  

- 
 

Initial user manual, extracted from the matrix user manual, completely reworked, see Release 
Notes 
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